1. Registration issues have now been resolved. New accounts are able to be created

Official X8-H PLUS 009 firmware (20160328)

Discussion in 'NEO X8-H PLUS 009 firmware via MINIX FOTA' started by MINIX - Ken, Apr 9, 2016.

  1. Grippy Man

    Grippy Man Active Member

    any new firmware for x8-h plus ?
  2. Jeffers24

    Jeffers24 Active Member

    Preferably a Lollipop version
  3. Grippy Man

    Grippy Man Active Member

    lol, i would prefer a better fix-update in the same kitkat version.
  4. Jeffers24

    Jeffers24 Active Member

    But without Lollipop we will not be able to run Kodi Krypton and later Kodi versions.
  5. Grippy Man

    Grippy Man Active Member

    My choice is low end device needs less graphic-able or less hardware consumption systems. the more upgrade in android system has heightened the capability of multitasking which actually requires more hardware necessity. And, I'll be happy much with Kodi (basic) if it works without any issue.
    swamprat96 likes this.
  6. JaseM

    JaseM New Member

    Nice!

    [​IMG]

    Any ideas?

    Sent from my R2D2 using my C3P0 manservant
  7. Menorca Man

    Menorca Man Active Member Trusted Helper

  8. JaseM

    JaseM New Member

    Fixed by changing HDMI channel over to my Fire TV box and back again.

    Still can't get the PC to recognise the Minix box when in recovery mode though.

    Luckily, the Fire TV box is working well, so I foresee a long holiday in the obsolete computer stuff drawer very shortly.
  9. frutiloopis

    frutiloopis Member

    Any firmware update to my minix neo X8-H plus ?


    Enviado desde mi iPhone utilizando Tapatalk
  10. Turan1903

    Turan1903 New Member

    I don't seem to be able to update my minix 8X h plus. I don't have a windows pc therefore I am using a USB Stick to update which is FAT 32 formatted, I did even format the stick on a windows pc at work as I am not sure if OSX does really format in FAT32 or uses kind of a false fat 32.

    my box has following firmware right now: KOT49H.20141122

    I downloaded the zip file for FW009 through my box and put it on the stick and located it in the update whatsover app then selected the file and hit update. the box restarts and goes into this recovery like state where I chose apply update from EXT and then chose udisk. But the only information I get is:
    E: failed to mount /udisk (No such device)
    E: cannot mount /udisk (no such device)

    I read somewhere the file has to be named update.zip also tried that even though I didn't expect it to work as the box doesnt seem to be able to even mount my usb stick.

    I also tried all the other USB Slots or instead of the update app tried this thing pressing power while holding the reset button. Always the same outcome.

    my question is, could it be USB Stick related? I dont wann by another one and than figure out it still doesnt work, the same with SD Card, that one I cant use anyway and if it doesnt work its again money thrown away. Or could it be box related? Is it even possible to upgrade from my fw to the newest one? is that maybe the problem (even though I also tried to update to FW002 that didnt work either)?

    ther is also something called apply update from ADB, what is that? I chose it once and I think the box kind of froze nothing happened for 15 minutes so I pulled the power cable out.

    The whole thing is kind of frustrating.
  11. Villa

    Villa Well-Known Member Super Moderator

    You need to follow this guide...
    http://www.minixforum.com/threads/how-to-use-the-usb-zip-update-method-x6-x8-series-u1.6828/
  12. Turan1903

    Turan1903 New Member

  13. Turan1903

    Turan1903 New Member

    great company, when u need support you're told to use the forum and if you use the forum no one really cares about your problem and you only receive standard answers, not much more than telling people to turn off and on again their devices. and on top of all that the device is a piece of shit, which f..ing company sells devices in 2015 that cant be updated on the air?
  14. Villa

    Villa Well-Known Member Super Moderator

    You do not appear to be helping yourself!
    You really need to make sure the pendrive or SD card is cleanly and correctly FAT32 formatted. If it still doesn't work you need to try different ones.
  15. Turan1903

    Turan1903 New Member

    Yeah great solution i just buy one usb stick after the other and hope it will work before I get to the 20th or so. Thanks anyway
  16. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    You don't have to buy another stick for sure.

    Can you go into the recovery menu by holding the "Recover" key and powering up the device at the same time? Please also note that the USB stick should be attached to the device prior to entering the menu.

    The worst case scenario would be flashing a full system image from a PC.
    Villa likes this.
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We have a few fixes and updates and shall release an update on September as planned to.
    SJshah, sangaz, Jani and 3 others like this.
  18. Turan1903

    Turan1903 New Member

    As I wrote it before. Yes i can go into recovery menu as you say. I tried that 10 times or so on each usb port. I even formatted the usb again at work and tried again. It doesnt work and I dont have a pc.
  19. newbie99

    newbie99 Moderator Moderator

    @Turan1903
    Somehow you contradict yourself at post #110 or I misunderstand you... at the one hand you write "I downloaded the zip file for FW009 through my box and put it on the stick" and at the other hand you wrote "...the box doesnt seem to be able to even mount my usb stick." (or do you mean at recovery?)... Anyway...

    Because of "I did even format the stick on a windows pc..." did you remove the sick safety at windows? http://www.dummies.com/computers/op...7/how-to-safely-remove-hardware-in-windows-7/
    If you don't then this is often the problem at Android...


    btw: Why do you wrote at post #113 "which ***** company sells devices in 2015 that cant be updated on the air?" Do you never heard or read about the possibility to use the (F)OTA app to do updates "on the air"????

    I have to say I don't like every word you used at post #113 !!!!! That's not the way we like here at the forum....
    frutiloopis likes this.
  20. Turan1903

    Turan1903 New Member

    No I dont really contradict myself, the box can read my stick when running normally but for some reason it can't mount it in recovery mode. And thanks for the recommendation about the OTA, great Idea, just tell me how I do that on my FW001 and everything is great...