1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Only minix logo loading please help

Discussion in 'NEO U9-H' started by rusty718, Jul 31, 2018.

  1. rusty718

    rusty718 New Member

    i have had my device since feb and never had a problem now i just came back from vacation it worked fine the day i came back but the day after i tried turning it on and nothing will load. The only thing i see is the minix logo but after that the screen goes black and nothing works. I have tried factory reset option but that wont come up or any other menu that may help me in this scenario will not load. What else can i do to try to fix this problem.
     
  2. midnight

    midnight Moderator Moderator

    Try unplugging it then plug it back in while pressing the power button for 8-10 seconds to see if you can get to the Recovery Menu.... you may have a faulty PSU however :(
     
  3. rusty718

    rusty718 New Member

    I dont think its a faulty psu i tried a adapter my friend had with another minix and same thing happened and no recovery menu shows up nothing will load after the minix logo
     
  4. MINIX - Martin

    MINIX - Martin Moderator Moderator

    Normally a manually re-installing firmware fix a lot of problems.