1. Registration issues have now been resolved. New accounts are able to be created

OPENELEC Minix X8/-H/ Plus

Discussion in 'NEO X8-H Plus Custom ROMs, Kernels & Discussion' started by taki, Jan 5, 2015.

  1. Niclas Andersson

    Niclas Andersson New Member

    No it is not, I will do it right now.

    thanks
  2. Adam Wesolowski

    Adam Wesolowski New Member

    u says dont have to be rooted few posts up ITS YOURS post /have the minix x8h-plus box got to be rooted to do this
  3. dali

    dali New Member

    Thanks mick56, that image works, can boot LibreELEC 7 from SD card.
  4. mick56

    mick56 Member

    no root needed burn image to sdcard after put a folder on sdcard with boot and put there boot sc file in there place sdcard to box hold power and recovery pin a vieuw second till you see the first greenman from android if you see release the power and the pin this needed to install the boot not hold down to recovery menu release early so next time android start from nand and libreelec from sdcard
  5. mick56

    mick56 Member

    you must release early the recovery and power if you see the first greenman release pin and power so it can be installed and after that you have multiboot
  6. mick56

    mick56 Member

    no image file read description update file for nand you wanna multiboot use image file
  7. mick56

    mick56 Member

    no root needed it will work if you follow description only i think many people hold down power and recovery to long if you come to recovery menu you did something wrong with first logo the greenman release the power and recovery so the boot can be installed after you can multiboot
  8. Adam Wesolowski

    Adam Wesolowski New Member

    Yes I know I ask to have on internal storage and image didnt works I copy update.zip and then works
  9. Qefx

    Qefx New Member

    I have SMB network share problems.

    I get an error share not available:

    Error 2: share not availa

    Seems like it is "common" error. Only thing which solves it is if I delete all shares and then readd them....
  10. Adam Wesolowski

    Adam Wesolowski New Member


    Try add manual smb or check in zeroconf should be able to add smb
  11. CraigH

    CraigH New Member

    Thanks mick56

    I have been considering my next move for my Minix boxes. Buy some O2's or RPi3's

    Initially I have now upgraded from OpenELEC 6 on my 2 x RPi2's and my 4 x Minix X8H-Plus boxes to LibreELEC 7.0.2

    I copied your LibreELEC-S812.MXIII_Plus.arm-7.0.2.6.tar to the Update directory and restarted the boxes.

    All went relatively smoothly and returned a big improvement in playback performance for me around Enigma based Mpeg2 recorded content.

    Will be looking to go to Krypton as the builds progress a bit more

    Big thanks
  12. mark2

    mark2 Active Member

    Thanks mick56 this works great on X8H- Plus really fast no problems(y)
  13. kyri

    kyri New Member

    Hi all, I have a minix neo-x8h-plus
    with 4.4.2 KOT49h-20150214 kernel 3.10.33

    I've install a helix kodi custom rom , only kodi on it

    It's been a month or so that streaming stopped working,
    not sure if it is hardware or not, but if I hard reset everything and put all addons again, it works for a bit and then it doesn't work
    (it doesn't even open most popular or categories etc.)

    I think it is software issue..


    I am trying to go to Jarvis.


    When you say burn the img to an SD what do you mean by "burn" ..just copy paste?
    can I just run jarvis arm apk as I am?

    can I put openelec directly on it , how?


    I tried downloading the apk and put it on SD card but I cannot figure out how to run the apk because no browser is installed I think or I cannot find how to launch it.

    I want to try the openElec rom the way you describe it but I cannot understand what do you mean by burn the img to sd

    do you mean use: sudo dd??

    that is how I've been doing it, problem is that i cannot open the sd after and add folder on it. because computer (mac) doesn't recognize it once it has finished cloning with dd (it should run on other devices though)
    *the img must be ready from get-go just clone with dd and put it in box


    can you guys help a brother out, I just need kodi, on minix neox8h-plus. nothing else.
  14. mark2

    mark2 Active Member

    Just download update .zip drag or copy onto sd card
    boot to recovery then update from EXT this will wipe android and install libreelec onto internal nand
  15. rlimas

    rlimas New Member

    Hello Mick56, seems that newer dated files are hosted, 12/29/2016
    upload_2016-12-29_18-18-18.png

    Question:
    Why are LAN1000 and LAN_100Mb?
    Which should I use for X8-H Plus?


    What is purpose of s805_autoscript

    Thanks in advance
  16. EagleEye

    EagleEye Member

    does this one run on Minix Neo X8h (S802)?
  17. michel30

    michel30 New Member


    My original image in the flash is X8H_PLUS_FW 010

    Did you fixed it?
    It try what mick56 says, a short reset, but still I get this menu.

    What I did is created on the SD card /boot/boot.scr and on the root of the SD card LibreELEC-S812.LAN1000.arm-8.0.0-update.zip but I don't get it boot up.

    Or is there someting what I do wrong, or works it only from a USB stick?

    Still waiting that MiniX brings out a new android version, others already has lollipop or higher.

    Thanks

    Regards,
    Michel
  18. kyri

    kyri New Member

    Thank you for your support,
    I've followed your instructions and successfully installed openelec version 6.00 kodi 15.2

    Kodi seems to be behaving correctly but I have the following hardware issues



    a) Although I have an ac router, the minix8hp box only connects with b/gn
    b) when turning "off" with the remote (off meaning the mode that just waits on stand by for the remote) the wifi service crashes and it needs reboot to work again.

    Let me know if you know if newer versions of openelec solves any of these issues.

    other than that the box runs fantastic, thank you.!!

    Just one last question, is the "bios" of the box still there? can I update with the same method (sd card) or
    does it support the (update method of libre elec with SMB?)
    I see the Update folder if I mount the ip of the box, but I am not sure if it will work with any update like go from openelec to libre elec or it only supports going from openelec 6.0 to 6.1 etc.


    THANK YOU ALL FOR ALL THIS GREAT INFORMATION YOU PROVIDE

    oh, and HAPPY NEW YEAR (if applicable when reading this)
  19. michel30

    michel30 New Member

    @kyri , so you lost the compleet android on your local flash.
    There is also a way to run Kodi version 17 from the SD card with dual boot.
    But I don't get the dual boot.

    I do not want erase the internal flash memory for openelec because openlec is not android.
    I know how openelec works from my raspberry pi, but android gives me more other futures, it sued be nice to have a duel boot, what mick56 says to run kodi 17 from the SD card.

    Regards,
    Michel
  20. ArceeKay

    ArceeKay Active Member

    I'm just back from vacation and wanted to check out the latest and best version of LibreElec on my Minix X8H-Plus.
    Don't need any multi-boot, because LibreElec is all I need.

    For Krypton, is the latest build still the one from December 6th? That one is great, but Wifi doesn't work for me. Did anyone find a way to get it working?
    Otherwise, I do see the 7.0.3.2 build of December 29th, but that one isn't Krypton of course. Hopefully Wifi works there?