1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Openelec on Neo x8 ?

Discussion in 'X8-H & X8/Plus Custom ROMs, Kernels & Discussion' started by J├Ânke, Nov 13, 2014.

  1. mackin

    mackin New Member

    bignjato and theDriver like this.
  2. yonatandror

    yonatandror New Member

    Thanks.

    Few questions if you mind:
    1. I dont have sd card, will it work with regular USB stick?
    2. When the OpenElec is installed does it override the MINIX android OS? meaning there is no access to MINIX android and XBMC?
    3. Can you revert the process back to original MINIX settings? How?
    4. Where is the OC installed on? Can I remove the USB after the installation?

    Thanks
    Last edited: Apr 21, 2015
  3. NetAndif

    NetAndif Member

    Hi,

    i've used the original OpenELEC build 4.97.1 on my Neo X8-H, until recently the box had died.
    Now on the replacement box, i've flashed the new 5.0.5 release from here.
    Unsurprisingly it worked 'out of the box' ;-)

    But i have a single problem with OpenELEC on Minix Neo X8-H:
    I cannot choose the audio output (i like to either use SPDIF or analog rather than HDMI).
    Is this an already mentioned issue, and how likely will it be fixed?
  4. Itrix

    Itrix New Member


    Yes i loaded it. The installation goes fine no problems there. Also the sound problems most of the people have been reporting is not present for me.

    Things i did encounter so far:

    - The M1 remote mapping is all over the place. Sometimes it works sometimes it doesnt had to change mapping manually.
    - On reboot or shutdown xbmc freezes and doesnt do anything anymore have to remove power to make it work again.
    - Sometimes XBMC doesnt store the watched status. So sometimes when the machine is rebooted it shows everything as unwatched.
  5. alesc

    alesc New Member

    Hi,

    For me the 5.0.8 is unusable, settings are lost and the ethernet MAC address changes everytime after reboot.
    But the CEC works better in 5.0.8 (on my Samsung TV).

    AirMouse buttons "back" and "menu" don't work as expected (same problem in 5.0.5).
    If someone found a way to make it work I will be more than happy to know how ! :)

    Also infrared receiver does not seems to works with other remote control.
  6. NetAndif

    NetAndif Member

    I've flashed 5.0.8 and audio output is now selectable from HDMI to Analog. That's great.
    But another issue i have is that the video output is stuck at 720p and mode selection is greyed out. How can i switch to 1080p?
    I have connected my X8-H via HDMI to DVI Cable and this usually did work with 1080p.
  7. MuscleMan2000

    MuscleMan2000 Member

    Fail post
    Last edited: May 3, 2015
  8. NetAndif

    NetAndif Member

    I've fixed the 1080p issue by adding the following entries to the file /storage/.config/autostart.sh

    echo 1080p > /sys/class/display/mode
    echo 1 > /sys/class/graphics/fb0/freescale_mode
    echo 0 0 1919 1079 > /sys/class/graphics/fb0/free_scale_axis
    echo 0 0 1919 1079 > /sys/class/video/axis
    echo 0 0 1919 1079 > /sys/class/graphics/fb0/window_axis
    echo 0 > /sys/class/graphics/fb0/blank
    echo 1 > /sys/class/graphics/fb1/blank

    Taken from this comment: http://www.cnx-software.com/2014/12...ga-s89-tv110-and-cx-s806-s812/#comment-316672
    Last edited: May 4, 2015
  9. ArceeKay

    ArceeKay Active Member

    To fix the IP settings that change all the time, there is a fix setting your IP or your MAC (or both) in the autostart.sh file.
    To fix your remote buttons install the keymap editor add-on and map your buttons to the function you want.

    I advise all readers of this topic to check out the OPENELEC Minix X8/-H/Plus thread in the X8-H Plus Custom ROMs forum. There @surkovalex is participating and he is the one compiling the builds on http://amlinux.ru we all use. Many forum participants (including me) donated to him to buy a box as until today he makes the builds without even having a Minix in his possession.

    A lot of the issues discussed in this thread are already discussed in that thread and many answers are already available there. And even though it is in the X8-H Plus forum, there are many X8 and X8-H users participating too, as the X8-H Plus ROM works on those devices as well without any issues.

    Here a link to that thread:
    http://www.minixforum.com/index.php?posts/51942/


    Sent from my iPad using Tapatalk
    Last edited: May 5, 2015
    zarb likes this.
  10. ArceeKay

    ArceeKay Active Member

    1. I am not sure, as some users I know installed from a USB stick and encountered problems. SD Cards are so cheap these days, I suggest you just go buy one.

    2. Yes, OpenELEC overwrites your Android OS. So only use it if you only need Kodi/XBMC. You will not regret if you are an audiophile like me, because in OpenELEC, Kodi is not bound to the Android audio environment. In OpenELEC you get bit perfect audio from PCM 44.1kHz 16bit all the way to 192kHz 24bit which was the main reason to switch for me. And it boots much faster, too.

    3. Yes you can revert to the official Android easily by using the USB loader on your computer to flash back an official Minix release.

    4. It is installed on the internal flash memory. There is ways to install it on an SD card too, but I never tried that.

    If you want more detailed answers on these questions, check out the OPENELEC Minix X8/-H/Plus thread on the X8-H Plus Custom ROMs forum. I've updated the installation guide there too:

    http://www.minixforum.com/index.php?posts/51479/


    Sent from my iPad using Tapatalk
    Last edited: May 5, 2015
    zarb and yonatandror like this.
  11. savvasha

    savvasha New Member

    For some reason it doesnt recognise my advancedsettings.xml... Am I the only one? The same xml file was working fine with kodi under android
  12. ArceeKay

    ArceeKay Active Member

    Yes, I did. I'm running OpenElec on my Minix and my old HTPC is in the room for the kids upstairs. Both running from the same database and sharing a folder on my NAS for the pictures/thumbnails. Like this the footprint on the Minix and the HTPC of Kodi is very small, and the gigabytes of thumbs plus the database is on my NAS as well.

    It is simple to do, just make sure both Kodi's are the same version and share the same sources.xml in the Userdata folder. One slight difference in the paths of the sources and already it doesn't work.
    Furthermore you must set-up a database on your NAS as well (lots of forums explaining that, I'm running a database in MariaDB which was set up in minutes) and you must modify your advanced settings.xml (also in the Userdata folder) to contain the following:

    HTML:
       <videodatabase>
           <type>mysql</type>
           <host>xxx.xxx.xxx.xxx</host>
           <port>3306</port>
           <user>dbuser</user>
           <pass>dbpassword</pass>
           <name>xbmc_video</name>
        </videodatabase>
        <musicdatabase>
           <type>mysql</type>
           <host>xxx.xxx.xxx.xxx</host>
           <port>3306</port>
           <user>dbuser</user>
           <pass>dbpassword</pass>
           <name>xbmc_music</name>
        </musicdatabase>
        <pathsubstitution>
         <substitute>
          <from>special://masterprofile/Thumbnails/</from>
          <to>smb://username:password@xxx.xxx.xxx.xxx/web/Kodi-Media/Thumbnails/</to>
         </substitute>
        </pathsubstitution>
    Obviously username and password should have access to a Samba share on your NAS, xxx.xxx.xxx.xxx should be the IP of your NAS, and in my case, thumbs are located in the web/Kodi-Media/Thumbnails folder.

    dbuser and dbpassword should be configured in your MariaDB (or mySQL) database for Kodi to be able to build up tables and populate the database.
  13. ArceeKay

    ArceeKay Active Member

    Be advised that @surkovalex just uploaded a new build dedicated to the Minix X8 Plus (and not the X8-H or X8-H Plus).
    Find it here: http://amlinux.ru/target/x8p/

    I would expect it to work on both X8 and X8 Plus, just like the X8-H Plus build also works on the X8-H.
  14. ArceeKay

    ArceeKay Active Member

    It just works! CEC must be activated on your TV, and if a Processor or Amp is in between the two, that one must have CEC activated, too.
    Advantage of using CEC: your TV remote also works within Kodi on the Minix.
    Disadvantage of using CEC: switching off your TV also switches off the Minix. I find that not preferable, as I want to use the Minix also for music with my TV switched off, so I ended up not using CEC after all...
  15. ArceeKay

    ArceeKay Active Member

    Maybe because you put the advancedsettings.xml in the wrong place? Browse to your Minix' SMB share, and go to Userdata folder. If there is no advancedsettings.xml there, just create it, and OpenElec will recognise it for sure.
    zarb likes this.
  16. KraceyZ

    KraceyZ New Member

    What kind of tools do you use when you're going to flash the device?
    Once i tried to flash my device(it's not Minix Neo X8-H), but the remote controller was unavailable in the recovery interface...
    So i just take the tf card out, and move the files into root directory...
  17. yonatandror

    yonatandror New Member

    So thanks to ArceeKay I have updated my Minix to OE 5.0.8 and it works great.
    BUT :)rolleyes:) one of the main reason to move to OE was the need to use MEDIA CENTER PC as a device in my Logitech remote as done over CuboxTV I have.
    This allows ALL buttons to work straight away (Especially Stop, FF, FB...) and not via a menu like today.

    Do you know why it doesn't work like this?
    Is the remote mapping is a device HW issue or an OS issue as I thought it is?
  18. ArceeKay

    ArceeKay Active Member

    So far I have not succeeded either to make my Harmony work that way either. What I did is learn it the buttons from the original Minix remote, and programmed a few useless buttons such as volume up and down under the play and stop burtons and with key mapper add on, remapped those to play and stop in openelec. But even better, I started using Constellation on my iPhone and iPad and use that as a remote, way better than the harmony.


    Sent from my iPad using Tapatalk
  19. yonatandror

    yonatandror New Member

    If you find a way to add those buttons to the Logitech it will be great. Make the device perfect.
  20. ArceeKay

    ArceeKay Active Member

    Well, a start is to relearn the + and the - button to MyHarmony so that it doesn't know it is VolumeUp and VolumeDown. Set the Harmony to use VolumeUp and VolumeDown from your amp or your TV. Then, you have the + and - buttons free. In MyHarmony, I put the + button under Play and Pause buttons of the Harmony, and the - button under the Stop. Then, in Kodi, using Keymapper add on, I learn Kodi under navigation the Play/Pause function by pressing Play or Pause (in fact, the + button) and learn Kodi the Stop function by pressing stop (actually the - button). That gives you at least play/pause/stop, which is the ones that are most important.


    Sent from my iPad using Tapatalk