1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

[Patches][update.zip] Root, Unroot, System mods (no CWM / no PC needed)

Discussion in 'X8-H & X8/Plus Custom ROMs, Kernels & Discussion' started by gufone, Aug 7, 2014.

  1. adi_tca

    adi_tca Trusted Helper Trusted Helper

    No, root is not meant to brick your box. Read the 1st two posts in this thread how to root your box, if you really need it. I guess you want root to apply those TCP buffer settings you mentioned in your separate thread.
    Like Higgs mentioned, upgrade your box 1st (via FOTA app, or USB zip or flash full image), then you can root it.

    Theoretically yes, once rooted you may not be able to upgrade via FOTA. But you can simply unroot, using same steps as for rooting (you just need the unroot file from post #2 in this thread), do the upgrade and then root again.
    Sypher_04 likes this.
  2. Sypher_04

    Sypher_04 New Member

    Awesome. Thanks for the help. And yes, I'm trying to apply the TCP settings.
  3. skyzo2000

    skyzo2000 Member

    Hi,
    I ve some problem to unroot my x8-h,
    I rooted the box 3 days ago to test an app. No I need to unroot because of another app.
    But when I lauch the unroot.zip, It mark install ok but when I reboot the box it s always rooted.
    I tried 3 times and no change.
    I downloaded twice the zip and no change.
    What can I do to unroot my box ?
  4. Villa

    Villa Trusted Helper Super Moderator

    If it really isn't working then you will have to re-flash the firmware.
  5. adi_tca

    adi_tca Trusted Helper Trusted Helper

    Did you installed Xposed Installer and its framework? If so, if you want to unroot, unistall first Xposed framework.
    Villa likes this.
  6. skyzo2000

    skyzo2000 Member

    It s ok now, I did twice and it s working now, the root is gone.
    Thanks
  7. Villa

    Villa Trusted Helper Super Moderator

    I wonder what the root of the problem was?! :rolleyes::whistle:
    Drew McClure likes this.
  8. spykos

    spykos New Member

    @gufone

    How did you manage to create the signed zip ? Do you have the pk8 from Minix ?
    I am just asking as I am trying to make a zip to mod a few things but it fails.
  9. Touny

    Touny New Member

    Hi,
    I have some problem with root of my X8-H plus. I have KOT49.20150925, Kernel 3.10.33. I tried install root from USB disk , but after recovery restart when I choose update.zip , then start root, but failed on verification :-(

    --install/UDISK...
    Start copy/udisk/update.zip to /tmp/sideload
    Finding update package...
    Opening update package...
    Verifying update package...
    E:failed to verify whole-file signature
    E:signature verification failed
    Installation aborted

    Where I do mistake?
    Please help. I am a beginer in world of minix
    THX
    Last edited: Nov 4, 2015
  10. HKB

    HKB New Member

    what you guys mean when you say remove ads? From where ads would be removed? Which app? All apps?
  11. Frederick_99

    Frederick_99 Well-Known Member

    if you use something like adaway app ( which requires root) then it can often "remove" the "advertising" you often get on the free apps you may have installed
  12. HKB

    HKB New Member

    If I want both root and remove ads, do I use remove ads update.zip only or apply both updates sequentially?
  13. gufone

    gufone Big Owl - Developer Super Moderator

    You must apply both. But pay attention that the ad patch is quite old now. You can simply root and then use an app like adaway.

    Sent from my GT-I9505 using Tapatalk
    HKB likes this.
  14. HKB

    HKB New Member

    Thanks mate
  15. Skyy

    Skyy New Member

    hi,

    i followed all the steps but i met some issues during the procedure and i don't understand where wrong.
    I tried many times but with the same result, with different USB keys and SD cards.

    here the details of my device and the issue:

    Device: Minix X8-H Plus
    Version: KOT49.20150925
    Kernel: 3.10.33

    Issue:
    When i boot in the recovery mode and try to update via sdcard i see the following error:
    "
    -- Install /sdcard ...
    Start copy /sdcard/update.zip to /tmp/sideload
    Finding update package...
    Opening update package...
    Verifying update package...
    Installing update...
    Installing Gufone update...
    set_perm: some changes failed

    Install from sdcard complete.
    "

    Can you help me?
    Please....

    Thank you very much
  16. Skyy

    Skyy New Member

    Hi all,
    no bady has any idea?
    Thank you
  17. sambit

    sambit New Member

    Hi Need help, If I need to use Minix Nx8h plus with G910 game pad, do I need to root the Minix? What difference does it make?
  18. Villa

    Villa Trusted Helper Super Moderator

    As far as I'm aware you shouldn't need root for a G910 controller!
    @Higgs you have one of these controllers don't you?
  19. Higgs

    Higgs Yellow Dude Super Moderator

    I do (somewhere). I haven't used it for awhile. But no, you don't need root to connect it.
    Villa likes this.
  20. famousmini

    famousmini New Member

    Hi
    I read here and there that are 3 ways to upgrade the minix: via de pc (otg), via usb/sdcard (zip method) and fota. I have a rooted device. I want to know wich one may works/not works for me ? and also wich one keeps/ not keeps data ? thanks

    I am asking this because. I have rooted via Gufone method. He says thatś rooting does not affect ota. But i read elsewhere that fota is not working on rooted device. Iḿ confused
    Last edited by a moderator: Jan 27, 2016