1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Play Store not working - certification issue?

Discussion in 'NEO X6' started by Sracimir, Jan 1, 2018.

  1. Sracimir

    Sracimir New Member

    Hi

    I have an issue with my X6.

    Today I tried to update the apps with Google Play Store, but it returned message "Error checking for updates".

    I checked the device certification status in the settings and it sais "Uncertified"

    Is this a bug? Can it be fixed within the current firmware (version 008)? Or is this device completely out of support now?

    Will migrating to the Lollipop beta firmware fix the issue?

    I will appreciate your prompt reply.

    Cheers!
     
  2. Villa

    Villa Administrator Administrator

    "Uncertified" is the correct status.

    As for the update issue, have you checked your connection?
    Are you connected by WiFi or Ethernet?
     
  3. Sracimir

    Sracimir New Member

    Hi Villa,

    Thanks for the prompt reply. I checked the internet connection and it was OK. I am on Ethernet, but this was never a problem.

    It seems that I fixed the problem by deleting all cache and data for the Play Store app.

    Cheers!
     
    Villa likes this.
  4. Avinash786

    Avinash786 New Member

    Hi,

    I have a x6,

    I am having the same issue with google play store, I tried deleting cache and data but this problem still persists

    How do i fix this?

    Thanks,