1. Registration issues have now been resolved. New accounts are able to be created

Plex playback stutters and has no sound

Discussion in 'NEO X8-H Plus' started by Simon245, Aug 12, 2017.

  1. Simon245

    Simon245 New Member

    Plex will not playback properly on my X8-H plus or on my X6. The video stutters and often the sound will not play and sometimes the playback fully crashes. I have tried all settings in plex to no avail. There are a few videos that play but I don't know why the others don't.

    I assume there is an issue with minix for plex as I have two different boxes and both are the same. Has anyone found a way to fix this?

    please don't just recommend using Kodi instead of plex as I have seen other people do. I do use kodi but as I use plex on other devices I just want to use the same platform on everything
  2. mackdenny

    mackdenny New Member

    I too had the same troubles. No what what codec I had and setting I chose, Plex always stuttered. I just use the "Use External Player" option in Plex and MX Player plays the files seamlessly. That kind of led me to the conclusion that it wasn't Plex Media Server, it was just the Player.
  3. Simon245

    Simon245 New Member

    Yeah it's not an issue with Plex media server, the server is working fine for all other platforms, It's always just been the player for the minix boxes.
  4. tomyr7

    tomyr7 New Member

    Hey all, Any ideas on this? I've got a Minix X8-H Plus and plex stutters when playing at original quality.
    The box was factory reset and is up to date via OTA.
    Plex app is also up to date.

    A fix is to put the quality down to 480p or even 320p for some media. Very annoying. Almost renders the box useless.
  5. Villa

    Villa Well-Known Member Super Moderator

    Are you using internal or external player?
  6. Simon245

    Simon245 New Member

    I think I tried this with a few external players as well and still had the same results with some files. I just don't think this is a compatibility issue that will ever be fixed.
    The good news is that Plex has just released an official kodi addon so I will be trying that out.

    I was pleased to try out the beta updates to android 5 but that still didn't fix the playback issues on my X6