1. Welcome to the official forum for MINIX devices!

Poor wifi / ethernet speeds.

Discussion in 'NEO X8-H PLUS 002 firmware' started by Kajukenbo, Jan 17, 2015.

  1. kricsek

    kricsek New Member

    I'm also having problems with my Minix X8-H Plus's network speed.
    The way I test it is I download some files from the HDD connected to the router to the Minix's download folder.
    Results:
    Ethernet: 15 MBytes/sec (don't know how to check if gigabit or not)
    Wifi both 2,4 and 5 ghz 1 meter from the router: 5-6 MBytes/sec (I have only N router, channel is clear.)
    Wifi both 2,4 and 5 ghz downstairs: 3,5 MBytes/sec
    Laptop and phone 2,4 ghz from downstairs: 7 MBytes/sec
    So basically I get half the speed with Minix than my other devices.
    I'm using firmware 005.
  2. Dr Goodvibes

    Dr Goodvibes The Doctor

    15MB is ~120Mb so indications are that you're using 1Gb Ethernet.

    To test data bandwidth I install an FTP server from the Google Play store on the Minix X8H-Plus.
    I then use client FTP via a SSH or DOS shell using command line.(QNAP NAS in my case)

    I then push/pull (put/get) on a large file (500MB maybe) where the FTP client displays the time and data per sec sent/receive.

    FTP is one of the more efficient transfer methods and gives a good indication of read/write access on the Minix X8H-Plus.

    An NTFS storage device on USB is faster than SD card even if you have a 90/60MB read/write SD card.

    WiFi is capped at ~10MB (802.11ac at 80Mbits )no matter what storage device you use on the Minix box.
  3. kricsek

    kricsek New Member

    None of these explains why I have half the wifi speed on Minix than my other devices.
    The storage card is not the bottleneck since via ethernet the speed was much higher.
    I forgot to mention in my previous post that I also use FTP to measure the download speed between the router's HDD and Minix.
    The FTP client I use on the Minix box is the built-in ES Explorer.
  4. GDan

    GDan New Member

    My Minix X8-H Plus, connected to a gigabit router on a gigabit internet connection, reported over 900 Mbps download and over 200 Mbps upload the first time I ran Ookla Speedtest.
    After installing several apps, nothing strange, only usual stuff, running the test again I got only 20 Mbps download and over 200 Mbps upload. I thought that might be a cable problem, so I replaced it.
    First test on the new cable, over 600 Mbps download and over 200 Mbps upload. I thought that maybe the network was overcrowded.
    I turned off the device and went to sleep. In the morning the same issue: only 50 Mbps download and over 200 Mbps upload.
    After each of the tests mentioned above, I ran also a test for the 5 GHz Wi-Fi connection: about 100 Mbps download and upload.

    The conclusion is that something is strange.
    Reading this topic, I did't find the reason or a solution.

    Can someone help?
  5. Villa

    Villa Well-Known Member Super Moderator

    ...and this is an old firmware thread! ;)

    Have you updated to the latest firmware?
    What is the Build number of you device?
  6. GDan

    GDan New Member

    Yes, I updated to the latest firmware.
    I will come with the Build number. Does it make the difference?
  7. Villa

    Villa Well-Known Member Super Moderator

    A lot of Member's say, ''I have the latest firmware!'' but that doesn't mean anything! The Build number tells us exactly which firmware you have. :)
  8. GDan

    GDan New Member

    The build number is: KOT49H.20150925

    Trimis de pe al meu SM-N9005 folosind Tapatalk
  9. triks

    triks Member

    Test results from pinging (ping -f -l 1472 10.0.1.55) my Minix X8-H Plus shows MTU is set to 1500.
    I have 4 x Minix X8-H Plus on my home network together with 2 HP switches and approx 10 other devices. I was able to configure all my other devices to accept Jumbo Frames with a MTU of 9000 (resulting in approx 30% transfer speed improvement from my Synology 1813+ NAS aggregated to a 4gig link). Can someone please advise if there is any way to enable Jumbo Frames and set a MTU on the LAN Adapter ?
    If not, Ken would it be viable to enable this feature in the next update ?

    Minix NEO-X8-H-PLUS
    Build: KOT49H.20160328
    Kernel 3.10.33
    Android v4.4.2
  10. Menorca Man

    Menorca Man Active Member Trusted Helper

    Not sure why you decided to post this in the Firmware 002 thread given that you're using firmware 009!!:confused:

    Suggest you would receive a better response by contacting one of the Moderators and request that they transfer your post as a new thread in the X8-H Plus general forum (http://minixforum.com/forums/neo-x8-h-plus.81/). ;)
    Villa likes this.
  11. Villa

    Villa Well-Known Member Super Moderator

    Or @triks could delete the post and post in the correct section, himself! ;):)
    Menorca Man likes this.
  12. Villa

    Villa Well-Known Member Super Moderator

    He did already but hasn't responded here!

    http://www.minixforum.com/threads/configure-lan-adapter-for-jumbo-frames-mtu.13410/
    Menorca Man likes this.