1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

[Possible SOLUTION] SD Card Problem

Discussion in 'NEO Z83-4' started by MrReis, May 26, 2017.

  1. MrReis

    MrReis New Member

    UPDATE – 10 JAN 2018

    Intel documents the following SD card problem for the Atom Z8000 series processor that has the same symptoms as the Neo Z83-4 disappearing SD card problem documented on this forum but a different cause.


    System May Experience Inability to Boot or May Cease Operation
    Under certain conditions where S0ix is not implemented and activity is high for several years the LPC, RTC and SD Card may stop functioning in the outer years of use.
    LPC and RPC circuitry that stops functioning may cause operation to cease or inability to boot. SD Card that stops functioning may cause SD Cards to be unrecognized. Intel has only observed this behavior in simulation. Designs that implement the LPC interface at the 1,8V signal voltage are not affected by the LPC part of this erratum. Designs implementing S0ix are not affected by this issue.
    Firmware code changes for LPC and RPC circuitry and mitigations for SD Card circuitry have been identified and may be implemented for this erratum.
    For the steppings affected, see the Summary Tables of Changes
    “Intel Atom Z8000 Processor Series Specification Update,” July 2017, Revision 012, page 29, https://www.intel.com/content/dam/www/public/us/en/documents/specification-updates/atom-z8000-spec-update.pdf

    On 30 DEC 2017 I noticed that both of the Z83-4 units I have stopped displaying their installed SD memory card in Windows Explorer. In addition Windows Device Manager did not display the “SD Storage Class Controller” that had been connected to the SD memory card nor the SD memory card device (“Generic ADLCE SD Card”). Enabling “Show Hidden Devices” in Windows Device Manager displays both the “SD Storage Class Controller” and “Generic ADLCE SD Card” with the following status.

    “Currently, this hardware device is not connected to the Computer (code 45).
    To fix this problem, reconnect this Hardware device to the computer.”
    Nothing I do restores the SD card to Windows Explorer or Device Manager. It seems like this problem is guaranteed to reoccur and has no solution.

    Around May 3, 2017 I noticed that both of the Z83-4 units I have did not display the installed SD memory card (SanDisk - Ultra PLUS 64GB microSDXC UHS-I Memory Card) in Windows Explorer. The device status of the “SD Storage Class Controller” that had been connected to the memory card (“Generic SL08F SD Card”) in Windows Device Manager was

    “This device cannot start (Code 10)
    {Operation Failed}
    The requested operation was unsuccessful.”
    Windows troubleshooter reinstalled the “SD Storage Class Controller” drivers which didn’t solve the problem. One of my Z83-4 units has already been replace by Minix USA for the same reason so getting replacement units won’t solve the problem because it will just happen again.

    This problem has previously been reported in this forum.

    The same SD card problem has been reported on other forums as well.
    KB3149135 update 15-6-2016 causing my SD Card to unmount many times during the day
    For those having SD card reader issues - try this driver fix
    Micro SD card woes (Error 10)
    Error: "SD storage class controller has a driver problem" on tablet running Windows 10
    “…there are no solution from Microsoft. Its general problem for almost all atom based tablets. Fortunately I discovered a way around. My solution is rather simple ie use a mini pendrive like sandisk ultra fit and plugged in it with one of your usb port permanently...”
    "64GB SD cards are SDXC, 16 & 32GB SD cards are SDHC. If the slot is HC, it will not read XC cards. XC slots will read both XC & HC.”
    “My Hi8 Pro (May 28 Bios) can only use SD cards up to 8GB in Win 10, anything larger and I get the "code 10" and the card doesn't work."

    There's a solution for this problem that actually works (but is not a perminate solution) – install the Windows 8.1 version of the Intel SD Host Controller driver. It fixed the problem on both of my Z83-4 units.

    It would be nice if Minix would provide a Windows 10 version of the driver that works.
    Last edited: Jan 17, 2018
  2. MrReis

    MrReis New Member

    Does anyone know the manufacturer of the SD card socket used on the Z83-4? Perhaps they have a Windows 10 drive for the socket.
    alex_notredame likes this.
  3. minics

    minics New Member

    If your microSDXC UHS-I Memory Card came formatted as exFAT try re-format it to NTFS which is the default file system of Windows NT family.
    exFAT has been adopted by the SD Card Association as the default file system for SDXC cards larger than 32 GB. Microsoft "adopted" exFAT and is said to have optimized it for flash memory such as USB flash drives and SD cards. However, it is proprietary and Microsoft owns patents on several elements of its design but not all.
  4. srjuanjo

    srjuanjo Member

    same problem here, no matter what bios I have updated or what file format does my se card have, it disconnects
  5. minics

    minics New Member

    Have you tried to change your SD Card "Removal policy" setting to Better performance from Quick removal (default) via Device Manager?[​IMG]
  6. Daraku

    Daraku New Member

    I need to give MrReis a huge "Thank You" because thanks to this post, finally, I solved the microSD Card Reader issue I had since January.
    At the beginning of January the card reader started disconnecting the card (I tried many microSD Cards of various formats) many times every day, then stopped working all togheter. I could still hear the typical sound we can hear when inserting or extracting an SD Card, but nothing more, none available to use with Windows.
    It was definitely a Windows driver problem, not a Minix z83-4 hardware fault or Bios related issue.
    I don't have the Creator Update istalled, of course I will let you know if the issue reappear.

    I couldn't use a microSD in 6 months, I'm really happy to have my card reader working again.:)
    Last edited: Jun 23, 2017
  7. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Does it affect the speed?
    We've reported this special workaround to Intel.
    We can't make our own driver so it must be Microsoft or Intel to fix this.
  8. Daraku

    Daraku New Member

    I didn't check, I use the microSD just to store some movies and I didn't notice any issue with Kodi. I will check.
    BTW in the last week I had no SD card disconnections.
  9. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    We've tested and the speed isn't affected.
    Daraku likes this.
  10. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    @MrReis I've put this thread sticky. Thanks.
  11. BertMagin

    BertMagin New Member

    My SD card problem may be different in that after an ejection (drop) or two the card becomes unusable anywhere. Also this did not allow me to load the unsigned driver. Yep I had the test mode enabled. TestMode _did_not_work.PNG
  12. Crispy

    Crispy New Member

    My 12 year old daughter has been unable to play SIMS4 since Jan (it was her Xmas present) - all because of this SD CARD problem. We couldn't get help because of the forum registration errors. We were about to give up so Special thanks to MrReis for this fix. Speed problems will show up pretty soon once I get the game downloaded again. I will keep you posted.
    ciberciccio likes this.
  13. Crispy

    Crispy New Member

    I had the same issue - use the alternative boot method instead of the command line.
  14. srjuanjo

    srjuanjo Member

    working flawless so far... many thanks
  15. markhanooft

    markhanooft New Member

    Hello !

    I have the same problem than @BertMagin I'm unable to install the drivers even in test mode.

    Best !
  16. srjuanjo

    srjuanjo Member

  17. gadgetuk

    gadgetuk New Member

    I changed this driver yesterday, twice the SD disappeared again within an hour, so hasn't fixed it for me

    Sent from my Redmi Note 4 using Tapatalk
  18. bencali

    bencali New Member

    I'm finding the problem is coming back again, despite updating / changing the drivers. I started a new thread to address (read BEG) Minix to take a better look at this problem and put more resources on it, since MOST of us rely on the SD card as our main storage space. At what point does Minix admit this may be a HARDWARE issue?

    @ MINIX - Is the warranty on these boxes any good?
    gadgetuk likes this.
  19. gadgetuk

    gadgetuk New Member

    I've since had to reinstall windows 10 , all working fine at present, including the SD card, will check out again next week as not around at the weekend

    Sent from my Redmi Note 4 using Tapatalk