1. Registration issues have now been resolved. New accounts are able to be created

RECOMMENDED: Z83-4 V1.6 BIOS update

Discussion in 'NEO Z83-4' started by MINIX - Ken, Mar 27, 2017.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all NEO Z83-4 users,

    Here is the official V1.6 BIOS for Z83-4:
    http://www.minixforum.com/downloads/download.php?file=Z83-4_V1.6_BIOS.zip

    Change log since V1.4 BIOS:
    1.) Updated Intel TXE firmware;
    2.) Modified audio codec source code for Windows 10 OS;
    3.) Disabled UEFI PXE boot option (since PXE boot doesn't support booting from eMMC storage);
    4.) Enabled TPM 2.0 support;
    5.) Improved CPU performances;

    Update procedures:
    1.) Download the V1.6 BIOS zip package
    2.) Extract this package to your Windows' local storage, e.g. Desktop
    3.) Run the "update.bat" by double-clicking it
    4.) Choose "Yes" to proceed when Windows prompts for your administrative rights
    5.) Patiently wait for the update to complete, DO NOT disconnect the power source during the process or the BIOS will be corrupted!
    6.) Restart the system to take effect, please notice that the system will restart for several times before re-entering the OS.

    Regards,
    Team MINIX.
    gufone, Rayways, huy and 1 other person like this.
  2. tunay

    tunay Member

    Hi ken ,

    Is the sound issue solved with this bios update? ''Thump Thump ''

    Modified win 10 audio codec?
  3. Randomz

    Randomz New Member

    After a couple of hours the power button stops working. Has to be shutdown by logging in.
  4. Brian EclipseWiFi

    Brian EclipseWiFi New Member

    I've updated the BIOS to your V1.6 as advised and that went successfully. The issue that is still happening for me is the Auto Power On After AC Loss is still not functioning. I confirmed this feature is enabled in the BIOS (several times) and the unit still does not power on when juiced up until I manually press the power button. I purchased and configured about a half dozen of these Z83-4 and the first few I was able to enable this function and it worked. The last two units purchased are having this problem of not powering on after power loss with the feature enabled in the BIOS. I appreciate any input and thanks.

    Ken, btw, I apologize for sending a private message BEFORE I read your footer in your post. I'm a turd.
  5. Villa

    Villa Well-Known Member Super Moderator

    I'm not sure if this affects Auto Power On After AC Loss, but maybe check the state of Fast Startup!
    http://www.minixforum.com/threads/disabling-fast-startup-in-windows-10.14034/
  6. borbafett13

    borbafett13 New Member

    installed the new bios and have noticed that everything seems quicker,from initial startup to launching apps. Just to be clear we are not talking about a night and day difference but a noticeable improvement , Great job on this update.
    Thank you.
    Villa likes this.
  7. iceman

    iceman New Member

    it´s the same as the beta 1.6 bios?

    or i need to upgrade again?

    thanks!

  8. hahnweiler

    hahnweiler New Member

    Updated successfully, but what still does not work is to disable the powersupply on the usb 3.0 port after shut down. I disabled the charging feature with no effect.
  9. Villa

    Villa Well-Known Member Super Moderator

    I don't know if it is the same or not? I would just run the BIOS update again!

    @MINIX - Ken can you confirm whether the Beta and this release are the same?
  10. tunay

    tunay Member

    The sound issue thump thump is still alive with this bios update. Also is a problem with standby Mode. The led is now blinking
  11. Villa

    Villa Well-Known Member Super Moderator

    That's because the "thump thump" has nothing to do with the BIOS!

    You have already been told this!
  12. Rayways

    Rayways New Member

    Same issue with the sound as @tunay and some other owners of Minix Neo z83-4 have mentioned in this forum. Anyone at Minix looking for a solution OR is it a known issue with under-powered controller and we just have to live with it?
    Last edited: Apr 2, 2017
  13. Villa

    Villa Well-Known Member Super Moderator

    @tunay have you done as @MINIX - Ken suggested here?
    http://www.minixforum.com/threads/sound-issue-with-neo-z83-4.15799/#post-125022
  14. srjuanjo

    srjuanjo Member

    I did install the new bios.
    Previously I had installed the version 1.4 and everything was ok.
    My only problem now that Inhave updated is the led.

    When my minix go to sleep the led turn into green as it should, but after 5 minutes it turns into blue but still sleeping.
    It is quite uncomfortable because I have the minix in my bedroom and at nights the blue led it's too bright and it's bothering me.
    There is any way to solve this issue? Should I go back to 1.4? if yes how can I do it.

    Thanks!.
  15. tunay

    tunay Member

    I think bios 1.6 is wrong coded srjuanjo. We have to wait bios 1.7 or go back to 1.4. As the thump thump and the Led doesnt work correct .
  16. Villa

    Villa Well-Known Member Super Moderator

    thump thump I'm going to thump you! :mad:
    The thump thump is not a BIOS issue as already stated by @MINIX - Ken
    KDB likes this.
  17. srjuanjo

    srjuanjo Member

    so if this update is problematic, how can I go back to 1.4 v. bios? it is as easy as download and install the previous one again?.
  18. Villa

    Villa Well-Known Member Super Moderator

    Yes, just reflash the older BIOS.

    But as far as I'm aware the new BIOS brings better performance!
    As for the LED bothering you why not shutdown the device?
  19. srjuanjo

    srjuanjo Member

    Cause It is more convenient updates are done while it sleeps and windows defender is all done as well, beside it does consume really low energy. If I want to turn it on I just have to touch my keyboard and Imdo not have to go to my device and look for the button.
  20. Villa

    Villa Well-Known Member Super Moderator

    Maybe that's the issue! If it is sleeping then it should not be updating 'coz it is asleep. If the LED is blue then it is no longer asleep!
    Just a thought! :)