1. Welcome to the official forum for MINIX devices!

RECOMMENDED: Z83-4 V1.66 BIOS & MCU firmware update

Discussion in 'NEO Z83-4' started by MINIX - Ken, May 3, 2017.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all NEO Z83-4 users,

    We are releasing the official V1.66 BIOS and MCU firmware upgrade for Z83-4:
    http://www.minixforum.com/downloads/download.php?file=Z83-4_V1.66_MCU_update.zip

    Change log since V1.6 BIOS:
    1.) Fixed the real time clock (RTC) inaccurate issue;
    2.) Fixed the problem that auto power on option doesn't work on some units;

    Note:
    You don't have to upgrade to this build if you are not suffering from the above 2 issues,
    as only a very small percentage of users are experiencing these problems.

    Upgrade procedures:
    1.) Download the zip package from the link above

    2.) Extract this package to the root directory (not inside a folder) of a USB thumb drive - FAT32 formatted
    There should be 6 files in your thumb drive's root directory when it's done.
    upload_2017-5-3_15-18-5.png

    3.) Plug this USB drive containing the 6 upgrade files to your Z83-4, then powering it up and press "F11" on your keyboard during boot to enter the boot device menu

    4.) Select "Built-in UEFI Shell" when you see the below boot device menu and hit "Enter" on your keyboard
    upload_2017-5-3_15-20-54.png

    4.) Type "fs3:" and then hit "Enter" to read from the USB drive
    (you may also type "dir" and hit "Enter" after this step to verify all the 6 upgrade files are there, optional)

    5.) Type "update.nsh" and hit "Enter" to execute the upgrade package, it shall take a few minutes and upon completion, your Z83-4 will be shut down automatically, you will have to turn it back on manually after this upgrade.

    upload_2017-5-3_15-23-31.png

    6.) Patiently wait for the upgrade to complete, DO NOT disconnect the power source during the process you may brick your machine!

    If you have any questions regarding this upgrade, please feel free to let us know.

    Thanks & regards,
    Team MINIX.
  2. tunay

    tunay Member

    hi ken what do you mean with auto power on?
  3. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Auto power on after AC loss.
  4. srjuanjo

    srjuanjo Member

    where can I download previous bios (1.4) thanks
  5. Villa

    Villa Well-Known Member Super Moderator

  6. srjuanjo

    srjuanjo Member

  7. Villa

    Villa Well-Known Member Super Moderator

  8. Nunop

    Nunop New Member

    Hi there.
    By Fixed the real time clock (RTC) inaccurate issue, you mean that the clock is most of the time with the wrong time? In my case, when I start the minix, sometimes the time is the previous day, then it adjusts to the right time and suddenly it takes an hour, and after some time it takes another hour to delay.
    In addition to this problem, the Ethernet and wi-fi network connection is constantly losing signal, indicating that there is no valid ip address. Does this update solve this?
    Thank you.
  9. srjuanjo

    srjuanjo Member

    Yep I have tried but the issue is still there. However The issue with the minix´s led has been resolved, now when my minix is sleeping the power light is green, not light bluee like before. So I will stay in bios 1.4 which works well for me.
  10. gadgetuk

    gadgetuk New Member

    Is it also a bios problem with micro SD card keep disconnecting or is that a Windows problem? Cheers

    Sent from my Lenovo P2a42 using Tapatalk
  11. klapa

    klapa New Member

    I have v1.50. I would like to try the newer BIOS but would like a "way back" if needed. I have seen v1.40, v1.60, and v1.66links, but none for 1.50.

    Would it be possible to post a link to the 1.50 BIOS package?

    Of course, I am guessing that in addition to the BIOS EEPROM code for the main CPU there is also some smaller microcontroller on the board that has code included in some of the 'BIOS upgrades' and not others?
  12. Villa

    Villa Well-Known Member Super Moderator

    I've never seen v1.5
    It appears to have been skipped as a release!

    http://www.minixforum.com/downloads/download.php?file=Z83-4_V1.4_BIOS.zip
    http://www.minixforum.com/downloads/download.php?file=Z83-4_V1.6_BIOS.zip
  13. klapa

    klapa New Member

    Yea - I was afraid of that ;)

    I verified that by re-checking the BIOS screen Project info:

    CHT0A 1.50 x64

    Does the later BIOS code address the SD card issues? I just installed a 128Gb card Friday and yesterday (Saturday) tried that as storage for apps (programs) and had problems with Windows loosing the connection. In one case while installing an application I could only get out of this situation with a power cycle (plug cycle) boot.
  14. Villa

    Villa Well-Known Member Super Moderator

    As far as I'm aware the SD card issue lies with Windows 10.
    @MINIX - Ken keeps saying it is fixed with Windows update!

    I really must start using my Z83-4 to see if I have any of these issues! o_O:)
  15. klapa

    klapa New Member

    The Windows 10 installation did a massive update shortly after I first brought the thing up last week. For now I have disabled updates, as I don't want any drivers changing at this point.

    I have a particular dislike for Win 10 now that I've used it for a bit - the Home edition in particular pretty much takes control away from the user (no control of updates, bloated useless applications I can't get rid of, etc.). It's sort of Microsoft catching up with Google in the "control the user" technique of revenue generation.

    I'll just put up with the thing as it is for now. I might entertain the Linux install when it is certified by Minix. This unit as it is still seems the best route for what I want to do if I don't want to run Android - another tentacle of the Google family of monitoring and control.

    The support here from Minix directly and others is very good and was the primary factor in my decision to not send the thing back to Amazon.
    Villa likes this.
  16. jshrader

    jshrader New Member

    Following installing this BIOS I am no longer able to boot to a USB flash drive or PXE. I was able to previously. We are planning on using these in an enterprise/education environment and booting to PXE is critical for our purposes.
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I think so, have you tried yet?
  18. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    If this is happening to BOTH Ethernet & Wi-Fi, I would rather think the origin of the problems is the router instead of the pc.
    IPs are granted by the router.
  19. redcat

    redcat New Member

    Hi,

    Can you tell me please how can I select the option 4, that is:

    Select "Built-in UEFI Shell" because the arrrows dont work and I cant find any key that work. I already use 2 keybords and always the same problem.
    therefore I cant update but I have this anoying problem... of clock

    By the way what problem is this? Because with the firmware 1.4 i never had this problem is related with the 1.6?

    the esc button also dont work the only way out of bios is to power off the unit.
    Last edited: May 11, 2017
  20. mark2

    mark2 Active Member

    What type of keyboard are you using wired or wireless