1. Registration issues have now been resolved. New accounts are able to be created

RECOMMENDED: Z83-4 V1.66 BIOS & MCU firmware update

Discussion in 'NEO Z83-4' started by MINIX - Ken, May 3, 2017.

  1. redcat

    redcat New Member

    both non work
  2. redcat

    redcat New Member

    If I dont connect the pen drive I am able to use the up/down arrows however now If I connect the pend drive minix dont enter in the bios menus also...
    Amaizing the number of problems that the unit has I never have something like this.
    Since the begining I have problems and they continue even after 3 bios updates... At least the bios update could have been like the previous ones...

    How can I return to the 1.4 bios is possible right? How to proced? Because now the black screen and the clock issue are even worst than before.
    Last edited: May 11, 2017
  3. mark2

    mark2 Active Member

    Try the pen drive in a different USB port
  4. redcat

    redcat New Member

    no difference.

    Solved. I try another pen drive and now worked.... why I dont know both were in fat32.

    Now is updating let see if solve any issue.


    After update the hour should not be ok? Or do I have to adjust? Because was wrong of about 1 hour.
    Last edited: May 11, 2017
  5. Hammerhead

    Hammerhead Member

    I need some help..

    I can't get this to work... When in shell I type fs3 I get "is not recognized as an internal or external command.. Id I type dir I get can not open current directory no mapping ...
  6. redcat

    redcat New Member

    Hammerhead you are missing the ":" after the fs3. However I would not advise anyone to update. This dont solve any issue specially the Clock issue. After update The hour was wrong I adjust the hour as you can see in my last post I have done this around 10 PM now that is 12:47 the minix is saying that the hour is 10:57.

    How Ca I go back to the 1.4 Version please I need help to do this....

    By the way after I install the 1.6 version (not the 1.66) if he box stay on and I am able to see the TV (i.e. when HDMI works) I was getting a windows message saying error memory leak and I get errors related with the windows logon.... This only started after the 1.6 coincidence or not?

    The sound also dont works properly and this never was solved. Sometimes when I turn on the minix I have sound others no sound. When no sound I need to restart the minix to get sound. When these problems will be solved? And Yes I have the last drivers installed...
    Last edited: May 13, 2017
  7. LorryW

    LorryW New Member

    Hi, To let those who have the AC Power On issue know... installing this firmware update took about 15 mins and fixed the issue perfectly... Now, when I repower the computer, it boots automatically - saving me the agro of climbing into the loft following a powercut, to just to switch it on! :) thanks.
  8. redcat

    redcat New Member

    if it solves AC Power On issue good for you but dont solve the clock
  9. StudioTerminal

    StudioTerminal New Member

    Can I install V1.66 if I haven't updated before, or do I have to install V1.4 and V1.6 first?

    Thanks!
  10. Villa

    Villa Well-Known Member Super Moderator

    Just follow the instruction for V1.66
  11. WWHK

    WWHK New Member

    Glad to report that since update V1.6 (NOT V1.66), everything is going fine:
    - Wifi connection has been stable
    - No disconnection of SD card
    - AC on power on working all the time
    - System clock 100% accurate

    I also went to Device Manager to do a complete round of drivers update check, updating anything where a newer driver is available. Looks like the system has run in well with all drivers. Very happy with a super stable MINIX! Thanks to the tech team!
  12. Moganero

    Moganero New Member

    Just updated and no apparant problems but I still have no Wireless or Bluetooth adapter. Note I use a Spanish keyboard and the colon :)) in the boot menu is "ñ + shift".
  13. WWHK

    WWHK New Member

    Check network and Bluetooth adaptors in device manager. Uninstall them both and restart hopefully it should reinstall ok.
  14. WWHK

    WWHK New Member

    Oops...for the first time after having BIOS v1.6 for more than a week, my 64gb Samsung class 10 disconnected!!! I do have secondary programmes installed in that. Win10 version is 1607. Can we get a firm diagnosis whether it's a Win10 problem or an Intel driver's problem?? The disconnection is unpredictable and poses a lot of inconveniences as rebooting is the only way out. Thanks.
  15. WWHK

    WWHK New Member

    Think I've exhausted with finding an ultimate solution for the SD card disconnection issue. Will get a USB3.0 hub with integrated card reader as a permanent fix. Makes sense as the Z83-4 only comes with one USB 3.0
  16. gadgetuk

    gadgetuk New Member

    Been on bios 1.4 for over a week now, not had the disconnect SD problem.

    Sent from my Lenovo P2a42 using Tapatalk
  17. WWHK

    WWHK New Member

    Gadgetuk, are you losing the AC on Power on function, even though it has been set to enabled in BIOS? If not, I might try downgrading to 1.4, thanks!
  18. gadgetuk

    gadgetuk New Member

    Not sure I've not looked in bios for that, will do later if I get chance.

    Sent from my Lenovo P2a42 using Tapatalk
  19. gadgetuk

    gadgetuk New Member

    Right I have it set on in bios, what is it you are asking? As I've left it on at log in screen, then disconnected the power for 30 seconds, plugged it back in and it booted back up, is this what your asking?

    Sent from my Lenovo P2a42 using Tapatalk
  20. WWHK

    WWHK New Member

    Great, it's working then. I read from earlier posts that the auto on with AC on sometimes fails in V1.4, thanks!