1. Registration issues have now been resolved. New accounts are able to be created

RECOMMENDED: Z83-4 V1.66 BIOS & MCU firmware update

Discussion in 'NEO Z83-4' started by MINIX - Ken, May 3, 2017.

  1. gadgetuk

    gadgetuk New Member

    Well tried it twice and it still worked

    Sent from my Lenovo P2a42 using Tapatalk
  2. janglapuk

    janglapuk New Member

    It works for my device! (y)

    Thanks for the update.
    gadgetuk likes this.
  3. gadgetuk

    gadgetuk New Member

    Unfortunately yesterday I have kodi installed on my SD card, kodi crashed, then I went to restart but it couldn't find it, noticed the SD drive was missing, so unfortunately it's still the same in this 1.4 bios, but not so often by the looks of it.

    Sent from my Lenovo P2a42 using Tapatalk
  4. WWHK

    WWHK New Member

    The SD card disconnection issue seems more a driver problem than BIOS, something Intel and Windows have to work out. Short term solution is not to install softwares that will cost you loss of working data, as it happens without any prior warning. Or, an external card reader.

    So far I'm not seeing the SD disconnection since my device updated to Creators version three days ago. I'm keeping my fingers crossed that it won't happen again, as I did notice some drivers have been changed in Win 10 1703.
  5. minics

    minics New Member

    Maybe you could try the Better performance setting (as opposed to the default Quick removal) for your SD card as shown below. I think the image is self-explanatory. I'm using a 64GB card that I do not plan to "quickly" disconnect anyway :) The SD card came in exFAT file format but I re-formatted it in NTSF just to be on the safe side.
    Also shown in the picture are the disk drives configuration as per Disk Management and my current Windows and BIOS versions as per System Information.
    [​IMG]
  6. gadgetuk

    gadgetuk New Member

    Mm interesting, will try that to, I'm on creators update, so nothings changed the as it did it before.

    Sent from my Lenovo P2a42 using Tapatalk
  7. WWHK

    WWHK New Member

    I've been on "Better Performance" setting in day one, but still seeing the occasional disconnection of the SD. But after Creators Update, so far so good. My SD still remains as exFAT. If I still have the disconnection, I might try formatting it to NTFS.
    gadgetuk likes this.
  8. marc keller

    marc keller New Member

    Just wondering, is it risky to update the bios? I have version 1.4, does the newest version really improve performance? I´ve always thought updating the bios should only be done if absolutely neccesary, because if anything goes wrong, the pc will be more or less unbootable...

    Never mind, I just installed the update, no problems, everything o.k. :)
    Last edited: Jul 17, 2017
  9. jmagick

    jmagick New Member

    I updated too I had 1.5 it came with the box when I bought it I was worried about problems after the 1.66 update as I didn't have any issues before but I like to keep up to date. Since doing this update I have had the SD card disconnect once so it does seem to be an issue however it's only happened the once so far since the update. All in all though I really love my x83-4 very pleased with the purchase. I might buy another one actually that's how happy I am with it.
  10. Villa

    Villa Well-Known Member Super Moderator

    The BIOS update does not fix the SD card issue!

    SD card issue fix/workaround is here...
    http://www.minixforum.com/threads/solution-sd-card-problem.16628/
  11. Villa

    Villa Well-Known Member Super Moderator

    I see you have updated but if you read the first post you would have seen this...
  12. jmagick

    jmagick New Member

  13. Villa

    Villa Well-Known Member Super Moderator

  14. Richard Nicholas

    Richard Nicholas New Member

    Quick message to thank you for great instructions - a massive help!