1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Reflashing the Z64 Android OS (creating rescue disk)

Discussion in 'NEO Z64 Android OS' started by MINIX - Ken, Mar 11, 2015.

  1. leolas

    leolas Member

    This one has no password:
    MINIX - Ken likes this.
  2. Henkl33t

    Henkl33t New Member

    [​IMG][/url][/IMG]
    it dident work :( .error massage "Image type X64 is not supported by this IA32 shell" please help
  3. WeK05

    WeK05 Audio Visual Master Specialist

    What is it that you are trying to do? You have posted in Windows Install, Bios Conversion and Android Reflash threads.
  4. WeK05

    WeK05 Audio Visual Master Specialist

    Are you using Minix official Bios conversion files or the one from Lifeforce?
  5. Henkl33t

    Henkl33t New Member

    i downloaded Gadget Friendlys files
  6. WeK05

    WeK05 Audio Visual Master Specialist

    I have used Lifeforce files only once (They are not Gadget Friendly's files). I have since used Minix provided UEFI conversion files. I have never had a problem with them.
  7. Henkl33t

    Henkl33t New Member

    so gadget freindly is using lifeforce files. is it possible to use minix uefi converison files in this state ? and were do i find them ?
  8. Mr Doppey

    Mr Doppey New Member

    Hi All,

    New to this forum so my excueses I am asking a NOOB question.

    Can anyone confirm this really reflashes the Z64A with android the way it was when you received it.
    So If I have this Android Image I can do the switch to windows 8.1 (With other Bios) and back to android only using this IMG file?
  9. notjoe

    notjoe New Member

    Thanks for this. Had to flash back after a little stint with ubuntu!
  10. It does, you will notice no difference at all. Best way to think of it is flashing Windows first required the windows bios then you do the windows install. Reverting back to android requires you first install the android bios and then flash back android. In my experience with flashing android it takes approx an hour to complete so it is quite time consuming to do it but it does work.
    mercury16, Rui Alves and leolas like this.
  11. Solorzano

    Solorzano Member

    When I have all the files in the USB and get into EFI Shell, I get errors.

    parition using fs_type 'vfat'
    E:installer device ignored
    E:installer device ignored
    E:No valid installer medium found.
    Could not open /sys/devices/virtual/backlight

    It won' go past that. I downloaded the .img file 3 times and wrote the img file to my usb like 5 times and still keep getting this error. Any ideas?
  12. Higgs

    Higgs Yellow Dude Super Moderator

    I'm not a developer but I think the clue is in the first line - "parition using fs_type 'vfat'". Maybe the usb drive isn't formatted correctly.
    Did you follow the instructions in the doc exactly?
    Solorzano likes this.
  13. Solorzano

    Solorzano Member

    I thought of that too so I formatted the USB to different types then ran it through Win32Imager and noticed that the program formats it on its own to FAT32. I also tested the USB and know that the files are written correctly.

    My problem started after installing Xposed Framework. Now my Z64 goes through boot loops. I know that by creating a folder at the location data/data/de.robv.android.xposed.installer/conf/disabled will disable the framework which will let me boot correctly. If I can find a way to create that folder outside of the OS I will solve my problem.
  14. leolas

    leolas Member

    Try to use rufus program to write the img file to the USB disk
  15. Solorzano

    Solorzano Member

    I just tried Rufus and its a better program than Win32Imager but I still get the same problem. Thanks I was exited for a minute.
  16. fir_nev

    fir_nev Member

    How about trying to convert the .img file to .iso then writing it using YUMI?

    An old link for reference. Long shot; hope it helps.
  17. Rui Alves

    Rui Alves New Member

    Ty very much... ;) hugs!
  18. peterpiper

    peterpiper New Member

    I'm new to this, but could this mean you have booted to the BIOS for Windows (which is a 32 bit BIOS) then are trying to execute 64 bit code?

    Question:
    Answer:
    That answer is maybe confusing:
    Q. "back to android only using this IMG file?" A. "It does" .... a single step
    A. "you first install the android bios and then flash back android" ..... two steps, 64bit BIOS first then Android.
    I think it must be two steps.

    If I'm correct then look at Minix Neo Z64A to Z64W and reverse at freaktab site /forum/tv-player-support/intel-based-tv-players/minix-z64/24814-minix-neo-z64a-to-z64w-and-reverse (sorry can't post a link yet).
    That covers BIOS switch both ways and installing Windows, but not how to install Android.

    The instructions and video don't all match the download files now available. I'm about to post there a summary of what's been said and files needed. You'd need to follow the BIOS Install section, using the files from the extracted folder Z64 BIOS \windows-to-android

    Then come back here and install Android.
    Villa likes this.
  19. peterzane375

    peterzane375 New Member

    thanks for information
  20. atkinsm70

    atkinsm70 New Member

    Is it possible to do the flash process without a USB keyboard? The steps in the word document state:
    7. Connect the keyboard and USB drive to NEO Z64, boot your NEO Z64 while pressing F11

    But I don't have a USB keyboard available.