1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

FAQ Rockchip Drivers for Windows 8.1 - need help!

Discussion in 'NEO X7 Guides & FAQs' started by bakardi, Nov 14, 2014.

  1. bakardi

    bakardi New Member

    Hello,

    has anybody installed Rockchip Drivers on Windows 8.1? I have to flash fw 010 to Kitkat on my Minix X7 and I need to use Rockchip Batch Tool v1.7. I've tried to install drivers with Rockchip Driver Assistant but without success.
    Anybody that installed successfully drivers on Windows 8.1 Professional and may give me some suggestions on how to solve the problem?
    Thanks.
  2. I had this problem, but unfortunately I too had to find a Win7 laptop and proceed. Couldn't get things working on Win8.1.
  3. MaxeL

    MaxeL Active Member

    I think I found a way with Internet help to force RKBatchTool to work on Windows 8.1. It's working for me and I share that way with you. So, somehow I'll try to explain it.

    Download lastest drivers from HERE and unpack somewhere on your PC. Do the same thing like HERE (go to device manager, search for 'rockusb device' and update it from file - point folder with unpacked drivers). As of HERE, go to folder with RkBatchTool (for example downloaded with lastest Custom Community Edition ROM), open file config.ini and edit part from:
    Code:
    LOGFLAG=TRUE
    #SUPPORTLOWUSB=TRUE时,扫描支持full speed usb设备,默认只支持high speed usb设备
    SUPPORTLOWUSB=
    to:
    Code:
    LOGFLAG=TRUE
    #SUPPORTLOWUSB=TRUE时,扫描支持full speed usb设备,默认只支持high speed usb设备
    SUPPORTLOWUSB=TRUE
    I found that you can add another parameter: FULLSPEEDUSB=. After the change, the part of code will be look like:
    Code:
    LOGFLAG=TRUE
    #SUPPORTLOWUSB=TRUE时,扫描支持full speed usb设备,默认只支持high speed usb设备
    SUPPORTLOWUSB=TRUE
    FULLSPEEDUSB=TRUE
    Try it and tell me if it works. :)
    Last edited: Jan 16, 2015
    NoSubstitute, Teknicl and r4mios like this.
  4. baldojolly

    baldojolly New Member

    It works great for me. thks!
    MaxeL likes this.
  5. Zarek

    Zarek New Member

    I too have experienced this problem recently, and unfortunately the solution described here doesn't worked for me :(.

    But I solved the problem by editing directly the Windows registry.

    I share my solution, I hope this can serve someone:
    1- Install the driver provided with the firmware
    2- Connect the X7 with the reset manipulations
    3- At this state, Windows 8.1 detects the device, but indicate an error 43
    4- Edit the Windows registry (in command line: regedit)
    5- Go to HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/usbflags/2207310B0100
    The device number (last part) may be different, but I think it is the same for all Minix Neo X7.
    6- Add a new DWORD 32bit value, with the name SkipBOSDescriptorQuery and the value 1
    7- At this state the device may be correctly detected by Windows. Redo the reset manipulations if necessary.
    8- Add the line in the config.ini file of the flashing tool as describe in the previous message: SUPPORTLOWUSB=TRUE
    9- Flash your device

    This method tell to Windows to not check the USB BOS descriptor. It is not well contruct within USB's standard and this is only check since Windows 8.1. This is why this problem doesn't occur in previous Windows versions.

    Note that I had to redo the reset step several times. Indeed, the device would disconnect after a few minutes.

    I hope this will save you waste of time on this :)
  6. frugg

    frugg New Member

    HI Guys
    I've bought a MINIX NEO 7 and I am really desappointed, since it does'nt work properly (lags, crashes, ecc) and I cannot update my factory firmware to your latest community release. I have a WINDOWS 8.1 PC and it's not possible to install drivers to get the device recognised by the system. I've tried to follow the above mentioned instructions, but nevertheless it doesn't work and, anyway, IT'S UNBELIEVABLE THAT YOU SELL A NOT THAT CHEAP DEVICE WHICH DOESN'T WORK. Could you please at least upload in just one place all the drivers, fix, executable, video instructions we need to fix this mess?
    thank you
    Francesco
    Italy
  7. bachikho

    bachikho Member

    this is working for X7 on windows 8.1 but not for X5 mini yet
  8. nunorfa

    nunorfa New Member

    Thanks a lot Zarek your solution works for me.
  9. r4mios

    r4mios New Member

    ZareK thank You soooooo much. I was fighting with this whole day and tried dozens of "solutions" that never worked. I actually signed in to this board just to thank You. I was so frustrated and its so easy your solution.
  10. Sidik

    Sidik New Member

    I used X7 and windows 8.1 and this work, thanks for the guide
  11. Kbirkins

    Kbirkins New Member

    Zarek, would it be possible for you to post a more detailed tutorial with your solution?

    I have tried all the other internet methods for updating the drivers on my W8.1 computer- without success. I'm trying to update to the latest Kitkat firmware on my X7. I'm a rather casual computer user however and somewhat nervous about modifying the registry unless I'm completely sure of the steps. Screenshots would be the best of course but any additional guidence possible would be appreciated.

    Thanksin advance

    --a very frustrated Mininx owner
  12. Joakim

    Joakim New Member

    It appears there isn't a driver for windows 8.1 X64.

    The USB device number was not the same for me, so the above trick didn't work out after all.
    The only thing that really worked for me was to find a windows 7 computer.

    I found an alternate version on-line but because of stupid forum policies I´m not able to post links (yet).
    Anywa, it goes something like this:

    1. First download Rockchip driver USB fix archive from <links>. The archive contains two system files: usbhub.sys & usbport.sys (x64 & x86 versions).
    2. Go to your windows system32 folder and back-up these 2 files (e.g. usbhub.sys & usbport.sys)
    3. Then copy over yourself the provided 2 files from the link over the originals
    4. Restart your PC and Install RockUSB driver with Rockchip Driver Assistant and proceed as normal.

    There is a video, just search for "How to easily install Rockchip Rockusb Driver for Windows 8.1 x64" on youtube
    The post I found had the same name but in all caps and you should be able to find it with google as well:
    "HOW TO EASILY INSTALL ROCKCHIP ROCKUSB DRIVER FOR WINDOWS 8.1 X64 BIT"

    Run Rockchip Batch Tool v1.7 and if the first block is pink then press 'Switch' button to turn it into green. The press 'Restore' button to flash the new firmware on your Rockchip CPU device (in my case a RK3188 tablet).

    Don't wory trying the registry tweak above if you can find the key though, just export a copy of the key first first.
    If a USB-device wstops working, you should just be able to delete and re-discover it anyway. Or simply doublecklick on the expert to restore the default value.
  13. linhtran

    linhtran New Member

    This guide is great. I applied for my minix x5 mini (2207300A0100).
  14. cyloncity2

    cyloncity2 Member

    anybody have a clearer video/guide to flashing a minix x7 mini with unfortunately only access to a windows 8.1 laptop. the only videos I found are a little unclear to my small brain.
    thanks
  15. Villa

    Villa Trusted Helper Super Moderator

  16. cyloncity2

    cyloncity2 Member

    Thank you so much. I was really apprehensive in messing with the registry but gave it a go in desperation really and it worked. Followed your clear instructions carefully and happy as a result. Thanks again.
  17. lpws

    lpws New Member


    DUDE! Thanks a ton! This worked perfect on Win 10, x64.