1. Welcome to the official forum for MINIX devices!

[ROM] update.zip flashable Firmware

Discussion in 'NEO X5 mini Custom ROMs, Kernels & Discussion' started by gufone, Aug 7, 2014.

  1. john68

    john68 New Member

    I forgot to put my minix 5neo mini into mass storage mode and flashed it,the firmware goes on but it won,t start up anything I can do
    thanks
  2. Higgs

    Higgs Yellow Dude Super Moderator

    Hi John,
    Which firmware did you flash? I'm confused as to what you actually flashed and how. If it as this custom update.zip firmware then you don't need to put your device into mass storage mode, you just copy the file into the root of internal or external SD.
    If it was one of the offical firmwares flashed using the flashtool on the pc, then you shouldn't have been able to flash the firmware if not in recovery mode.

    In any event, your best course of action would be to flash the latest official firmware using the FlashTool

    http://www.minixforum.com/threads/neo-x5-mini-4-2-2-firmware-004-11th-march-2014.61/
  3. john68

    john68 New Member

    Hi higgs just to let you know im back up and running thanks for your help
    Higgs and HardwareGuru like this.
  4. luckyben

    luckyben New Member

    Unfortunately, still the same problem ... keeps on rebooting again and again ...
  5. jbern25

    jbern25 New Member

    Thanks for this! this is 100% working for me.

    Btw, i bought Minix Neo X5 Mini for few days now. And I have few question for being a beginner on this device.

    - Can I modify the official firmware? I mean I just want to remove some of the apk's that I don't like and add some that I want to be included for this device. This will also save some space on the internal storage to be available for app downloads.
    - Is there any way I can do to redirect the apps download to nand flash? or to my sd card?
    - If I download a rooted rom, will it work the same way as putting the zip on the root of storage and rename it to update.zip?

    I hope someone can help me on this.

    Thank you so much!
  6. jbern25

    jbern25 New Member

    Hi, what do you mean on flash on top the root and dp240 files? Thanks!
  7. jbern25

    jbern25 New Member

    it seems that the 720p firmware cannot be downloaded. do you have any mirror site to download? Thanks!
  8. BigD_ca

    BigD_ca Member

    Hey I appreciate all the help I've got on this site. I know I don't have the programming knowledge as most of you but I can make my way around. Here is what I'm having trouble with
    1) I would like to be able to watch movies in full 1080p
    2) I see the they're two stock fw available with one I want to upload is the 1080p
    3) I've read this original post how to install the fw but when when I d/l it its a zip file so when I click it using the remote I get an error message
    4) I need to extract the file & save it to root. How can I do this using a minix remote
    5) I using minix x5 mini
    Last edited: Nov 12, 2014
  9. jbern25

    jbern25 New Member

    you
    you dont need to extract it on your root or control it via remote. just download the firmware, rename it to update.zip and paste it directly to the root of your nand flash. then just wait for a prompt on your minix that there is an update detected. just hit okay and let it install and finish.
  10. BigD_ca

    BigD_ca Member

    I just downloaded Gufone 1080p wf & saved in internal flash under update.zip. After about 10minutes it prompted me to update but then gave me an error message not a valid update package

    Sent from my iPhone using Tapatalk
    Last edited: Dec 14, 2014
  11. Higgs

    Higgs Yellow Dude Super Moderator

    Try downloading it again with a download manager and check the sha1 signature when downloaded to check the file is Ok

    Sent using Tapatalk
  12. BigD_ca

    BigD_ca Member

    Hey Higgs thanks but I don't know where to d/l a download manager nor do I know the signature as d/l directly to my minix mini x5


    Sent from my iPhone using Tapatalk
  13. Higgs

    Higgs Yellow Dude Super Moderator

    You can use es file explorer, download manager.
    Look in playstore for a.sha1 checksum.calculator.

    Sent using Tapatalk
  14. JimBobVFR

    JimBobVFR Active Member

    I believe you should have ES Explorer on your box?

    Find he file in ES explorer, press and hold on the downloaded file to select it, click the menu and choose properties, on the properties box choose show checksum.
    Higgs likes this.
  15. BigD_ca

    BigD_ca Member

    I did a check sum now what do I do. Not sure what I'm supposed to see


    Sent from my iPhone using Tapatalk
  16. Higgs

    Higgs Yellow Dude Super Moderator

    Does the sha1 checksum match the one given fir the file in post2?

    Sent using Tapatalk
  17. BigD_ca

    BigD_ca Member

    I ran a check & it verified it & said it matched


    Sent from my iPhone using Tapatalk
  18. Higgs

    Higgs Yellow Dude Super Moderator

    Then the file should be ok.

    Sent using Tapatalk
  19. BigD_ca

    BigD_ca Member

    Here what I do step by step:
    1) I click on gufone 1080p fw
    2) I have the option to import or download. I click on download
    3) I download to a internal flash folder I names Update.zip
    4) I the. Also change the file name to Update.zip
    5) I reboot my minix mini x5 when a prompt come up to install update & then I get the error message
    6) not sure what I'm doing wrong if anything. Any help would be appreciated. Thanks to all those who have I'm still new at this

    Sent from my iPhone using Tapatalk
    Last edited: Dec 15, 2014
  20. Higgs

    Higgs Yellow Dude Super Moderator

    Step 3 is wrong. Do not put the file in a folder, put it in the root of the internal sdcard. (in ES file explorer put it in Home.)

    Sent using Tapatalk