1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

[ROOT][How To] Root, Unroot, System mods (no CWM / no PC needed)

Discussion in 'NEO X7 Custom ROMs, Kernels & Discussion' started by gufone, Jul 21, 2014.

  1. senos

    senos New Member

    Hello to all. I loaded the 4.4 ROM PRE-ROOTED Gufone'spre-rooted version of the MINIX NEO X7 KitKat firmware. I have two problems. the location in settings is inactive. I saw a message that in a previous version of android I had turned off. how can I activate it?
    second in spmc the image in film is only slightly upwards. How can I grow? Thanks in advance (sorry for my English)
  2. StanTek

    StanTek Member

    Can you use Wasser's OC Kernels on HardwareGuru's Community Edition 2.x custom roms?
  3. g_sahota

    g_sahota New Member

    please help me
    i insert the file update.zip in location / mnt/sdcard on minix neo x7 mini
    i am not getting update popup
    even SHA1 CHECKSUM is correct of downloded file.
  4. Villa

    Villa Trusted Helper Super Moderator

    You are in the Neo X7 section. I am not certain, but maybe what you are trying to achieve is not possible on a X7 mini!
  5. Mogge

    Mogge New Member

    Hi I´m on new X7 Kitkat v2.2.0 Community Edition Neo X7. Trying to do root (update.zip) from the 1st post. But getting "not valid package". Downloaded several times both from pc and direct to X7. Done the root before on the other older Fw with no problems. But now it doesn´t work. Checked the SHA-1 checksum and it matches the downloaded file. Any ideas??
  6. vn800art

    vn800art Member

    Mogge and gufone like this.
  7. Massi1965

    Massi1965 New Member

    Some way to install a custom ROM from a linux machine (ubuntu)?
  8. Hyrion

    Hyrion New Member

    Help! I tried to upgrade the firmware by following theguide but at some point the tool Rkflash crashes and says "firmware download fail" after you formatted the device, now going on does not appear at all, only the logo"minix"!! This is the log

    12:53:50 178 **********Restore Start Total<1>**********
    12:53:50 181 <Layer 1-1-5> Test Device Start
    12:53:50 183 <Layer 1-1-5> Test Device Success
    12:53:50 185 <Layer 1-1-5> Lowerformat Device Start
    12:54:03 189 <Layer 1-1-5> Lowerformat Device Success
    12:54:03 191 <Layer 1-1-5> Test Device Start
    12:54:03 194 <Layer 1-1-5> Test Device Success
    12:54:03 196 <Layer 1-1-5> Check Chip Start
    12:54:03 198 <Layer 1-1-5> Check Chip Success
    12:54:03 200 <Layer 1-1-5> Get FlashInfo Start
    12:54:03 202 <LAYER 1-1-5> INFO:FlashInfo: 0 0 0 1 0 20 20 28 1F 2 1
    12:54:03 204 <Layer 1-1-5> Get FlashInfo Success
    12:54:03 208 <Layer 1-1-5> Prepare IDB Start
    12:54:03 209 <LAYER 1-1-5> INFO:CS(1) (8192MB) (HYNIX)
    12:54:03 219 <Layer 1-1-5> Prepare IDB Success
    12:54:03 224 <Layer 1-1-5> Download IDB Start
    12:54:03 955 <Layer 1-1-5> Download IDB Success
    12:54:03 958 <Layer 1-1-5> Reset Device Start
    12:54:04 961 <Layer 1-1-5> Reset Device Success
    12:54:04 963 <Layer 1-1-5> Wait For Loader Start
    12:54:05 948 <Layer 1-1-5> Wait For Loader Success
    12:54:05 950 <Layer 1-1-5> Test Device Start
    12:54:15 956 <Layer 1-1-5> Test Device Success
    12:54:15 958 <Layer 1-1-5> Download Firmware Start
    12:54:49 453 <LAYER 1-1-5> ERROR:RKA_File_Check-->Memcmp failed,Read(0)
    12:54:49 509 <LAYER 1-1-5> ERROR:DownloadImage-->RKA_File_Check failed(system)
    12:54:49 512 <Layer 1-1-5> Download Firmware Fail
    12:54:49 515 **********Restore Done Success<0> Fail<1> Time<59343>ms**********
    Last edited: Mar 12, 2015
  9. vn800art

    vn800art Member

    Nvm, it was a different HW!

    Inviato dal mio Nexus 5 utilizzando Tapatalk
  10. pouzy

    pouzy New Member

    Hi Gufone,

    Would you have that pre-rooted ROM for X7mini ?

    Thanks !
  11. Igor Guerra

    Igor Guerra New Member

    How do I add a custom boot load image?

    Can I use the Boot Animation Factory to generate the "bootanimation.zip" file and replace it in the update.zip that Gufone published? Would that work? Is there a better way?

    Thank you!
  12. gufone

    gufone Big Owl - Developer Super Moderator

    If you just replace the bootanimation.zip inside the update.zip it will not work. You will broke the update signature.
  13. Igor Guerra

    Igor Guerra New Member

    Thanks for the reply Gufone!

    Is there a easy way to do it? I already tried to use Kitchen to rezip and realign a firmware on other Android device but it didn't work so good.

    If there isn't a easy way to do, is there a guide on how to do it?

    Thank you so much.
  14. StanTek

    StanTek Member

    You can use "Root Explorer". Navigate to the system\media folder and rename the bootaninmation.zip file there and copy your custom one. Make sure the file permissions are the same as the original. Make sure you have Twrp recovery or CMR recovery installed in case it doesnt work. I recommend Twrp latest version it has way more features to use at the root level.
  15. Doug Nelson

    Doug Nelson New Member

    are the certificates to sign these updates public?

    I have a service app I want to install in system/app. I've got to do this on 100 devices and don't want to root them. I could create an update.zip I'd I had the right certificate to sign it.
  16. Gabi

    Gabi New Member

    Hi, i have KitKat Version 240 installed and i need to root my device ,witch version should i choose?
  17. Villa

    Villa Trusted Helper Super Moderator

    Last edited: Aug 5, 2015
  18. Gabi

    Gabi New Member

    It worked, thanks.
  19. shibub

    shibub New Member

    Hello,

    I am looking for the re-rooted file

    gufone-rooted-NEO-X7-216A_2014.7.17.4.4.002.zip

    The link in the main posting above is broken. Can you please point us in the right direction?

    I also tried the update.zip to root a minix 7 which is running 4.4.2 and it kept complaining about an incorrect format on the zip file. What options do I have to root my X7? This is in order to run apps that let me connect PS3 controllers like the sixaxis drivers.

    Thanks,
    SB
  20. Higgs

    Higgs Yellow Dude Super Moderator

    Which firmware do you have? If it is the offical KitKat V240, then the root update files are provided in the post with the firmware.