1. Welcome to the official forum for MINIX devices!

Scan New Content - no longer gets movie/TV series info

Discussion in 'NEO U1' started by Sherpa25, Aug 13, 2017.

  1. Sherpa25

    Sherpa25 Member

    Hi, need help pls. Using latest FW and XBMC 16.3 on my U1, films in NAS (2 Red drives, 2 USB drives).

    Doing a 'Scan For Content' for newer vids (movies or TV series) no longer gets information (ie. fanart, etc) for the new vids. All are still set as before (Movies-IMDB, and TV Series). Tried to remove Movies as source in content, and then back again to Movies to refresh, but still doesn't get new content. Just scans briefly, then says at the top 'Compressing Database' then returns.

    I tried individually too, but it keeps asking for the file name, and even editing the file name to the movie name and year, it still doesn't accept/recognize it.

    Any ideas?
    Last edited: Aug 13, 2017
  2. skynet

    skynet Well-Known Member Trusted Helper

    Hi Sherpa,

    The information server may be down or your Kodi module isn't up-to-date.
    I just tried to get informations for new movies with Kodi 17.3 and it's working fine.

    Sent with my S7 edge
  3. Sherpa25

    Sherpa25 Member

    Sorry, can you clarify, what's the Kodi module, how do I have it updated?

    Is there another way to check if information server is working? It's been like this for a long time already, so I'm not sure about it being down all these time. Thanks.
  4. skynet

    skynet Well-Known Member Trusted Helper

    It's a Kodi add-on. I'll check the name tomorrow.
    Can you try with Kodi 17.3?
    You can install it beside xmbc.

    Sent with my S7 edge
  5. Sherpa25

    Sherpa25 Member

    Thanks, will wait for that module name, so I can check it out.

    I read somewhere that Kodi 17.3 needs Marshmallow, which I'm not using, is this accurate?
  6. skynet

    skynet Well-Known Member Trusted Helper

    No you can install it on U1. It requires android 5.

    Sent with my S7 edge
  7. skynet

    skynet Well-Known Member Trusted Helper

  8. Sherpa25

    Sherpa25 Member

    Might try Kodi 17.3 soon (hopefully this weekend). Not enough time yet to do this as we open the U1 only at night to watch and don't want the family to be waiting :).

    I'll check that fanart scrapper first in settings. But I understood this should already be installed as default in U1's Kodi? Or does it need a 'manual' update?

    FWIW, tried individual TV series last night and scan was fine. It's only in movies (2 drives in my NAS) where the issue still happens. Thanks.
  9. Sherpa25

    Sherpa25 Member

    FWIW, movie scan worked after I changed source to Universal Movie Scraper, from MovieDB (w/c I used for a long time, like a year already). Dont know whats happened with MovieDB.

    Small issue with Universal Movie Scraper, there are some movies that dont have fanart, only the poster and description. Any idea how to address this in the U1?


    Sent from my iPad using Tapatalk
  10. Frederick_99

    Frederick_99 Well-Known Member Trusted Helper

    its nothing to do specifically with the U1.....its a kodi issue and probably best asking for help over on the kodi forums...don't mention any 3rd party addons though ;)

    probably just a glitch in the movie database scraper that will sort it self out soon anyway
    Last edited: Aug 16, 2017
    Sherpa25 likes this.
  11. Sherpa25

    Sherpa25 Member

    I see, anyway, it's not critical, thanks.
  12. JeroenR

    JeroenR Member

  13. Smartie36

    Smartie36 Active Member

    I finally managed to fix this & what a relief as the universal movie scraper was slow as hell to scan and literally took over an hour to scan my movies in and got quite a few wrong!

    To cut a long story short the tmdb & tvdb scrapers don't work in the minix build anymore as they are old versions and because the version number of those addons have '67' added to them I couldn't update them but finally sorted it & I'm scraping new movies and tv shows as we speak.

    Fixing it requires editing the version number of these two scraper addons, this wouldn't be necessary if minix hadn't been using weird version numbers for these two addons, spmc also uses the same version numbering hence why I also had the same issue with that until I applied the same fix with that too.



    Sent from my SM-G935F using Tapatalk
    augur likes this.
  14. Sherpa25

    Sherpa25 Member

    Thanks for the headsup. Can you share how you edited the version, and update?
  15. jph33

    jph33 New Member

    I Think smartie36 talks about the solution exposed here: https://github.com/koying/SPMC/issues/944
    But i tried and for the moment i didn't achieve to solve the Problem.

    Envoyé de mon HUAWEI VNS-L31 en utilisant Tapatalk
  16. jph33

    jph33 New Member

    Ok succeeded. I download the tmdb scraper and the common tmdb library. Unzip them. Then edit the addon.xml file and Added 67 before each version number
    3.9.5 become 673.9.5 and 2.16.0 become 672.16.0. In the tmdb scraper addon.xml i changed the referenced version of the tmdb common library From 2.13.1 to 672.16.0.
    Finally i saved everything and rezip all and did an install From zip for both addons. Then all was working perfectly !

    Envoyé de mon HUAWEI VNS-L31 en utilisant Tapatalk
  17. jph33

    jph33 New Member

    This morning i tested the tvdb addon and it succeeded too. If someone wants i can share the corrected zip files for the 3 addons. Let me know.

    Envoyé de mon HUAWEI VNS-L31 en utilisant Tapatalk
  18. Sherpa25

    Sherpa25 Member

    Great, yes pls, thanks!
  19. Smartie36

    Smartie36 Active Member

    That's different to the way I fixed the scraper, I never unzipped any archives, I edited after installing but your way is quicker, especially if needing to re-install in the future, I'm forever choosing the long winded method instead of the quick and easy way lol.

    Sent from my SM-G935F using Tapatalk
  20. jph33

    jph33 New Member

    Here they are...

    Attached Files:

    augur, kingsizept and Sherpa25 like this.