1. Welcome to the official forum for MINIX devices!

SD card nightmare

Discussion in 'NEO Z83-4' started by Sandokan01, Sep 2, 2017.

  1. Sandokan01

    Sandokan01 New Member

    Hello,
    I am struggling with my Z83-4 unit since when I bought it with a big sd card issue.
    The problem is that while I am moving or copying big files suddenly it blocks saying that the device is no more available.
    The destination folder every time is corrupted, I have to fix it with internal Windows tools, it works again for awhile and soon after again with this problem.
    I have changed a Samsung 64GB, Kingston 64 Gb, Sandisk 64 GB and 128 GB(using the procedure on the forum to allow to Windows to see them) sdcards Always with the same result.
    I already tried to reset the unit and the problem happens only with microsd, with usbkey or disk everything works well.
    It's useless to say that all sd cards works smoothly elsewhere.
    Has someone some advice to help to solve me this issue before drop definitevely minix hardware that was for me really a bad experience with 4 units (2 Z64 and 2 Z83-4).
    thanks
  2. Villa

    Villa Well-Known Member Super Moderator

    http://www.minixforum.com/threads/solution-sd-card-problem.16628/
  3. Sandokan01

    Sandokan01 New Member

    I have already applied that guide to allow to Windows to detect Sandisk sdcards even if the driver shown dramatically reduce transfer performance.
    I am right now again trying to reset minix and will start new tests