1. Registration issues have now been resolved. New accounts are able to be created

Shared folders/files not showing in XBMC (Windows Network SMB) - My solution

Discussion in 'Kodi/XBMC for MINIX' started by Thomas_NoTech, Jun 30, 2017.

  1. Thomas_NoTech

    Thomas_NoTech New Member

    I actually just signed up, to pass on my tip, in case anyone else ends up spending 4, I kid you not, 4 days trying to find shared folders in XBMC, via my router, from my pc.
    I have gone over everything, every setting on my computer, restarted my network adapter, changed sharing permissions, changed God knows what & no matter what I did, I still couldn't see s**t on my Minix box.
    Anyway, very long story short, this is what I did to make it work:
    Network settings, sharing settings are set to standard settings, tons of easy guides online for this, so not going to go over this.
    Start by running an ms dos prompt and type "ipconfig" (without the ").
    Go to XBMC on you Minix, choose Videos, files, next choose Add videos and in Add Video Source choose Browse. Go to the bottom option that says Add network location. In this, all you need to fill in is the ip address of your computer. This will give you the ip address of your pc as the top one. Type in the numbers (mine was something like 192.168.0.138) and click Ok. (No username and password, unless your settings require this in network sharing on your computer).
    Afterwards find the smb address you've just created from the list of connection options and you will be able to see and select your shared files. I tried over and over, and over, to find my shares by starting out with Windows Network (SMB), because all the guides I could find told me to do so. And I couldn't find anything, since I hadn't added the network location itself first.
    This may all sound stupid to people who knows this, but as I said it took me days to figure out, because I didn't know if a windows 10 update or a AVG update had messed up my sharing settings.
    Anyway, hope this will be of use to others than just myself.
    And love my Minix and my XBMC, so never give up trying.
    Also, as a side note, I read somebody tried to activate the wifi, but it kept switching off, whereas ethernet worked fine.. The guy ended up returning his Minix due to this. But if he'd just removed the ethernet cable, before trying to switch it to wifi, he would have seen it works just fine, only not with both connections active at the same time..
  2. Villa

    Villa Well-Known Member Super Moderator

    Which MINIX device do you have?
  3. Thomas_NoTech

    Thomas_NoTech New Member

    I have the U1 model.