1. Registration issues have now been resolved. New accounts are able to be created

SOLVED - Google Play won't download and install apps

Discussion in 'NEO X8-H Plus' started by toredge, Nov 12, 2015.

  1. toredge

    toredge New Member

    When I first got my box and started setting it up, I was able to download and install Kodi from the Google Play store, no problem. But now it just cycles endlessly when I select an app to install. The progress bar just loops and loops until I finally give up and abort.

    My Google account is added under the Settings, and everything else related to the account seems ok. My internet connection is wired, and stable. I've tried flushing the Google Play and Google Services cache and the app data, and it seemed to work, but after one download it goes back to getting stuck on the download/install stage.

    Does anyone know what might cause this? Is there any way to fix it? Thanks.
  2. mchp92

    mchp92 Active Member

    Go into Settings / Apps and clear all data and cache of PlayStore. Then it will download again. I have had same issue cpl times before
  3. toredge

    toredge New Member

    Thanks -- I have tried this and it will work for a bit, but then it goes back to looping again with no progress. I'm wondering what the cause is, and if it can be permanently corrected. Users shouldn't have to constantly flush the data and cache each time they want to download something from Play.

    Not everyone experiences the problem, so there must be "something" that causes it for some of us, either on Minix end or Google end. I have never experienced this issue on any other device, only my Minix box.
  4. toredge

    toredge New Member

    The issue is now resolved.

    Clearing the cache and data did not solve this issue, nor did any of the troubleshooting steps from Google. But here is how my issue was resolved, if anyone else has this problem:

    In the Play Store, I went to my account settings and clicked on My Apps. There were several apps trying to update, but all were looping in a "waiting for network" state (btw, my connection was ok, so I have no idea why they were in that state).

    I clicked "Stop" to stop the update process. This somehow cleared the jam and I was then able to go back to the main Play Store page and download and install apps normally.
  5. Nirv4nist

    Nirv4nist Member

    It's a bug. When you try and install a new app and if there are existing apps trying to be updated, the new app will not download. In fact the existing apps will also go in a loop and get stuck.

    The trick ( and not a fix) is to stop the update of the existing apps and then start the update all process again. Once you do that, the existing apps will update just fine and then you can download the new app.

    What you mentioned is actually a work around. Not a fix.

    Sent from my SM-N910G using Tapatalk
  6. toredge

    toredge New Member

    Thanks for the clarification.

    When I switch activities using my Harmony One, the Minix is sent a sleep command. Google Play must be in the process of updating and experiences a sudden dropped connection. Even when the connection is "restored", it does not recognize it until the update process is stopped and restarted. I haven't tested whether this issue happens on wi-fi (I'm wired).