1. Official MINIX forum

[SOLVED] HDMI CEC problem on Samsung TV

Discussion in '[Bugtracker] Official 002 firmware' started by RadekV, Dec 3, 2014.

  1. RadekV

    RadekV New Member

    Hello,

    I have a problem with HDMI CEC on Samsung TV, CEC is working automatically only after X8H reset.
    If I switch to another source - RaspberryPI with OpenElec and back I'm not able to use CEC in X8H anymore.
    The only solution is navigate to Tools menu on TV (select Source on remote), select Anynet+ HDMI-CEC, perform Refresh action and choose Minix box.
    After this I'm able to use CEC to navigate on X8H again.
    RaspberryPi with CEC is working without problems for months...

    My setup:
    Samsung UE46F6750, model from 2013
    HDMI1 - Minix NEO X8H, official 0002 firmware, updated from Beta8 without Wipe data
    CEC control: CEC switch = ON, One key play = ON, One Key play = OFF, auto change language = OFF
    HDMI3 - Raspberry Pi, OpenElec

    Is this a known behaviour?
    How can I help developers to debug/resolve this issue?

    Thanks

    Radek
  2. Higgs

    Higgs Yellow Dude Super Moderator

    When I have cec activated on my X8-h, It shows up as a separate source in the Samsung TV sources e.g. I have TV, HDMI1 - Minix X8-H, HDMI2 - DVD Player, Anynet+ - Minix X8.
    When switching sources back to X8 after watching a different source, I choose the Anynet+ source and CEC works.

    (I'm guessing at these source names as I'm not near my TV, but it will be something similar to this.)
  3. RadekV

    RadekV New Member

    Maybe it depends on model of TV, what TV do you own?

    After playing with a CEC control = switch off, switch on, my remote starts working again.
    So CEC is working but announcing this functionality on TV is not OK in my setup.
  4. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We checked on Samsung TVs, from old 32" of 5 yrs old to 4K model of this year.
    They all work fine with the Anyne+ console.
    Anyway, we will try to look into that.
  5. Higgs

    Higgs Yellow Dude Super Moderator

    Not sure of the model number, it's a Samsung smart led 3d tv.
    The screenshot below shows what I mean about selecting the anynet source. My x8-h is on hdmi3, but if I change source then I have to select anynet (HDMI CEC) to go back to the x8 with cec working.
    [​IMG]

    Sent using Tapatalk
  6. dramroo

    dramroo Member

    How to use this CEC with my TV? uploadfromtaptalk1417719840330.jpg

    Sent from my HUAWEI G700-U10 using Tapatalk
  7. RadekV

    RadekV New Member

    More findings about CEC in my setup:

    If I use a "Source" button on my remote, switching from any source to Minix box CEC is not working.

    Using a "Tools" button on remote, choosing "Anynet+ (HDMI-CEC)" option and next to point a "Minix NEO" CEC is working!!!

    Thanks Higgs to point to another way!

    Because there is another way how to properly choose a CEC device I'll mark this thread as SOLVED.
  8. srbutt

    srbutt New Member

    Hi
    This seems interesting, so my question is this feature available on X5(the device I have) so that I can use my TV remote to navigate Minix box. I have Samsung series 5 TV.
  9. Higgs

    Higgs Yellow Dude Super Moderator

    No its not available on X5/X7 models.
  10. RadekV

    RadekV New Member

    Just a small note about latest FW 003 - 20150207-release keys.

    Right now Minix CEC is more "aggressive" after first TV turn-on in my setup.
    If I try to switch to Raspberry PI (another HDMI port) using Tools - Anynet path for the first time Minix switch to itself. It never happens next time until I'll turn TV off.

    It not a bug from my point of view but little annonying.
  11. Sion Cohen

    Sion Cohen New Member

    Have same problem here with 55U6400 samsung, it is annoying to choose CEC instead of just moving to source (in tv menu).
    Raspberry pi is working ok with same tv.

    please fix update and not say SOLVED.