1. Registration issues have now been resolved. New accounts are able to be created

SOLVED - Samba Share Not Working

Discussion in 'NEO X8-H Plus' started by Mark112887, Jul 10, 2015.

  1. Sion Cohen

    Sion Cohen New Member

    nslookup 192.168.1.18
    will give you hostname
  2. Sion Cohen

    Sion Cohen New Member

    BTW, how unsafe is that password and user are known to all ? can smb be access from internet ? or is it restricted to local network.
  3. kalbit

    kalbit New Member

    Nope, minix x8h+ is fully capable of having samba which supports large files. I've installed optware on my minix and the samba which came with it has no problems with large files (The biggest one I have has 16GB, samba reports correct size and the file plays without any issues).
    I'm running 007 firmware and I followed ghinda optware guide (sorry, you need to google it, I can't post links).
  4. Mattia

    Mattia New Member

    With ubuntu linux connection time out, nautilus and file zilla!!!
  5. Les Thomas

    Les Thomas New Member

    I am now able to easily transfer files directly from my PC to the hard drive attached to my Minix X8-H thanks to suggestions on page 1 of this thread. I too have discovered the connection has to be frequently reset owing to losing connection. I too have the problem regarding larger sized files. I have checked out the ghinda optware guide but do not feel confident enough to give it a try. I guess I would just download the "Samba" as referred to on the guide website but I am not sure.

    Some detailed instructions to install this version of Samba would be good. Would I have to uninstall the Samba already on the Minix?
    moopage likes this.
  6. PacoC

    PacoC New Member

    Mapping the Samba Share as a Network Drive on a Windows 10 PC
    I did exactly what is above mentioned by Villa and it works very well, I am able to see every thing in the Minix. I have my Movies and TV Shows folders in my HDD as external USB storage so I mapped the folders. I have a problem when I power off/restart the Minix because the folders' mapping is lost then I have to mapp them once again everytime I start the Minix. Could anyone help me to solve this problem?.
    Thanks in advance.
    moopage likes this.
  7. PacoC

    PacoC New Member

    Everytime I start my Minix it shows the ES Explorer window. How can I change that?
  8. TGAMO

    TGAMO New Member

    Its an option in settings
  9. Villa

    Villa Trusted Helper Super Moderator

    I guess that there is a USB storage device connected!
    Just to expand on that!

    ES File Explorer, Settings, Display settings, USB plug-in message (Un-check)
  10. PacoC

    PacoC New Member


    Yes I have an HD conected
    Thanks a lot to TGAMO and Villa.
    In any case I decided to uninstall ES then install xplore. It is much more friendly for me.
    Villa likes this.
  11. kodlz

    kodlz New Member

    Hi guys. Any news about solution for large file transfer over samba?
  12. kodlz

    kodlz New Member

    is't any update with large file transfer over samba? or I need open new thread?
  13. moopage

    moopage Member

    How much speed through samba read and write you guy got?
    my one is
    PC to MinixU1 is 2.2MB/s
    MinixU1 to PC is 2MB/s
    My connection is PCGigabitLan>GigabitSwitch>PowerLineLan ZyXEL PLA4201(500Mbps)>MinixU1
    I quite confuse Mbps of Powerline is 500Mbps maybe from first floor may lost speed about half.
    So at least should get speed about 250Mbps=29-30MB/s isn't it?
    I wonder MinixU1 is 10/100/1000Mbps Lan port so it should be more speed?
    Do you anyone try with wireless too?
    Or speed is limit to read/write performance of MinixU1 too? I don't know technical data about this matter.
    Anyone can suggest?
  14. lalalala

    lalalala Member

    Real Powerline bandwidth is a lot less than nominal. It must also divided by 2 (in/out) if i remember well.

    Inviato dal mio LG-D855 utilizzando Tapatalk
    moopage likes this.
  15. moopage

    moopage Member

    Thank you for advise.
    So you means PowerLine may show 500Mbps but when actual may got only half speed at 300Mbps right? (with full speed connection status:GreenLight)
    I just saw my connection of PowerLine show Orange Light which mean medium so maybe another have speed from actual or more worst.
    Will try again with direct Gigabit Lan cable.
  16. lalalala

    lalalala Member

    My 400 powerline get 20mbit and 80mbit at best.

    Inviato dal mio LG-D855 utilizzando Tapatalk
    moopage likes this.
  17. moopage

    moopage Member

    Its nice si you mean 40-80Mbps (4-8MB/s) right?
    I just wonder why when I transfer is max at 20Mbps(2MB/s) but with internet speed test it goes more higher at 30Mbps(3MB/s)
    Do any one know have any android app can test Lan Speed?
  18. Villa

    Villa Trusted Helper Super Moderator

  19. Peter F Model

    Peter F Model New Member

    My experiences with the standard NEO smb matches the comments above, low speed and some form of file transfer limitation, I am guessing its something to do with FAT32. I also have occassional issues with windows telling me i can't copy a file due to lack of space at the target end.

    Coming from a WDTV background where i can easily copy BluRay quality MKV files from a windows PC to a WDTV , I was hoping to replicate this. I am coming to the conclusion I am better off placing all my video's on a NAS (linux running smb) and then running all my videos on the NEO from the NAS. So far it works well, must better than doing the same with my WDTV. I suppose the NEO had a larger cache and can handle MKV 1080p video's.

    But it would be nice to get smb working on my NEO in those cases when my network gets hammered* and i am forced to run my movies from the local USB drive. (* = copy video files from my windows PC to the NAS).

    My initial guess is if the 2GB file limitation (I have not tested if its exactly 2GB, only there is a limitation, so I basing this from this thread) is something to do with FAT32 support in ANDROID (I think ANDROID has problems writing NTSC, although its seems to read it ok) then there is no simple fix. For those running other smb products such as SambaDroid, do you see the same limitation.
  20. Les Thomas

    Les Thomas New Member

    I too have graduated from the WDTV to Android TV boxes. I streamed from the drive I had attached to my WDTV as a 'networked' drive and streamed my movies and TV show files from the WDTV attached drive to my Minix. There was no drive attached to the Minix in my setup at all. It worked perfectly. I was able to copy files from my PC to the drive attached to the WDTV at around 6mb per sec.

    There was a program for the WDTV website called WD Discovery. I ran this, was able to add the WDTV drive as a network drive, and could then access it from all devices in my home.

    The WDTV needs to be in standby for the network drive to be visible across the network.

    Possibly worth a try?