1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

[SOLVED] Screen becomes green/purple

Discussion in 'NEO U1' started by Foreman34, Jan 6, 2016.

  1. mahertheone

    mahertheone New Member

    Hi

    I have a Phillips 42pfl5604h (a 42' TV made in 2009) & keep getting the green screens *even* with the latest firmware & the RGB mode.

    It seems to be more frequent in 1080p than in 720p resolution, but otherwise - there's no way to avoid it completely. I hope a fix can be add in future Firmware.
     
  2. Aristothenes

    Aristothenes New Member

    NEO U1 and Samsung UE40KU6400U LED 4K Ultra HD Smart TV does the same thing.
    Using the standard U1 remote, turning off and then on again resolves the problem but is irritating.

    U1 has FW011
    HDMI version is 2.0a
     
  3. mahertheone

    mahertheone New Member

    - Try to change the resolution - it usually fix it for a while. Also try 720p (50 or 60) resolution.

    I wonder if it has to do with the graphics chip of the unit.
     
  4. mahertheone

    mahertheone New Member

    Try with resolution of 1080i 24Hz - no green screens so far.
     
  5. mahertheone

    mahertheone New Member

    [SOLVED]
    I think
     
  6. mahertheone

    mahertheone New Member

    Unfortunately not. Still green screens, even with the new FW (Feb 17').

    EDIT (22/5/2017) - SOLVED finally. When starting the U1, go to settings & disable the RGB. Go back & enable the RGB. The screen will turn green. Now plug out the HDMI cable and then plug in. it will revert to normal.

    Check it by turning on & off the RGB Mode - when On, there won't be any green screen. That is, until the next restart... No cure for that, Yet.
    (edit - 30/11/2017)
     
    Last edited: Nov 30, 2017
    mike113 likes this.
  7. animest4r

    animest4r New Member

    This happens to me if i put the minix neo u1 to suspend and resume mode when i press the power button. So i set the power button to shut down and turn on when pressed.
     
  8. Flora

    Flora New Member

    I've tried everything suggested in this thread and nothing works with my Sony Bravia KDL-46Z4500. Still get green/purple screen. Can't find what level HTML it is (1, 1.3, 1.4 ?) but it is certainly not HTML 2. Although I love my U1 Looks like getting a Minix with all the bells and whistles was a mistake. Is there another Minix that will talk to a Sony Bravia with an earlier version of HTML?
     
  9. mike113

    mike113 New Member

    i have a Sony KDL-37EX401 which was effected by this issue too. I used to own a Minix Neo X8-H plus which never suffered from this. Anyway I updated the firmware in the TV as well as the latest FW Feb 2017.
    I tried what was advised above and so far it's working, havent tested for long enough to be 100% certain. One thing i notice, the image isnt fitting exactly the screen size it's at 99% but if the purple/green effect stays off i can live with the screen size.
     
  10. mike113

    mike113 New Member

    Still switching to green/purple every so often, very random, very disappointed with this box! have tried all the suggestions here, so will Minix maybe look into it and come up with a solution?
     
  11. Casper562

    Casper562 New Member

    I fixed the issue i have an older phillips tv. Set to force rgb and i connected a plater 3 to 1 switch (hdmi)
    1080p 60hz
    Not a green screen in sight.
     
  12. Gili elias

    Gili elias New Member

    Hey you can give more details please also i have an old philips tv and minix u9 with the same problem
     
  13. antonioSLB

    antonioSLB New Member

  14. Flora

    Flora New Member

    Anyone still having problems, try a factory reset. This is the only thing that worked for me.
     
  15. Oreny1306

    Oreny1306 New Member

    Hi i have philips 65PUS8700 4k.
    And have the same problem (green screen)...
    But the big issue is that i run the media from smart tv application not from hdmi hw connection.
    What can i do icant change resolution in the app...
    There is way to set it on the tv?
    Tx for your help
    Oren
     
  16. mahertheone

    mahertheone New Member

    The hardware in the Philips set is usually too weak to run a new (H264 encoded) video files. Try a Streamer - they're really cheap now.
     
  17. Stefan Pantea

    Stefan Pantea New Member

    Hi Gents,

    Our context:
    - LCD Philips 32PFL7694H/12 (2010 I think)
    - U9-H octa-core media hub from Minix updated to the latest firmware etc.
    - moderate expensive basic HDMI cable.

    Symptoms:
    - green / pink screens almost every 20mins. when U9-H connected to Philips via the HDMI;

    This was far from ideal when you choose to pay money for an octa-core media hub (not cheap for latest U9-H!) which makes you think you may need to spend even more on a new 'smart' TV. We are just happy with our 32inch LCD Philips (not 8K but excellent HD quality though) worth every penny.

    Read all posts and everyone's pain with similar issues. I was almost on my foot to lunch it on flash sale on eBay... but found something it helped us and may help others.

    Solution 4 steps:
    1. Force RGB Ouput: ON
    2. Display Screen Resolution: 1080p-60Hz
    3. (note this one: which made the difference for us) Display Screen Resolution: More Setting: [Color Format and Depth]: RGB10bit
    4. Reboot both TV and U9-H box and enjoy your octa-core media hub...

    Solved for us, solid HDMI ouput on our old 2010 Philips.
    I can say MINIX tried to support for this however there is a lack of understanding of the entire community how all these options are working together. If this fixes your problem just say
    Thank you.


    Force RGB ON.jpe Screen Resolution.jpeg More Setting Format and Depth RGB10bit.jpe
     
    kingsizept likes this.
  18. Stefan Pantea

    Stefan Pantea New Member

    I wish to have discovered earlier AntonioSLB's solution which is the same combination of settings (his post it's just above... ;(), with no additional hardware is required.
     
  19. mahertheone

    mahertheone New Member

    Well done.
    Unfortunately, the 10Bit RGB option does not exist on the NEO U1 streamer. So for its users, there's still the need to turn on & off the RGB mode & connect and disconnect the HDMI cable after every restart...

    Hopefully, someone at MINIX may want to add this 10Bit option for the next Firmware...
     
  20. Dog's dinner

    Dog's dinner New Member

    This problem started for me yesterday. My Minix Neo U1 has performed superlatively since I bought it one and half years ago. Now all of a sudden the interface is reduced to 25 %, the image is massively enlarged, the colours are wrong, and it's nearly impossible to navigate.

    The minix is connected to a Marantz receiver (SR7008), and from there to the TV (LG Oled 55C6), all via hdmi cables. Nothing has changed over the past week or so apart from connecting a Qnap server to the receiver.

    I've tried disconnecting the Minix from the mains for more than 5 minutes, and have checked the cables. Everything is fine in that department. Anybody at Minix know what the problem is and how to resolve it? (By the way, firmware is the latest edition.)
    Minix TV screen.jpg