1. Welcome to the official forum for MINIX devices!

[SOLVED] Screen becomes green/purple

Discussion in 'NEO U1' started by Foreman34, Jan 6, 2016.

  1. Villa

    Villa Administrator Administrator

    Have you tried connecting directly to the TV?
    Have you tried a different TV?
  2. Dog's dinner

    Dog's dinner New Member

    Good idea. It worked. The picture was back to normal. I tried plugging the hdmi cable into other inputs on the receiver, but no luck there. It seems like there's something amiss in the Minix's connection with the Marantz. But what could it be. Would it help to factory reset the Minix?
  3. Villa

    Villa Administrator Administrator

    I have no idea! Worth a try though. Make sure you backup any data first.
  4. Dog's dinner

    Dog's dinner New Member

    I'll give it a shot anyway. Can't be worse than it is now. I might ask people on the Marantz forum. I'm sure others have experienced something similar. Anyway, thanks for your help, Villa, so far, and I'll keep you posted!
  5. Dog's dinner

    Dog's dinner New Member

    Just did a factory reset, but that didn't help either.
  6. Dog's dinner

    Dog's dinner New Member

    Ah, just realized I've wiped the entire system out, so no access via the Minix interface (there isn't one anymore) to download and flash/OTA the firmware/software to rebuild the system. (Don't know what OTA means, but I've seen it used a lot in the forums.)

    Anybody know which firmware to download which I can put on a usb stick and get Minix up and running again?

    Sorry to be such a bother!
  7. Villa

    Villa Administrator Administrator

    How have you wiped out the entire system?
    If you performed a Factory reset all should be good.

    Did you perform the Factory reset from the Recovery menu?

    OTA - Over The Air
    http://searchmobilecomputing.techtarget.com/definition/OTA-update-over-the-air-update
  8. Dog's dinner

    Dog's dinner New Member

    Hi Villa,

    No, I think I've done exactly what you told me not to do. I'd entered recovery mode by pressing the 'on' button for about 30 seconds. That brought me to a list of options. I went for factory reset, but when I was asked whether I wanted to delete everything, I clicked 'yes' thinking they only meant apps like Kodi - I don't use any of the others anyway, and I wanted to update the Kodi version on Minix. But when it restarted, I ended up with a completely blank screen. I went back into recovery mode (i.e. got a cup of tea from the kitchen), and tried various ways of loading/installing/recovering the basic software, but I knew instinctively that I'd messed up, and wouldn't find a copy of the software anywhere on the device itself.

    So I had a trawl through the updates sections and found the FW013 - 20170629 firmware release. I'm going to read the instructions (NEO U1 full system image reflashing guide) for a change, and hopefully, later today, the Minix will be up and running again. I'll need the micro cable apparently, but it's anyone's guess where that is. I've been redecorating the house for the past year, and nothing is where it's supposed to be anymore. I hope I can perform the operation with a usb stick instead of plugging the Minix into the computer.

    I'm feeling better about this than I did last night, and I'll keep you posted on progress as promised.

    Thanks for the OTA explanation :)
  9. Dog's dinner

    Dog's dinner New Member

    Well, I had another look yesterday, and I had chosen the factory reset option, but with wiping of all personal files. Nothing like a fresh start. I'm going to buy some high quality hdmi cables and see if they help. At the moment, because only part of the interface image is visible on the telly screen, it's difficult to navigate.

    By the way, I couldn't find the micro cable, so I transferred the img file to a usb, plugged it into the Minix, and tried to boot/update from the file, but the Minix couldn't see it for some reason. I included the unpacked rar file on the usb, but that wasn't visible either.
  10. Dog's dinner

    Dog's dinner New Member

    Just to revivify the thread here. I succeeded in the end to install the latest firmware using a ubs stick. (I also found the missing minix-usb cable.) The colours are improved, but only a portion of the interface is visible on the TV when the signal is routed via the Marantz receiver. I've purchased new hdmi cables (2.2 capable), and they've made no difference.

    As I think I mentioned before, the Minix works fine when plugged directly into one of the TV's hdmi inputs, it's only when it passes through the receiver the problems occur.

    Anyway, even if it did work, I can't access any of my files anymore. Whenever I try to connect with the computer via the smb channel, I'm told the argument is invalid. That's the next big issue to solve. It's been like this since I did a clean install of Windows 10 a month or two ago. It didn't matter then, because all the files were in the Kodi library on the Minix. Now they're not, and can't be retrieved either, unless somebody has a bright idea.

    Happy new year, by the way!
  11. FifthMeridian

    FifthMeridian New Member

    Hi. I get a totally green picture, on occasion. I am using the Neo-U1 to feed a Samsung UN55JS8500 SUHD TV (a 4K UHD TV). I have been lucky, thus far, to be able to fix the problem simply by a power-down and a reboot of the Neo-U1.
  12. Dog's dinner

    Dog's dinner New Member

    Yes, FifthMeridian, I've powered the U1 up and down umpteen times over the Christmas period, with absolute no effect. I've actually been in touch with a nice guy at Minix in Hong Kong, who suggested in the end to contact the maker of the receiver, Marantz, directly. Which I'll be doing when I get a chance. I'm just beginning to wonder in our age of planned obsolescence whether the UI might be made to run out of gas after a year or so.
  13. Dog's dinner

    Dog's dinner New Member

    I think I'll just buy a new media player. I'm currently thinking of the HiMedia Q10 Pro, which has garnered some good reviews.