1. Official MINIX forum

[Solved] Video stutter on MPEG2 (live TV and recording)

Discussion in 'NEO X8-H Plus' started by Mitchellross, Oct 12, 2016.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

  2. Villa

    Villa Trusted Helper Super Moderator

    Yes!
  3. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I confirmed both video samples play fine on U1 but not X8-H PLUS,
    we shall fix this problem, give us some time.

    U1 - Kodi ok, system movie player ok
    X8-H PLUS - Kodi not ok, system movie player ok

    It should be one of the fixes that we have introduced on U1 which fixed this issue.
    Menorca Man and Villa like this.
  4. Mitchellross

    Mitchellross New Member

    Excellent thanks very much guys.
  5. CrocAu

    CrocAu Member

    I reported this months ago, would be great to see this fixed, I prevents me from using two MINIX boxes way I want because TV is unwatchable yet it works fine on elchipo pc on the stick :(
  6. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We could have handled it much earlier if we could get the problem files earlier.
    As always, we need to see the problem so that we may proceed.
    Dr Goodvibes and HardwareGuru like this.
  7. Dr Goodvibes

    Dr Goodvibes Active Member

    Must commend @Mitchellross for some good problem reporting.

    It's a pleasure for everyone when someone takes the time to make a reproducible problem report.

    I put the video on my NAS and played it over a ~20Mbits 802.11n WiFi connection on a Minix X7 running Kodi 16.0 and it played fine.
    Using the NAS and not a local file, I had to advance the audio sync by 0.465s, but that's no biggie.

    The thing is, it should play fine as it's just a Standard Definition 576p video and not even 'good' DVD quality.


    Minix X7

    Android: 4.4.2 (240)
    WiFi: 802.11n (~20Mbits/sec)
    Source: QNAP TS-251 NAS
    LAN: 1GBit
    Monitor: DELL U2410 UltraSharp IPS
    Player: Kodi 16.0
    Video Playback: (y) No Stutter




    Minix X8H-Plus


    Android: 4.4.2 (008)
    Ethernet: 1GBit
    Source: QNAP TS-251 NAS
    LAN: 1GBit
    TV: Sony 48W600B
    Player: Kodi 16.0 AND Kodi 16.1
    Video Playback: (n) Stutter (video frame drop)


    When I play the video using BSPlayer Pro on the Minix X8H-Plus, it plays fine from my NAS over 1Gbit without any visual/audio problems.

    I note there are two encoded video streams, it looks like a thumb nail video for fast forward/rewind aka the same as you'd get with a YouTube video.

    Fig 1-1 Video played in BSPlayer Pro on Minix X8H-Plus plays fine.
    BSPlayer.Info.png

    P.S. Now looking for Protein Powdered Marinade (PPM) cause it's "Amazz"......???
    Last edited: Nov 7, 2016
  8. Mitchellross

    Mitchellross New Member

    Thanks all, appreciate the interest, but would love it if we could stay focussed. (y)

    @Dr Goodvibes many thanks for your tests on your X7. And you've reminded me to think more about the choice of video clip for next time - this really is the worst that Australian TV has to offer.

    Have we got any further with this issue? I'm wondering whether it has something to do with pts time stamps. I have no idea what I'm talking about really, but I do recall seeing similar behaviour when toggling an old openelec switch called prefer pts timestamps.
  9. Villa

    Villa Trusted Helper Super Moderator

  10. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    The problem is fixed, we shall release a new firmware (011) shortly.
    Mitchellross and Dr Goodvibes like this.
  11. CrocAu

    CrocAu Member

    fantastic news
    hope it comes before xmas :D
  12. Dr Goodvibes

    Dr Goodvibes Active Member

    @MINIX - Ken and Minix Team, Thank you very much.
    You continue to show that buying a Minix box is a no brainier for support and updates.
    In a few months I will have had by Minix X8H Plus for over two years and to read you are still providing updates/fixes places you into a VERY rare group as far as Android support goes.
    Big players like Sony and Samsung may support a device for one and maybe two years, depending on popularity, but generally never beyond that.
    I see your initial Minix X8H-Plus fw release noted as 30-NOV-2014, this now places you over two years of support for an Android device ... and continuing.
    Guess you can start to write your own rule book on extended Android support, as look around, who else is still going after the extra mile has been completed.

    So, big thanks from me and Minix forum for all your support and a very happy festive season.
  13. CrocAu

    CrocAu Member

    Been a while just wondering if there is any workaround for this that we could use while we waiting for new firmware
    Mitchellross likes this.
  14. Spellbound

    Spellbound Member

    There is new firmware out, discussion here.

    But there is no news yet as to what has been changed in this update.
  15. Mitchellross

    Mitchellross New Member

    Update not coming through on my OTA yet. Very keen to give it a try though.
  16. Villa

    Villa Trusted Helper Super Moderator

  17. Mitchellross

    Mitchellross New Member

    Happy Chinese Lunar New Year guys.

    Have just updated to Firmware 11 - and the issue is indeed resolved. Many thanks to @MINIX - Ken for fixing the issue. And also to @Villa and @Dr Goodvibes and others for testing and helping identify/confirm the original issue.

    Great support - much appreciated!