1. Welcome to the official forum for MINIX devices!

SOLVED!! Yet another passthrough issue - promise it's a gooder!

Discussion in 'NEO U9-H' started by Grencola, Oct 2, 2017.

  1. Grencola

    Grencola Member

    Haha ok, ill keep it quiet ;)

    Hit 'n Miss AVRs:
    Pioneer Elite VSX-1131-K
    Marantz NR1508
    Pioneer Elite VSX-01TXH

    100% Working:
    Marantz SR5011
    Pioneer VSX1122

    Makes no sense really as those AVRs work fine with my other HD Audio devices :eek:

    Cheers.
    EricE likes this.
  2. Duncan Singleton

    Duncan Singleton New Member

    My Samsung k950 doesn't want to play any TRUEHD or TrueHD ATMOS what so ever. DD+ ATMOS works fine... Pulling my hair out as Got the U9H As WRXTASY said that it was supported :(
  3. Grencola

    Grencola Member

    Duncan you're hooking it up to your tv directly via arc or using your AVR? Regular arc is only good for the formats you listed, so you won't get HD audio that way
  4. Duncan Singleton

    Duncan Singleton New Member

    No direct into soundbar. I have my UHD bluray player in hdmi 2 and minix in 1. Then output is to TV, NO arc used
  5. Grimmyn

    Grimmyn New Member

    Like to add that I have given up on Android/Minix/Kodi for now due to the problems with audio.
    And made an LibreELEC usb boot stick instead read on forum for libreelec.tv
    It boots fast (on a fast usb 3.0 stick) and now EVERYTHING works! :)

    Note that I tried SD card to no use and messed around with other USB sticks and differnet dtb.img before I got it to work.
    Somehow very tricky with no reason. Used the original dtb.img (as I found after a long while) and it worked fine as I tried different USB sticks.
    Grencola and Duncan Singleton like this.
  6. Duncan Singleton

    Duncan Singleton New Member

    Never mind, got ATMOS TRUEHD finally working!!!!!!!!!!!!!!! thanks man.
    Last edited: Oct 22, 2017
    shablamy, Grencola and Grimmyn like this.
  7. EricE

    EricE New Member


    Grencola,

    Did you ever find a solution to your hitor miss passthrough problem?
    I am having the same issue...
  8. Grencola

    Grencola Member

    Erice, nope :(
    The only fix seems to be that you gotta use either a different AVR or Box :/ No matter what I try they never work together with HD Audio.
    EricE likes this.
  9. EricE

    EricE New Member

    Oh well thanks Grencola.

    I worn't replace my pre/pro for a while so I guess I'll have to look for a different solution...
  10. MCussans

    MCussans New Member

    Tell me how... have the same soundbar... i can still only get sample files to work, any of my other media files that are ATMOS just do not flick out the ATMOS signal...
  11. shablamy

    shablamy Member

    I also just bought the k950 and the only atmos media via Kodi 17.6(FW007) i get to work is the one from dolby's website:

    No Atmos from these:

    PLEASE SHARE what you did to get ATMOS to work? Really thinking of LE at this point...
  12. MCussans

    MCussans New Member

    Libreelec was the winner. All sounds amazing now, every file working on Atmos. Hopefully Minix can identify the difference in real pass through to make this easier for all. :)
  13. wrxtasy

    wrxtasy Active Member

    Just out of interest what Software did you use to flash the LibreELEC image and also which Brand / Speed of SD card or USB Stick please ?

    I'm trying to track down why some U9 LE users are having issues booting after flashing LE images.

    PS. I'm assuming Atmos comes with HDR video, so just as a reminder SSH Login to LibreELEC:
    https://wiki.libreelec.tv/accessing_libreelec

    And issue this terminal command for 10bit HDR output: (needed once only) (y)

    Code:
    echo "echo '444,10bit' > /sys/class/amhdmitx/amhdmitx0/attr" >> /storage/.config/autostart.sh
    Last edited: Nov 26, 2017
  14. MCussans

    MCussans New Member

    Hi wrxtasy,
    i think this is what you are asking for:

    Just using a generic Verbatim 8Gb usb stick, usb 2 im pretty sure - old one.

    Downloaded the S912 arm-8.2-8.2.0.1 img gz, unzipped to a folder then created image via 'win32 disk imager', completed all via the PC.

    followed instructions, for the most part, via youtube - cant post links sorry, but if you search 'Amlogic S912 LibreELEC 8 KODI 17.3 Dual Boot Guide Tutorial' you should find the same video.
  15. Wes Brown

    Wes Brown New Member

    i bought the u9-h box because of the hdmi pass through licensed dolby 5.1 feature. if i cant just plug it in and it works with my onkyo receiver, i am
    not interested and sending it back. all of these comments are way too much trouble to figure all of this junk out.
  16. wrxtasy

    wrxtasy Active Member

    The problem all along is U9 LE users have been using the incorrect device tree file (.dtb), the correct one is now in this thread:
    https://forum.libreelec.tv/thread/1...eo-u9-h-could-not-mount-label-libreelec-disk/
  17. MCussans

    MCussans New Member

    Went to watch a movie tonight in Atmos (first time in a few weeks). Suddenly not working... Unsure if Samsung sound bar, software or Minix....

    Sent from my HTC 2PS6200 using Tapatalk
  18. MCussans

    MCussans New Member

    Soundbar.... Had to unplug at PowerPoint and restart it... Uggghhhh! Won't be going Samsung again.

    Sent from my HTC 2PS6200 using Tapatalk
  19. Marwell

    Marwell New Member


    Thank you! Finally no sound problem. The installation was easy with this video tutorial. Thank you again for sharing this!
    MCussans likes this.
  20. Thomas9406

    Thomas9406 New Member