1. Welcome to the official forum for MINIX devices!

Source Slow From QNAP

Discussion in 'Kodi/XBMC for MINIX' started by Violentsoul, Dec 10, 2017.

  1. Violentsoul

    Violentsoul New Member

    Hello ,

    im new to minix and kodi .

    i encounterded an issue with slow source on my Kodi that pulls 4K videos from my QNAP .

    some information on what i have :

    - Minix neo U9
    -Kodi 17.3
    -QNAP 2-Bay with 2 HDs Seagate Barracuda HDD 4TB Sata III ST4000DM004
    -1G Local Network.

    i saw that i need to configure the advancedsettings.xml on my Kodi so i did with the following configurations.

    <advancedsettings>
    <cache>
    <buffermode>1</buffermode>
    <memorysize>420000000</memorysize>
    <readfactor>4</readfactor>
    <curlclienttimeout>45</curlclienttimeout>
    </cache>
    <video>
    <subsdelayrange>0</subsdelayrange>
    </video>
    <splash>false</splash>
    <enablemultimediakeys>true</enablemultimediakeys>
    </advancedsettings>


    the splash endicator works becouse i dont see the Kodi logo on start up screen .

    and after all this my 4K/Blu-ray movies are not working its like buffering for two present and then i have a smooth video for 4-5 min and then stuck again.

    any suggestions?

    thanks.
  2. pusb87

    pusb87 Well-Known Member Trusted Helper

    to see if its your network or NAS causing the issue then place the video file either on a fast usb stick or in the minix memory and play from there....
    Katalyst and Villa like this.
  3. Violentsoul

    Violentsoul New Member

    Hey , i have tried to run via NFS on another windows computer and it worked well.
    today ill try to copy to USB stick and run on minix and update .
  4. pusb87

    pusb87 Well-Known Member Trusted Helper

    i know a lot of people say NFS is better but Ive always used SMB and not had any issues
  5. Violentsoul

    Violentsoul New Member

    um , im already so lost with this NFS SMB .

    - I use SFTP to access my NAS and Put Files port 22.
    - tried with Stick all works great (Probably Protocol to slow) .

    when i try to clock NFS on Kodi it just dont access it like kicks me out immediately .
    when i click SMB its empty (QNAP is LINUX) .

    already googled it all looks so messy .

    any ideas or suggestions?
  6. pusb87

    pusb87 Well-Known Member Trusted Helper

    in the add source dialog of kodi's file manager browse to the Add network location" option, choose the Windows network (SMB) option, and then enter the IP address of your NAS into the Server name box
  7. Violentsoul

    Violentsoul New Member

    i clicked on add "network location" then SMB with IP of NAS .
    then i clicked on browse and it showed me only smb:// thats all if i click ok its says its unable to connect .

    and if i do //192.168.0.101 from pc its working . also its opened to everyone so no cred are needed.
  8. skynet

    skynet Well-Known Member Trusted Helper

    You need good credentials to able to be connected with SMB.
    My advise :
    - create a new account / password in Nas side (ex : Kodi / Kodi)
    - Give your videos folder R/W access to this account
    - in Kodi, type SMB://Nas_IP
    - in credentials type Kodi and Kodi

    Works fine here with a Synology Nas
    Katalyst and Violentsoul like this.
  9. Violentsoul

    Violentsoul New Member



    Dude Works like a charm !!!!
    only with creds this works even is the folders are open for everyone.

    but it was shutting after 15 min each time like quiting to home screen . so i deleted the advancedsettings.xml .

    and walla everything work with SMB . thx mate thank you all .
    skynet likes this.
  10. skynet

    skynet Well-Known Member Trusted Helper

    (y)
  11. Sydes

    Sydes New Member

    Is there a setting on the nas i am overlooking but this only works with my admin account and not with any other username / password i made.

    Thx
  12. skynet

    skynet Well-Known Member Trusted Helper

    Put your new created username into administrator group, or give it the good folder accesses.
  13. Sydes

    Sydes New Member

    Thx Skynet... But it does not work.

    Tried adding New user under admin Group and using this in kodi but it can not connect. Tried adding normale user... Does not work. (all of course with right priveleges). Only the original admin account can connect.

    Any Idea? Or other qnap user That Got this Working for smb?

    Thx
  14. skynet

    skynet Well-Known Member Trusted Helper

    Hi,

    Did you shared your folders with your created user ? (Read / write access)

    You can also try with NFS protocol. Kodi works fine with it.
  15. Sydes

    Sydes New Member

    Yes i did. Read That smb is The fastest way, if you are using Version 3.0 with jumboframes. Is this correct?
  16. skynet

    skynet Well-Known Member Trusted Helper

    In my test with a Synology, NFS is faster. I didn't tried with jumbo frames.