1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Start over

Discussion in 'NEO X8-H PLUS stock firmware' started by GaiusPrimus, Feb 14, 2016.

  1. GaiusPrimus

    GaiusPrimus New Member

    New to Minix but familiar with settop boxes. Anyways.

    Picked up my Minix 2 days ago. Got it installed, updated and Kodi setup. Next morning, went to show the wife how to use it and box kept either freezing and making a scratchy noise or the black screen without any response from mouse/keyboard (A2 Lite).

    Only way to reset was to pull the power and restart, but it was happening every time I got to the video addon section of Kodi. Tried installing Kodi from Play Store. Would get to the same point and it would freeze.

    I installed Showbox and that worked without any issue, so did PLEX and Youtube.

    Then I thought that maybe the Repo was the problem (1channel), and installed another one (Icefilms). System then started freezing at startup.

    I'm wondering if there's a way to start over, but the file provided here for the stock firmware is in .rar and the device is not recognizing it. I have an apple computer without bootcamp so I cant do the OTG setup.

    Any help will be appreciated but I'm on a losing battle already.
    Last edited: Feb 14, 2016
  2. ENDRJUPL

    ENDRJUPL Well-Known Member Super Moderator

    I would suggest to borrow a windows pc and flash the latest firmware. That's the only way to start over if something messed up your system.
    lmcder1 likes this.
  3. Villa

    Villa Trusted Helper Super Moderator

    I recommend Option 1 here...
    http://www.minixforum.com/threads/x8-h-plus-updating-the-firmware-not-via-fota.8331/
  4. GaiusPrimus

    GaiusPrimus New Member

    I was able to revive an old windows 7 laptop. Will attempt and repost. Appreciate the help.

    Just a quick clarification. I should not start from stock and upgrade FOTA? Should go straight to latest?
  5. GaiusPrimus

    GaiusPrimus New Member

    Update: I was able to install the latest Firmware. Everything seemed to be working fine until I went into the resolver settings for 1Channel on the Minix Kodi app. Then started getting the black screen again. Will transfer this convo over to the right folder.
  6. ENDRJUPL

    ENDRJUPL Well-Known Member Super Moderator

    Then it has to be a problem with that addon.
  7. GaiusPrimus

    GaiusPrimus New Member

    Posting this here as I'm not getting any responses on the firmware forum.

    I'm transferring this over from the stock firmware forum folder.

    Basically got a Minix X8 H-Plus 3 days ago. Got it installed, worked fine the first night. Went to show the wife how to work it the next morning, and was getting one of two problems. One was a black screen with no response, second was a screeching noise from the TV with no response. This first started on Kodi, but then started happening anywhere. (I don't have issues on Youtube or Plex though)

    Used an SD card to attempt to reflash the firmware, problem continued.

    Revived an old laptop running windows 7 to Flash using the USB tool. Success. Didn't seem to be any issues until I went into the Resolver settings of the 1Channel Addon on Kodi and black screen came back. Power cycled and black screen happened again on the first 10 seconds on home screen. YouTube and Plex work without any issues.

    Cleared the data from the XBMC minix app so it would show as an initial setup, because someone mentioned that 1Channel could be the problem. Installed a different add-on and it happened again.

    Faulty box or am I missing something?

    Extra: Also, running on Ethernet not WIFI and also attached to a Samsung TV as I've read that can be an issue. Will try on a Vizio I own and confirm back.
  8. Villa

    Villa Trusted Helper Super Moderator

    @GaiusPrimus
    Please stop re-posting the same issue in other Forums! As you have realised, it doesn't help sort out the issue any sooner!
    Thank you.
  9. Higgs

    Higgs Yellow Dude Super Moderator

    If you are on the latest firmware (you can confirm this by posting your build number) then I'd suggest you do a factory reset and test without opening Kodi.
    If everything is working okay then you can try again with Kodi, try without any addons, e.g playing local media to see if there are any issues. Then you can try some addons.
    This might help pinpoint the cause of your problems.
  10. GaiusPrimus

    GaiusPrimus New Member

    Thanks.

    I flashed the 008A that Villa suggested earlier in the thread (20160114). I just redid it and will try out local file play on Kodi. Not seeing any issues still with any of the other applications.
  11. GaiusPrimus

    GaiusPrimus New Member

    Local media seems to be working fine. The only thing i did different up to this point this time around is install regular Google Chrome, as opposed to the beta.
  12. GaiusPrimus

    GaiusPrimus New Member

    Been playing local media for the last few hours without any issue.