1. Welcome to the official forum for MINIX devices!

Static pop/clicking sound

Discussion in 'NEO U1' started by Valentino25, Sep 28, 2016.

  1. Sean369

    Sean369 Active Member

    Post #52 in this thread. MINIX - Ken said.

    We can't reproduce it... have you considered the chance that your unit is just a faulty one?
    I mean... I'm using it almost every day, if there are pop sounds, I would have noticed that for a long long time.

    So I would say Minix knows but as they can't reproduce the issue it's kinda hard to fix. I've never noticed any popping or clicking noises on my U1.
    Villa likes this.
  2. mehgurd

    mehgurd New Member

    That's horrible support. If they "know" then they probably have a bunch of returned devices laying at their office and they should be able to reproduce it with those.
    I'd even be glad if they came out with an official statement: "We know we have some faulty units out there, serial number starts with XXX- , they are faulty because YYYY, send them back until you get a working one.

    Telling me "I MIGHT have a broken one" DOES NOT fix the problem for me and leaves me wondering what I should do with this box.
    I've seen a lot of people here sending their units back time after time and they always end up with the same problem. Why would I waste my time on doing the same.

    At this time I'm starting to regret me saving a few bucks to buy the U1 instead of the NVIDIA Shield which clearly is THE box to buy momentarily, based on support and community.
    Lessons learned I guess.
    Last edited: Jan 28, 2017
  3. quazatron

    quazatron New Member

    Hi,

    I have this issue too. My U1 is a couple of days old. Latest firmware, I've only tested XBMC so far. Have been watching streamed movies through an add on. As previously mentioned, the rate of 'ticks' is proportionate to the intensity of the audio, so if there's a bassy soundtrack I'll hear it every 7 seconds or so, but a movie without a soundtrack might not show it. (Update: It turned out to be the volume of the ticks that is proportionate, not the rate - rate is always 7 seconds)

    Setup to achieve DD 5.1:
    - Minix is configured for digital audio over HDMI
    - XBMC is set for IEC Passthrough, 2.0, optimised, stereo upmix is off, resample quality medium, enable pass through, only AC3 and E-AC3 are on of the 4
    Minix - HDMI - Samsung OneBox - optical out - Receiver
    Have also tried
    Minix - optical out - receiver

    The movies I've been watching were actually all 2.0 sources so far

    Tests:
    1. Audio out of TV speakers, ticks
    2. Audio out of one box optical, ticks
    3. Audio out of minix optical, ticks

    Test 1 is effectively HDMI only and test 3 is effectively optical only - two different types of output and both show the issue, so this is looking like a software issue.
    Despite this, I did try swapping the HDMI cable with my high grade PS4 Pro one, and naturally there was no difference.

    I note that one post on here said that issue disappeared after enabling transcoding in Kodi, but I note that I see no option for transcoding in XBMC. I'll keep an eye on this forum for a few days in the hope it can be replicated, but may have to use the return window on my Amazon order.
    I've just noticed 'Enable audio DSP processing', which is off and says it needs an add on to work - will read up to see if this is something I need enabled.

    Update 1: just changed from IEC Passthrough to PCM, with and without pass through enabled, still clicking, and this time I timed it and yes it's every 7 seconds, but like I said, only when a lot of audio is playing like end credit music. Actually, I think the tick volume scales linearly with the audio volume, rather than tick or no tick. With headphones on, I can tell it appears at varying positions in the left to right sound field.

    Update 2: I installed Kodi 17 and do see the additional AC3 transcoding option. I get the ticks at 7 seconds with or without it enabled.
    Last edited: Feb 5, 2017
  4. mehgurd

    mehgurd New Member

    Hi quazatron, thank you for your extended troubleshooting.
    I can add that the 7 second interval ticking sound is not limited to XBMC or KODI alone. You can also hear the ticking in the android YouTube app so this is NOT XBMC/Kodi related.
    According to me this is an issue with the device itself. I found some possible causes for audio glitches like a lot of users here are experiencing and posted them somewhere in this thread but I guess they haven't been checked by the developers.

    I really wish people would take this issue serious. I don't consider "I don't hear them and I use it every day" to be adequate troubleshooting as the intensity of ticks can vary from content to content as stated multiple times in this topic.
    @MINIX - Ken , @MINIX - John - can we get a serious investigation for this already? Is there somewhere else we/I need to report this issue to be taken serious? Or is this issue just going to be ignored until a new minix device comes out?
    Clearly, this is an issue that hits lots of users, please get it fixed!
  5. LocoMujik

    LocoMujik New Member

    Same problem in my U1 listening music in Power Amp and other players.
    Sound slightly distorted and clicking as on a vinyl disc. :confused:
  6. dryster

    dryster Active Member

    I have a similar phenomenon on my NEO X6 with a random audible "pop" on the audio that sounds like static.

    The setup is NEO X6 -> HDMI -> TV -> Amplifier

    Note that if I swap my Q-Box into the same setup, there are no pops. It only happens with the Minix. I am running 008 firmware,
  7. Kev02

    Kev02 New Member

    Has anyone come up with a fix other then what's been mentioned? I just bought this box the other day and it's the first thing I noticed when watching a movie. I've tried all of the above. Still not working. It's too bad. Really like the setup of the box. I'm wondering if I return it and get the kahosi ll but when you read online about that android box, you hear the marshmallow OS isn't the greatest for Kodi playing.

    Any help would be greatly appreciated.
  8. Cacildo

    Cacildo Member

    To be fair, i just got my password for the forum back because the clicking sound really sucks

    I got everything right in my set, finally found the right HDMI cable for ARC, everything is perfect.... except the clicking sound

    I cant reproduce exactly the problem. To me it seems to be random. But feels like everytime a "heavy"* soundwave starts, its just when the wave is climbing.... CLICK!


    I thought maybe i was ignoring some obvious setting, but it seems to be a more popular problem than i expected

    My settings:

    - Using the recomended XBMC, updated
    - The System is updated
    - The other setting possible to be updated is already updated (i really dont get why does this have 2 systems that can be updated)
    - Minix plugged at the TV using HDMI cable
    - Tv plugged on receiver using HDMI cable, ARC setting working fine for everything
    - No clicking sound when whatching Regular TV or any app from the Smart Tv set (i normally use Netflix and Youtube from the Smart TV instead of the Minix Options)


    *that makes sense in my language
  9. chriscr

    chriscr New Member

    Hi,
    I have a vague memory of this happening to me about a year ago.
    The "interrupt" interval always stayed the same, and it sounded to me like it was the junction between 2 packets of audio data, without a clean join between them. ie a momentary dropout.
    It was very obvious on the long notes at the beginnings of Star Trek (2009) or The Lone Ranger.
    I have HDMI to the TV (Picture only) and SPDIF optical to the amplifier.
    I think I fixed it by changing the "Playback Settings/HDMI Self adaption" setting.
    Back then my TV only did 50/60 fps, and I had to default it to 60 to get 24 fps movies to render motion in a reasonable fashion.
    Now my 4K TV does 24, 25, 30, 50 & 60 fps and I'm on HDMI Self adaption level 2.
    Try changing that setting to see if the "clicking" problem alters.
    If it doesn't help, then that's one less setting to worry about being "wrong" ....

    Regards,
    Chris.
  10. p2maniac

    p2maniac New Member

    Hi, I have the same issue with my Minix Neo U1. Clicking sound is terrible, I have tried all solutions.
    The problem disappeared when I installed Libreelec. After that Kodi works perffect. The sound is clear and clear.
    There are no problems with clicking sound, but on android problem is further. Youtube, Kodi or another apps
    every now and then I have issue with my sound. On Libreelec Kodi shows other drivers in menu in sound setting/output. Maybe this is the problem. Maybe we need another drivers in android. SUPPORT please install Libreeelec and check that. Maybe you can help us. Maybe just replace the drivers in Minix firmware or something like that. Please resolve this problem because use the device without android or with clicking sound is not in place. Please reply. Maybe together we'll do something about it.
  11. p2maniac

    p2maniac New Member

    Yesterday evening I managed to partially solve the problem. My equipment, Samsung Soundbar, has a bluetooh audio option. I decided to include the bluetooh in Minix and send the sound. In the Audio output option I chose Samsung Soudbar and the sound works fine. There are no strange distractions. The sound is pure as in Libreelec. For me it's a great message. Something must be with the sound card drivers since the sound on other drivers in Libreelec works fine and bluetooh on the android also. Maybe someone will help it. Regards.
  12. mehgurd

    mehgurd New Member

    Anyone here who has bought the new Neo U9-H to replace this ticking box and can confirm that it doesn't have this issues?
    I stopped using my Neo U1 to watch movies as it is a SHITTY experience.
    It's so sad to see that there is literally NO INPUT from official Minix people here. Sad Sad Sad customer experience.
    I mean, from the number of people here posting EXACTLY the same symptoms you could REALLY EXPECT a bit more INVESTIGATION of EXPLANATION or ACKNOWLEDGEMENT.

    Very sad. Will never buy a Minix again just because of this. I mean, Android is shit, but a shitty Android experience is even shittier!
  13. silvapa

    silvapa Member

    Hi All. I Have a U1 and a U9. I had some issues playing audio and video. Main issue was related to micro-interruptions in sound and video. Technically seems to be a sync problem. The practical result was a "click" in sound, resulting (imo) from the amp loosing and acquiring again sound, and a micro pause/jump in picture.
    After reading a lot in some forums and trying several configs I got rid of all interference's.
    Lessons learned:
    • Don't use any HDMI switches/hubs or other similar equipment because they always affect the signal. Keep the path of the signal as simple as possible;
    • Channel your signal like this: Minix > Amp > TV (let the amp do the sound decoding). The amp decoders (imo) are better than those of Smart TVs;
    • Use a good amp/receiver capable of decoding modern codecs (part of my problems with U1 resulted from using a entry level Receiver);
    • Use good/fast hdcp 2.2 capable HDMI cables (no dramatic change for Full HD 5.1 but recommended if using 4K HDR videos with 7.1 sound ... lots of info circulating);
    • Try to use the receiver only for sound decoding. Avoid other improvement features like upscaling.
    My current config:
    • U1 > Full HD Marantz Receiver (5.1 speaker config) > Full HD TV
    • U9 > 4K Denon Receiver (7.1 speaker config) > 4K TV (Audioquest Pearl cables hdcp 2.2 certified)
    The other part of the solution was around minix and kodi/XBMC config. Mainly:

    KODI/XBMC VIDEO:
    • Adjust TV refresh rate - Always
    • Sync reproduction to TV - OFF
    • HQ Scales - 20% (minimum in XBMC)
    • Graphic Buffers - 3
    KODI/XBMC AUDIO:
    • Audio Passthrough - ON
    • Mastering Quality - Medium
    • Threshold for Pitch Correction - 2

    MINIX:
    • Dolby Sounds - DRC Mode (Line)
    • DTS Sounds - DTSDrscale (Sound0)
    • Digital Sounds - PCM
    • Sound Devices - HDMI
    Hope this helps. Good luck!
    Last edited: Aug 12, 2017
  14. vencaxxx

    vencaxxx New Member

    Hi I have same problem with my U1. It seems something is wrong in SW. I have very bad sound ticking while using neutron player. Some HD audio tracks are ticking all the time, some lossy MP3 are better, but I have the problem with all audio players, Tidal, Google play music and so on...
  15. Graham Archer

    Graham Archer New Member

    Well guys I'm beginning to consider just throwing all the minix devices out and buying another brand new device. Which will not be minix. All my units even updated to the latest firmware and 17.4 on kodi have a click. Are there any support suggestions from Minix? Cmon it's a great piece of kit other than the annoying click/static.
  16. wrxtasy

    wrxtasy Active Member

    Solution (for Kodi Krypton), as already mention in Post #70

    LibreELEC Kodi Krypton (click) running entirely from an external microSDHC card.

    Follow section (d) for a U1 DIY. (y)

    Next Hint - in LibreELEC Kodi's Power Menu there is a "Reboot from Internal" option to reboot back into Android. Welcome to Dual booting.

    This is now what is needed for Kodi Krypton Audio passthrough support in AMLogic Android Marshmallow Firmware:

    Welcome to Android MediaCodec standards (click)
    Last edited: Sep 15, 2017