1. Official MINIX forum

Stock firmware

Discussion in 'X8, X8 Plus, X8-H Official Firmware 007' started by MINIX - Ken, Jul 20, 2014.

  1. HardwareGuru

    HardwareGuru Developer Administrator

    @andrea.zennaro.10
    Please have respect to our members and forum.
    That there is a support forum does not mean you can just say what you want in an disrespectful manner.
    Your issues can be solved if you just ask in a polite way.
    This is my first and last warning to you.
    It is too bad we need to act this way as if we are in a kindergarden :(

    I am cleaning up this thread.
    Higgs, zarbman and Henk like this.
  2. andrea.zennaro.10

    andrea.zennaro.10 New Member

    ok. Sorry me. message arrived


    Inviato dal mio iPhone utilizzando Tapatalk
  3. Higgs

    Higgs Yellow Dude Super Moderator

    Please read the forum rules instead of posting eta requests, the rules are clear.

    Sent using Tapatalk
  4. David Ewing

    David Ewing New Member

    Thanks for the help as using the beta 8 firmware worked to allow the addon to function. However the minix is very unstable and creates frequently. If I check for an update of firmware will the add-on then become unusable once again? Maybe because i am using it to download torrents using ttorrent it is unstable. Any suggestions to make it even a little reliable??
  5. ENDRJUPL

    ENDRJUPL Well-Known Member Super Moderator

    If it crashes, try Hardwareguru's fix. You will find the link in his signature.
  6. Ketil Tuft

    Ketil Tuft New Member

    I have problem downloading the file. It end at aprox. 260 MB. I have tried several times and on different computers and networks with same result.
    Any one else with same experience?
  7. Raptor

    Raptor New Member

    I have this problem too. Please can you fix as I would like to return my unit back to stock firmware.
  8. David Ewing

    David Ewing New Member

    Thanks for your reply I looked at the signature but can only see a link to the beta firmware. What is the fix for the firmware you are mentioning or please send me the link
    dewing@tig.com.au
    I really need it as it crashes 3 times per film!
  9. Jeolman1

    Jeolman1 New Member

    The stock firmware will not download properly is there another source for this file? I want to flash to original so I can return it to the seller. my wifi is non functional on my unit
  10. HardwareGuru

    HardwareGuru Developer Administrator

    I will upload it to the forum server lateron
  11. Jeolman1

    Jeolman1 New Member

    Any ETA on when later on is? I really need to ship this back to my seller. I also noticed that it appears as though it is downloading fine and then randomly between 79 and 130mb the connection speed starts to slow down drastically and the file fails due to network timeout. It does this on 2 different computers on seperate physical networks so the problem is not on this end but maybe your server or file host.

    hope the extra info helps resolve this problem.

    Thanks

    edit: was able to download file by pausing download whenever the connection began to slow and then continue download after a few moments. this kept the download speeds high enough to keep it from failing at a partial download.
    Last edited: Nov 21, 2014
  12. HardwareGuru

    HardwareGuru Developer Administrator

    sorry it skipped my attention.. uploading within an hour from now
  13. angealus

    angealus New Member

    hello i dont know if this issue has been resolved but all downloads from minix hve always done this do me. i learned to use a download manager like jdownloader to download minix stuff. i used it already for file hosting sites. it will let the connection drop then just pick up where it left off again
  14. EdT586

    EdT586 Member

    Can someone please make v001 20140529 F/W into a update.zip file ...need to revert back from v002 because deep sleep is an annoyance.
  15. kevin simpson

    kevin simpson New Member

    hello, I am having a big problem trying to get a good stock firmware DL. I have downloaded the FW from both official and forum sites and each time I try to unzip them it returns an error msg declaring the file corrupt! Is there another site I can DL a good Fw from?
  16. EdT586

    EdT586 Member

    Your not suppose to unzip it !
    Just make sure the you downloaded the complete F/W.
    Move the file onto the interal SD card storage and it will start to update by itself !
  17. kevin simpson

    kevin simpson New Member

    Thanks, sorry i think theres a coms prob here. I am trying to update fw via pc method as my minix has developed a problem i.e. the display from the hdmi to tv is not working, so i have no way of seeing whats going on or selecting files etc from the minix so my only option or unless someone knows differently is to go back and reinstall or upgrade the fw nd hope this fixes the prob with the hdmi display. So i'll re phrase, where is the link for the pc method fw? Thanks in advance. Actually just read the 2nd thread ref flash instructions and it seams i was correct the first time as the instructions are for this method. So my origional problem are these two fw files corrupt?
    Last edited: Apr 22, 2015
  18. Higgs

    Higgs Yellow Dude Super Moderator

    Try using a download manager to download the file. Is there any reason you want to flash this old firmware and not the latest one?
  19. kevin simpson

    kevin simpson New Member

    hello Higgs, thanx for the response. I have downloaded the latest fw and managed to use the burning tool method but the update procedure fails at 4% with the following:
    [17:01:22 324][HUB3-1][Err]--failed:[17:01:22 324][HUB3-1][Err]--Check command return failed
    [17:01:22 356][HUB3-1][Err]--[0x30201004]UBOOT/Disk initialize/Send command/Error result
    I get this each and every time so I have come to the conclusion that the box is in someway unable to complete the process so I will be returning it as faulty to the supplier..thanx again.
  20. Higgs

    Higgs Yellow Dude Super Moderator

    Some things to check before you return it;
    Make sure you are using a usb2.0 port, (do not use a usb hub)
    Check that you have the correct firmware (i.e x8-h plus firmware will only work on that model)
    Check the downloaded firmware is correct (check the md5 checksum)