1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

SW problem (something like GPU driver) or HW device fault?

Discussion in 'Official Firmwares' started by TurocK, Sep 14, 2017.

  1. TurocK

    TurocK New Member

    Hi! I just bought a new Minix Neo U9-H (my first android box) like a week ago.
    I start the device, conect on wi-fi and my google account and then run OTA update from apps list.
    Problem is: sometimes, when i play youtube or kodi movies (local from USB stick/FAT32), screen went green. When i press back button, apps gui show like no problem. Only video playback is green. I try forcing the RGB screen space and no result. All i can do is to restart the device and everything plays fine...for a time.
    I have this problem every day.
    After eack OTA update i run a software reset (to reset android). Software reset dont resolve the problem.
    Is GPU driver fault/firmware or my device is faulty and must return to RMA?
    I post a photo of green screen when i play a YT clip and a youtube clip (made by me) to understand my problem.

    Thank you in advance!

     

    Attached Files:

    PhillyGTA likes this.
  2. Goofy_Goober

    Goofy_Goober New Member

    PhillyGTA likes this.
  3. TurocK

    TurocK New Member

    So is a software problem?
     
  4. TurocK

    TurocK New Member

    About one hour ago it happened again: watching YT then press home button and open kodi and have green screen. Switchet again on Youtube TV apps...green screen.
    What's happening?
     
    PhillyGTA likes this.
  5. sham85

    sham85 New Member

    This is exactly happen to me as well. I noticed this happen when i start to use the Youtube TV app recently. Not sure if it just a coincidence or not. Tried everything as suggested in the forum but not solve anything. Hope someone can shed some light here.
     
    PhillyGTA likes this.
  6. TurocK

    TurocK New Member

    SAME HERE!
     
    PhillyGTA likes this.
  7. TurocK

    TurocK New Member

    A new problem: When i try to enter recovery mode (holding hidden button with a papper clip and power button at yhe same time) o screen appear artefacts and can't see anything.
    When i try to enter recovery mode only holding the power button, the image is fine.

    Maybe green video playback is related with the glitch appear when holding hidden button + power...

    I can come with video demonstration if necesary!

    My big dilema :Software or hardware problem?​
     
  8. Villa

    Villa Administrator Administrator

    I'm not sure what happens when pressing the reset (hidden button)?
    I only ever press and hold the power button to enter recovery!
     
  9. TurocK

    TurocK New Member

    When Minix is turn off, hold the hidden button (with a papper clip or something) and power button and see whats happen.
    show recovery menu, but, in my case, all screen is artifacts. I dont think is normal.
    I come back later with a clip.
     
  10. Villa

    Villa Administrator Administrator

    My point is that there is no need to use the reset button to enter recovery!
     
  11. TurocK

    TurocK New Member

    I figure that. The question is if is normal to have artifacts in that situation? Perhaps, somehow, the artefacts is related with green screen layer on video playback.
     
  12. TurocK

    TurocK New Member

    First i enter recovery mode holding hidden button+power. Second, holding only power button (i cut the clip to save time)
    It is normal to show that artifacts?
     
  13. TurocK

    TurocK New Member

    Does anyone else have this problem?
     
  14. HenryJP

    HenryJP New Member

    I have seen this on other devices ie. DVD players, Set top Boxes etc. In my case its been caused by cable problems. Component cables or HDMI cables or connectors. I suggest, before purchasing another cable...switch it to another HDMI input port on your TV. Hope this helps
     
  15. jpl69

    jpl69 New Member

    Green screen here too ! Going to downgrade to see if it helps

    Edit: Same thing

    Edit 2 : Youtube for android tv is the culprit, after watching a few videos and cycling through some applications (video applications mx/tv) the video on youtube tv gets green and mx player gets buggy
    I'm sorry if this was already mentioned but i could not find it

    Edit 3 : It's not youtube! It's about some sort of codec. Not having any issues since i've disabled the auto resolution.
     
    Last edited: Oct 6, 2017
  16. TurocK

    TurocK New Member

    From where i can disable auto resolution?
     
  17. Villa

    Villa Administrator Administrator

    If @jpl69 is referring to the device then...
    Settings, Display, Screen resolution

    Screenshot_20171015-123801.png
     
  18. jpl69

    jpl69 New Member

    I’m sorry bur it doesn’t solve the issue also! I’ve to restart the system when it turns green! I was new in the forum and thought was a hardware problem but it seems there’s no fix so it’s a “feature”
     
    Villa likes this.
  19. jpl69

    jpl69 New Member

    Just an update for this.
    I installed aptoide (Android tv box version) an play store alternative and it sugested me :
    https://smart-youtube-tv.aptoide.pt/
    I gave it a go and no more green video as i watch youtube all the time switch to downloaded movies multiple codecs. been more then a month now.
    I just love my minix ...