1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Top X questions and solutions

Discussion in 'General - Guides and FAQ' started by ENDRJUPL, Aug 22, 2014.

  1. chat1978

    chat1978 New Member

    I ran into this thread because of audio sync issues.
    I followed the advice mentioned here but my first remark is that -250 makes it worse. I then moved the slider to the opposite side (250) and things are better although not perfectly synchronized.
    Various video files are fine and played well by all other media players on the same device and kodi's on other devices.
    I also have this issue both with the optimized xbmc but also kodi 14.2

    This a big turn off. My MK809II 1/3 of the price plays better the videos over wifi than this device over ethernet.
    Is there a good way to solve this good or is it always a hack with audio delays etc which are not that precise?
  2. ENDRJUPL

    ENDRJUPL Well-Known Member Super Moderator

    How can we help if you didn't provide any information whatsoever? What model do you own? What firmware version do you have? How is your device connected?
  3. chat1978

    chat1978 New Member

    You are correct. My apologies. I got confused because I forgot that I switched thread from the specific mode.

    Anyhow, thanks for the remarks.
    I have MINIX NEO X8-H Plus Amlogic S812-H
  4. ENDRJUPL

    ENDRJUPL Well-Known Member Super Moderator

    What firmware version do you have? Do you have a surround sound system? How do you connect your MINIX to it - spdif, hdmi?
  5. chat1978

    chat1978 New Member

    kernel 3.10.33
    build number 49H.20141122


    I tried to do an update though the "Green" settings but it didn't find anything.
    If I understand correctly, OTA is supported and it is provided through this option?

    Regarding my connectivity, I just have an HDMI to a TV. I don't know if you require more information.
    Hope it helps.

    Attached Files:

  6. ENDRJUPL

    ENDRJUPL Well-Known Member Super Moderator

    Go to official firmware releases section and update to 002 firmware to be able to receive OTA updates. There is an instruction on how to perform manual update.
  7. chat1978

    chat1978 New Member

    I followed the instructions. It wasn't easy since there is a lot of confusion and which rom applies to which one.
    I think the issue is fixed.
    Thank you for your help and time!
  8. djustoe

    djustoe New Member

    hi guys
    Are the following the most optimal settings to counteract the buffer issues?
    <advancedsettings>
    <network>
    <buffermode>1</buffermode>
    <cachemembuffersize>102144000</cachemembuffersize>
    <readbufferfactor>1.5</readbufferfactor>
    <curlclienttimeout>45</curlclienttimeout>
    </network>
    <splash>false</splash>
    </advancedsettings>

    They definitely made an improvement. In the past when attempting to stream a HQ version of a tv show, I would get the cache full after like 2/3 % buffered.
    Now it will reach roughly 40-50% buffered before I get the cache full message.
    any suggestions?

    Thanks
  9. chat1978

    chat1978 New Member

    I still have two problem with my Minix after the last update to the 003 update

    Kodi has some glitches. For example many times after the device has been left for a couple of hour not doing anything, then I can't see the image when playing new videos. Also sometimes, the playback is not proper. It looks like the CPU is bogged down. Sometimes, these errors are fixed with a Kodi restart or sometimes a full device restart is required.

    Since there are problem with Kodi, I tried also the embedded xbmc. In general it looks faster and better. But I can't install addons. They are downloading and when complete they immediately don't do anything. Looks like a crash of the flow.

    About the device, I need to set the display size to 91%. This settings goes away very often and I need to set it again.

    I have checked if there is a new update through FOTA but nothing is there.
    I have to say that I bought Minix for its quality. But 50euro sticks behave more consistently with kodi versions that are not optimized....
    The kodi on that device is open 24h per day and we haven't restarted the device for many months.
    In comparison, the x8-h plus doesn't provide a feeling of assurance.
    Am I the only person who thinks that the experience is kind of problematic?
  10. djustoe

    djustoe New Member


    I'm well pissed off with the Minix aswell. I paid roughly 150 euro for it.
    All I ever wanted it for was to use Xbmc and Airplay.
    Its been a struggle to do either!
  11. chat1978

    chat1978 New Member

    I completly removed the kodi version which is not looking well. I did some remove/add of the sources for the embedded xbmc and I got some addons installed.
    So that part is fixed. I still need to verify stability. My wife was watching today an episode and it was complete with blue vertical lines. I checked the file on a tablet and everything played correctly.
  12. djustoe

    djustoe New Member


    So it turns out all along, the issue with my Minix 8H Plus was the piss poor wifi signal it has.
    I live in a small apartment and the router is in the hallway.. so it is particularly shit. (I have no signal issues with any other devices connecting to my router)
    So I have scrapped the wifi option and bought a pair of ethernet plugs.
    My Minix and Xbmc are now performing flawlessly aswell as the Airplay functionality.

    So any who has been experiencing airplay / buffering issues..
    May be worth looking at your Minix's wifi signal.

    hope this saves someone some time.
  13. stream_newbie

    stream_newbie Member

    Naive questions again sorry.

    1) If buffer size increased to 100mb as below, will the launch of any video take as many seconds as it takes to load 100Mb ? :)

    2) What is the factory-set buffer size om minix x8-h ?

    <advancedsettings>
    <network>
    <buffermode>1</buffermode>
    <cachemembuffersize>102144000</cachemembuffersize>
    <readbufferfactor>1.5</readbufferfactor>
    <curlclienttimeout>45</curlclienttimeout>
    </network>
    <splash>false</splash>
    </advancedsettings>
  14. frankvh

    frankvh New Member

    Good afternoon,

    I also have buffering problems. Looked deeply into this forum and tried various things/posts.

    Setup :
    • Minix X8H plus ( android 4.4.2 / Build KOT49H.20150506 / kernel 3.10.33 )
    • Synology DS214+ NAS ( wired directly into the router )
    • Minix connected via Powerplugs ( 600Mbps version ) to a 1.000 Mbps switch into the router
    • XBMC for Minix pre installed
    • advancedsettings.xml uploaded unto the box ( content below )
      • <advancedsettings>
      • <network>
      • <buffermode>1</buffermode>
      • <cachemembuffersize>102144000</cachemembuffersize>
      • <readbufferfactor>1.5</readbufferfactor>
      • <curlclienttimeout>45</curlclienttimeout>
      • </network>
      • <splash>false</splash>
      • </advancedsettings>
    • 9,50 Mbps down / 3,20 Mbps up / 29ms ping ( Sppedtest results )
    Problem :

    The bigger files seem to have an issue, not all the files but some of them. When I start a movie or serie ( example game of thrones S05E08 5,33 GB MKV file ) it starts buffering, slowly to up to 4% and then starts the playback. Smoothly. When I press O on the keyboard i see the buffer size slowly decreasing to 0 and then the buffering starts again. This is when I open them from my NAS setup.

    If I open then an HD stream from Genesis it plays flawlessly. But also some other files from my NAS with bigger size ( 5 GB+ ) then play flawlessly. Lately I notice the problem with the new episodes from Game of Thrones and Walking dead, mostly directly from the NAS. Other series play great ( also from NAS ).

    Question :

    How can i solve this buffering problem, the network seems pretty ok looking at the tests that i have done ( 9,50 Mbps should be enough, and this is from the internet, the NAS is connected internally ) and I have changed the advancedsettings.xml accordingly to the remarks made in this forum. The box is up to date. Please advise how can I resolve this problem? Thanks!!
    Last edited: Jun 3, 2015
  15. ENDRJUPL

    ENDRJUPL Well-Known Member Super Moderator

    Try increasing the readbufferfactor to 20. Also, the file should be named advancedsettings.xml NOT advancedsettingsfile.xml
  16. frankvh

    frankvh New Member

    Changed the type in my post. It was advancedsettings.xml, only i made a type in my previous post.

    I have changed the readbufferfactor to 20. No change. It takes 45 sec to fill up to 5% and then it starts playing. The buffer is quickly emptying to 0 in 60 seconds roughly.
  17. Higgs

    Higgs Yellow Dude Super Moderator

    As you don't have any issues streaming files from the internet, then maybe the problem is with your connection to the NAS.
    How is the NAS connection set up in xbmc/kodi? smb, nfs, ftp?
    Maybe try a different protocol to see if it makes a difference.
    Do the same files play ok in other apps?
  18. Userseven

    Userseven New Member

    I can't say anything about x8 but in my experience with x7 I found that it has horrible wired performance (ethernet). I have a gigabit network at home (not that relevant considering x7 is limited to its 100mbit hardware) and the NAS is perfectly capable of consistent speeds of over 100megaBYTES per second. Not with x7 and certainly not with the xbmc on minix.
    You should really increase the cache size, consider the fact that it usually only fills it to about 50%. So in the default configuration with the 20megs of cache it would hover around 10 (13 max) for some reason. That's like 5 seconds of increased bitrate before everything goes south. Considering this I would double your cache from 100megs to 200 for good measure. Readbufferfactor to at least 10. Shutdown and coldstart the unit after these mods. If everything fails you could try the wifi, I heard it's much more reliable on minix.
  19. cyran0

    cyran0 New Member

    Very informative thread!

    I have the X6 with the basic IR remote, FW007a. Lately, I moved from SPMC to KODI 15 release. With SPMC in video fullscreen mode, the menu button toggled the display of the codecs used. With KODI that button does nothing. Can someone gives me some pointers to how to replicate that behavior with KODI. From there, I'll try to remap the config button to cycle the subtitles.
    In the past on MS Windows, I managed to remap a remote that acted like a keyboard (HID), IR remotes are another story I suppose. If someone could supply the remote.xml file with all the buttons with their default settings, that would be great.

    Thanks in advance.

    Update:

    Inside KODI, I found the Program add-ons: Keymap Editor (cited here)! I tried it to remap the menu button and the result is:
    Code:
    <keymap>
        <osdvideosettings>
            <keyboard>
                <key id="61656">codecinfo</key>
            </keyboard>
        </osdvideosettings>
    </keymap>
    in the file: /sdcard/Android/data/org.xbmc.kodi/files/.kodi/userdata/keymaps/gen.xml

    Unfortunately, no effect. Am I on the right track? Should I rename the file?
    Last edited: Jul 26, 2015
  20. Oxygen

    Oxygen New Member

    how to change the file to .xml in windows10 please, I changed the file name to end in xml but it still shows as a text file so I assume this is wrong

    and can I plug the box into the pc and change setting there or is it all done through the TV?

    file is now called
    advancedsettings.xml

    and this is whats in it

    <advancedsettings>
    <network>
    <buffermode>1</buffermode>
    <cachemembuffersize>102144000</cachemembuffersize>
    <readbufferfactor>1.5</readbufferfactor>
    <curlclienttimeout>45</curlclienttimeout>
    </network>
    <splash>false</splash>
    </advancedsettings>

    as a final ps I only get buffering on certain things, others like HD Tv stream fine so could it be the source more than the box?
    Last edited by a moderator: Jan 25, 2016