1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Trying to update to FW013 using TWRP

Discussion in 'NEO U1 Official Firmware Releases' started by MooseKnuckles, Aug 26, 2017.

  1. MooseKnuckles

    MooseKnuckles New Member

    Downloaded the FW013 zip and put on a FAT32 USB.
    Boot into TWRP>Install>FW013
    Get the message "Update process ended with ERROR=7"

    How do I update from FW011 to FW013 in TWRP without doing a full wipe?
     
    JJ-KwiK likes this.
  2. JJ-KwiK

    JJ-KwiK Active Member

    You get a like based on your user name alone...

    Why aren't you trying to flash the update zip file via stock recovery? You can use the update zip to update to the latest firmware via stock recovery without losing your app configurations. You can also update using the Minix OTA app.
     
  3. MooseKnuckles

    MooseKnuckles New Member

    My device is rooted and has TWRP flashed, i dont think stock recovery or OTA are an option.. or is that not correct?
     
  4. MooseKnuckles

    MooseKnuckles New Member

    I'll try unrooting and use the OTA
     
  5. MooseKnuckles

    MooseKnuckles New Member

    I unrooted, confirmed with a root checker. When trying to use the OTA app it lets me download FW012, but then says "your system was damage wirelss update is disabled". So it must still be able to detect it was rooted.
    Tried flashing FW013 zip in TWRP and got the same ERROR=7

    I guess it's pointing to doing a factory reset
     
    Last edited: Aug 26, 2017
  6. MooseKnuckles

    MooseKnuckles New Member

    Ah crap. went from bad to worse, wasn't paying close enough attention when doing a wipe in TWRP and wiped the damn system. No OS installed at all anymore. I can still boot to TWRP but that's it.
    Where can I get a valid download for a stock ROM and install guide?
     
  7. MooseKnuckles

    MooseKnuckles New Member

    derp on my part. kinda in panic mode and didnt think to go back to the original firmware source post. thanks
     
  8. MooseKnuckles

    MooseKnuckles New Member

    a Mod had replied to me with a link but the post has since been deleted. I dont think the OTG flash will work because it boots into TWRP when you hold the power for 6 seconds
     
  9. MooseKnuckles

    MooseKnuckles New Member

    so i'm just throwing darts now, when i try to flash FW013 in TWRP my error is ERROR=7 but i noticed in the string of text it also says "this package is for NEO U1 device, this is a NEO X6"

    my device is definitely a U1
     
  10. PuscherChitin

    PuscherChitin New Member

    When you unrooted did you also revert back to the original recovery.img?