1. Registration issues have now been resolved. New accounts are able to be created

Tutorial Tutorial - how to recover / unbrick the U9

Discussion in 'NEO U9-H Guides & FAQs' started by wrxtasy, Jun 6, 2017.

  1. wrxtasy

    wrxtasy Active Member

    I've been playing around with LibreELEC S912 development on the U9 and went to "reboot to internal", which is normally reliable and all I could get was a black picture video output from the U9 when trying to boot into Android from that point onwards.

    I've seen this before when Android devices with HDCP - copy protection - where the Keys get corrupted and then you can get no video & sound output out of the device at all.

    Anyway this is the quick fix recovery method (should work on all AML Android devices):

    1) Save this code to a plain text file called factory_update_param.aml (there must be no .txt extension)
    Code:
    --wipe_data
    --wipe_cache
    --update_package=/udisk/update.zip
    2) Download whatever U9 Firmware file MINIX are currently using - eg U9H_FW004A.zip
    Rename this to update.zip

    3) Unzip the file in Step (2) and extract the recovery.img

    4) Save these 3 files to a USB Stick:
    factory_update_param.aml
    update.zip
    recovery.img

    5) Unplug the power from the U9, insert the USB Stick. Plug in power again and then press and hold in the power button for at least 6 seconds. The TV screen will still be black, but...

    I could see a flashing LED on my USB stick, indicating activity. And after approx. 7 minutes the MINIX desktop appeared again with all my Apps still intact. (y)

    W.
    olive069, steveg32, Juanfran1 and 4 others like this.
  2. steveg32

    steveg32 Member

    Hi. Will this fix my problem?
    http://www.minixforum.com/threads/u...arting-screen-wont-boot-up.17496/#post-140256
  3. Villa

    Villa Well-Known Member Super Moderator

  4. steveg32

    steveg32 Member

    There is no .zip file yet for U9H_FW006 - only .rar - and there is no recovery.img file in the Full System Image DL. Is it safe to use FW005.zip over my FW006 with your method or should I wait for 006.zip ? I have files that I really don't want to lose by doing a full factory reset.
  5. Villa

    Villa Well-Known Member Super Moderator

    If you want to try this you will have to wait for the FW006 .zip file.
    steveg32 likes this.
  6. steveg32

    steveg32 Member

    Ok. Thanks. Will it be available soon?
  7. Villa

    Villa Well-Known Member Super Moderator

    No idea! :(

    What type of files do you have on the device that you don't want to lose?
  8. steveg32

    steveg32 Member

    Thanks for your reply @Villa. I think @MINIX - Ken mentioned the other day that they were in the process of uploading it (though he might have been referring to the Full System Image .rar).
    http://www.minixforum.com/threads/neo-u9-h-fw006-20170810.17461/page-2#post-140118
    Mostly files & settings with paid sub services that I really don't want to lose and have to reconfigure again. In the interim, I'm using my old Rockchip (4-Core RK3188 1.42 GHz Mali-400) Android 4.4.2 box. It's a step down but it has NEVER crashed on me yet.
    Last edited: Aug 20, 2017
  9. steveg32

    steveg32 Member

    Fyi, this recovery method did not fix my issue nor did a manual update using the U9H_FW006.zip. Had to Factory Reset. All is well again. But thank you for this thread @wrxtasy. It was definitely worth the try.