1. Registration issues have now been resolved. New accounts are able to be created

U1 and Libreelec

Discussion in 'NEO U1 Custom ROMs, Kernels & Discussion' started by 9800pro, Jul 21, 2016.

  1. Vittorrio1980

    Vittorrio1980 Member

    Well, I did it. No issues and now it's a lot faster to load the movie artwork when moving down the list fast. Thanks for your help guys. I really appreciate.
    mark2 likes this.
  2. redstorm

    redstorm New Member

    Has anyone connected the Neo U1 to a 5GHz band Wifi AP,
    Under android my U1 would connect to my advertised 5GHz network ~860Mbit.

    I installed LibreELEC-S905.arm-8.2-8.1.3.img on a SDCard with gxbb_p200_2G_minix_neo_u1.dtb
    With this build connecting to WiFi only connects to my 2.4GHz AP.

    I have dried different channels in the 5GHz band and different SSID names but it just does not see the 5GHz networks.

    The regulatory domain gets set to CN not NZ.
    LibreELEC:/usr/share # dmesg | grep CRDA
    [ 17.125094@2] cfg80211: Calling CRDA to update world regulatory domain
    [ 18.901058@3] dhd_conf_set_fw_name_by_chip: firmware_path=/usr/lib/firmware/brcm/fw_bcm4356a2_ag.bin
    [ 18.901071@3] dhd_conf_set_nv_name_by_chip: nvram_path=/usr/lib/firmware/brcm/nvram_ap6356.txt
    [ 18.901082@3] dhdsdio_download_firmware: set use_rxchain 0
    [ 18.901091@3] dhdsdio_download_firmware: set txglomsize 40
    [ 18.981689@3] dhdsdio_write_vars: Download, Upload and compare of NVRAM succeeded.
    [ 19.046930@3] dhd_bus_init: enable 0x06, ready 0x06 (waited 0us)
    [ 19.047541@0] dhd_conf_set_fw_int_cmd: set WLC_SET_BAND 142 0
    [ 19.047882@0] dhd_preinit_ioctls: Set tcpack_sup_mode 0
    [ 19.048903@0] dhd_conf_set_country: set country CN, revision 38

    I cant find a way to force the regulatory domain to NZ, but that may not even be the issue.
    Has anyone got thier Neo U1 talking on a 5GHz band?

    Update: have now got it to see the 5GHz network but had to change to the lower channels.

    Thanks
    Last edited: Aug 23, 2017
  3. virtual_francky

    virtual_francky New Member

    HI, I can't boot from Librelec 8.1.5-8.2, I tried with many micro sd card, or USB Stick, and no way I can boot, but if I create a 8.0.2 micro sd, it works I boot on Librelec. I am using a Minix U1, any idea ?
  4. uberduke

    uberduke New Member

    Make sure you are using the correct device tree (.dtb) file for that version as they are different.

    Failing that, you would need to post this in the LibrElec forum here.

    Duke
  5. mark2

    mark2 Active Member

    I have tried this version Librelec 8.1.5-8.2, today and it works no problem i just downloaded the TAR file
    Put the file in the update folder and reboot your box instructions below
    https://forum.libreelec.tv/thread/5556-howto-faq-install-community-builds-on-s905-s905x-s912-device/
  6. Colmas

    Colmas New Member

    Just today I loaded the latest LE 8.1.5-8.2 with the most recent device tree, on a Samsung Evo plus micro sd card. Initially the update got stuck on the Libreelec splash screen. I then copied the latest device tree to the card and the update then proceeded. Strange, as I had thought I had the latest device tree already copied to the sd card. In any case, all works OK, although I cannot see any noticeable difference to my previous LE 8.0.2e version. I have two cards, one with each version on it so I can alternate easily between the two LE versions to see any obvious differences if necessary.

    Cheers
    Last edited: Aug 24, 2017
  7. Vinylity

    Vinylity Member

    For me, it fixed the problem with the HDMI signal becoming lost and getting a black screen.