1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

U1 and Libreelec

Discussion in 'NEO U1 Custom ROMs, Kernels & Discussion' started by 9800pro, Jul 21, 2016.

  1. Edwin

    Edwin Member

    Hi Guys,

    I installed libreelec 007 on my Neo U1 , all is good, reaaaaally good i must say
    even 10bit 720p anime plays and that is WITH the amcodec enabled!
    I installed to NAND as from USB it was sluggish responsiveness.

    .....except i cannot seem to get DTS to work?

    I am using a 2.1 setup with a receiver that is capable of doing DTS (working on openelec on my neoX8H)
    I am using passthrough HDMI and selected DTS capable receiver but still no audio.
    Anyone have this issue with 007 from kszaq ??

    right found it..i have to disable "DTS capable receiver" to make it work
    Strange as my receiver is capable of doing this but then again..it works!

    A big thanks to the guy who made this 007 port for the minix !
    Last edited by a moderator: Dec 20, 2016
  2. Edwin

    Edwin Member

    Just wanted to mention Another thing that speaks for libreelec over minix xbmc is the kodi key editor app
    Under minix xbmc on android it would not detect my "red green yellow blue" buttons on my sony tv remote
    On libreelec -> not a problem, works 'out of the box'
    Still on 007
  3. Guy Aftaya

    Guy Aftaya New Member

    Sorry for the stupid questions maybee..

    1.Can I installl LE on my U1 and will be able to go back to the Original Rom?
    2. LE can play 4K HDR on U1?

    Thanks
  4. Edwin

    Edwin Member

    Hi Guy,

    I not an expert here but,as you might have guessed from my comments , yes you can install LE on U1 and yes, you can go back to android if you would want that although make sure yr awake and do not rush things, follow the steps described here in this forum and you will be fine.
    Not sure 'bout the 4K thing, i still run everything with 1080p here but according to spec the U1 should be able to handle that too ;-)

    Try this, i copied it from the post of newbie:

    7.0.2.007 build for S905
    https://forum.libreelec.tv/showthread.php?tid=1497

    1. Download img.gz file and burn it to SD card/USB drive:
    - http://wiki.libreelec.tv/index.php?title=Installation (how to burn it to SD)
    - http://kszaq.libreelec.tv/s905/7.0.2.007/ (download)
    2. After this you will see that drive capacity is 512MB.
    - This is OK as there is a second (hidden) partition on the drive for LE userdata!
    3. Download a device tree, rename it to dtb.img
    - and copy it to main folder of SD card/USB drive - replace the one that's already there.
    - http://kszaq.libreelec.tv/s905/7.0.2.007/device_trees/ (use the gxbb_p200_1Gbit.dtb: http://kszaq.libreelec.tv/s905/7.0.2.007/device_trees/gxbb_p200_1Gbit.dtb)

    What i also did was the usb method but after that i copied to NAND, as the libreelec for me was too slow from usb but very fast from Nand
    You could use TWRP to make a full backup of yr android first if you already upgraded and installed to latest there.

    hope this helps
    Guy Aftaya likes this.
  5. Guy Aftaya

    Guy Aftaya New Member

    @Edwin

    Thank you so much..works perfect!
  6. Guy Aftaya

    Guy Aftaya New Member

    Another Question..

    After I installed TWRP recovery ,how to flash image to internal storage with the dtb.img inside?

    Thanks
  7. 9800pro

    9800pro Active Member

    You want to install LE to internal ?
    Run LE from sd card, login to it with ssh (putty.exe), execute command: installtointernal, restart. LE is now installed to internal. This however completely removes Android os. You can go back by flashing latest U1 minix image with amlogic burn tool, it's not complicated.

    sent from my G2
    Guy Aftaya likes this.
  8. Guy Aftaya

    Guy Aftaya New Member

    @9800pro thanks.

    What is the credentials to login?
  9. 9800pro

    9800pro Active Member

    root / libreelec

    sent from my G2
    Guy Aftaya likes this.
  10. rabrol

    rabrol New Member

    How have you guys managed to boot into LibreElec from USB? I simply seem unable to do it. Spent over an hour trying just to get it to boot!

    Created a USB stick (8Gb) with the 7 0 3 012 and the official LibreElec USB creator tool.
    Grabbed the 2G 1Gb dtb from device tree, renaming it to dtb.img
    However Minix U1 would just not boot - either into Recovery or Standard boot.

    Only way I can get into Recovery is if there is no USB stick plugged in - and it takes holding the Power button for 25 seconds or so, not 6 like is mentioned in many places.
    Any time I plug in the USB drive, Recovery will not load. In fact it just sits there with the Minix Green Android for as long as I leave it.

    If I boot into Recovery and tell it to reboot, still locks up if USB stick is plugged in :-(
    I tried a second 8Gb USB drive from a different manufacturer. Same results.

    I tried all 3 USB ports. Made no difference.
    Tried powering up while holding a pin in the reset button on the bottom. That did nothing.

    Summary - only way I can get in to Recovery is if no USB stick is plugged in. Have not been able to boot into LibreElec at all from USB.
    Would be most grateful for any pointers!
    Cheers,
    Rob
  11. getochkn

    getochkn Member


    Right from here https://forum.libreelec.tv/thread-3588.html

    Issues with booting? Freezes? Use a build with disabled temperature sensor:

    and https://forum.libreelec.tv/thread-3433.html

    Whole threads on there about booting issues. I'm using the latest build with the disabled sensor, can boot 100% of the times in a row now. Before I'd get 1 boot out of 20, I flashed to my internal NAND overwriting android, nothing. Flashed that, perfect.


    Use
    gxbb_p200_2G_1Gbit.dtb for the device tree, depending on what version you trying. I find the latest 7.0.3.012 with the disable temp sensor works really well.
    Last edited: Jan 8, 2017
  12. Damien Xenos

    Damien Xenos Member

    Used v009 with Mix U1 a while back. Had no issues using a microSD card. Given the low cost of am 8gb card versus your time it may be easier to just go down that path?

    Sent from my ONEPLUS A3010 using Tapatalk
  13. rabrol

    rabrol New Member

    Thanks for the response. Yep, I used that dtb and renamed it.
    Didn't try a non-temp sensor version though. Will give that a try next.

    Had read through the first thread you listed (just wasn't allowed to post the link that said I did!) Will read through the second one as well and see if it offers any other tips.
  14. mark2

    mark2 Active Member

    Agree with the sd card been using it with sd card for months works fine
    rabrol likes this.
  15. rabrol

    rabrol New Member

    Yeah, don't have an SD card kicking around. If I can't get USB to work, that will be next attempt - and maybe rolling back to a previous version as well.
  16. mark2

    mark2 Active Member

    rabrol check page 2 of this thread a few people had it running on USB
  17. getochkn

    getochkn Member

    Yes, I've never tried USB, only SD but the temp sensor build, always boots. It rocks.
  18. 9800pro

    9800pro Active Member

    Use the version of LE without temp sensor, with it it doesn't boot.
    Burn it with Rufus usb tool.
    Try all 3 usb ports, it has to work on one.
    When it works you will not get into recovery but straight into LE.

    sent from my LG G2
  19. getochkn

    getochkn Member

    LibreElec makes a USB tool to use instead of Rufus. burn the image with their tool, replace the device tree, boot and enjoy the pefect kodi experience,.
  20. 9800pro

    9800pro Active Member

    I'm using LE since 007 version so i know all this...just look who started this thread.
    It's also known that u-boot section of Minix has issues with temperature sensor and that is why the versions of 009, 010, 011 and 012 of LE with temp sensor enable have boot issues. Try doing 10+ consecutive reboots and see, it's gonna get stuck at boot. If you use non-temp version reboots are fine, tested with 40+ reboots...

    sent from my LG G2