1. Welcome to the official forum for MINIX devices!

U1 and Libreelec

Discussion in 'NEO U1 Custom ROMs, Kernels & Discussion' started by 9800pro, Jul 21, 2016.

  1. kingsizept

    kingsizept Member

    Me too, but never had a boot problem.
  2. 9800pro

    9800pro Active Member

    Are you saying that when you install latest 012 version with temp sensor enabled you can reboot continuously 20+ times?
    Don't guess, try it first.

    sent from my LG G2
  3. kingsizept

    kingsizept Member

    Yes, and i use in this moment "LibreELEC-S905.arm-7.0.3.012a.img.gz"

    Why people need to reboot continuously 20+ times?
  4. getochkn

    getochkn Member

    As a test. Before the temp-sensor disable build, I would need 20 boots to finally get LibreElec to boot. It would barely boot, from SD or internal NAND. Now with that build, I can reboot over and over and over. It's testing stability of it.
    kingsizept likes this.
  5. 9800pro

    9800pro Active Member

    I updated to 012 today and it wouldn't boot at all, just stayed at android logo. After 10 cold boots it finaly booted. Then i installed non temp version and it works every time.
    What is your soc revision, b or c?

    sent from my LG G2
    rabrol and kingsizept like this.
  6. kingsizept

    kingsizept Member

  7. getochkn

    getochkn Member

    How can you find your revision?
  8. rabrol

    rabrol New Member

    Yes, where do you get the revision number?
  9. rabrol

    rabrol New Member

    Now working for me! Yippee! As was pointed out in the threads above, it seems it is the temp sensor disabled mod that makes it work.
    Although I had also used a different USB stick as well.

    Let the testing begin :)

    Since I had to leave my main U1 on all night rescanning the libraries, I'm going to install this on the NAND on my Bedroom U1 first. If I like it there, I'll then do the setup in the media room!
    Thank you so much for the pointers. I'm glad to have the chance to experiment with LibreElec (was a long-time OpenElec user on my last device).
  10. kingsizept

    kingsizept Member

  11. rabrol

    rabrol New Member

    OK, now that I have LibreElec running on the upstairs U1, I would like to transfer it (complete with library and settings) to my other box.
    I know I could just do a standard install on the other Neo U1 with the USB boot stick, however it seemed that the USB could hold persistent data in another partition.

    So is there a way to back up the one unit's data onto that other partition so that the database and settings are the same when booting from the USB and installing?
  12. rabrol

    rabrol New Member

    Actually trying to work something else out now as well.
    On the downstairs system, running from the USB, I am unable to get passthrough sound working via SPDIF. Is this a known Neo U1 issue?

    I have it using passthru fine from Android on this AVR.
    Basically my receiver is older, and doesn't support HDMI audio. So I have to run Optical to it.
    Right now LibreElec is set to output 2.0 with passthrough enabled for AAC and DTS. However when I play a multichannel video file with mutli channel audio, I'm stuck at PCM48 sound :-(

    In the Audio settings I have changed the device from ALSA AML-M8Audio, HDMI to PULSE default, Bluetooth Audio (PULSEAUDIO). When I do this I hear no audio at all.
    When using the ALSA AML-M8AUDIO, PCM option I get PCM48 to the receiver, no surround audio - exactly the same as when using ALSA AML-M8Audio, HDMI.

    One observation I have is that regardless of which of the 3 audio device options I choose, the Passthrough Device always says ALSA AML-M8Audio, HDMI and is greyed out so that I cannot change it.
    There does not seem to be an option for SPDIF or Optical in the audio settings.

    Before I install on my main system here, I'll need to be able to get multi-channel audio working, so any help greatly appreciated!
  13. uberduke

    uberduke New Member

    It might be easier to use UPnP library sharing from the upstairs U1 to synchronize library contents including watched/paused status with the downstairs U1. There should be plenty of info on the Kodi/LibreElec forums about setting it up but it is fairly simple to do.

    Duke
  14. rabrol

    rabrol New Member

    Thanks for the suggestion. I had previously run a MySQL database on my media server. It worked fine, but fanart etc could be slow to load... But yeah, I'm probably getting off-topic with the library stuff here. The Kodi & LibreElec forums are definitely the better place to discuss those.

    Main issue now is if the U1 supports SPDIF output when running LibreElec. That's what I haven't been able to make work yet - and if that doesn't, it will end up staying an Android box :-( I love the speed and responsiveness of LibreElec, so am hoping there is a way around this. Or maybe I'll just go out and buy a used AVR that can handle HDMI audio!!!
  15. uberduke

    uberduke New Member

    You're welcome. I didn't suggest MySQL as it is the more complicated option but if you've done so in the past, you should be fine. I always liked the simplicity of UPnP, though, it isn't perfect, either (nothing ever is).

    Right, passthrough seems to be one of those hot-button topics. Can't post the links here but there are huge discussion topics on the Kodi/LibreElec forums.
  16. Mahevka

    Mahevka New Member

    I have just bought a U1 and have loaded LibreElec from SD (7.0.3.012c temp sensor disabled with gxbb_p200_2G_1Gbit.dtb) boots into LibreElec fine but get no audio to HDMI - in the Audio Settings I just get "Bluetooth Audio (PULSEAUDIO)" which is greyed out, no ALSA options at all.

    I am familiar with LibreElec, just bought this box to replace a Revo that I have been running LibreElec on from the start of the project but the Revo has HW problems and its time to replace it.

    I have read the forums both here and on the LbreElec site but don't seem to have found the answer - am I missing something obvious?

    Update: After some playing around I have found that audio works on older versions of LibreElec something changed between 7.0.2.008-fix and 7.0.2.009. I rolled back to the version reported to be working earlier in this thread, 7.0.2.007, which worked fine. I then progressively updated till it broke which was when I updated to 7.0.2.009. Audio also not working on the 8.0 Beta versions which is a shame. I will report this in the LibreElec thread when I get time.

    Makes me a lot happier as I bought the box specifically to run LibreElec into a Yamaha AV system using passthrough - would have been pretty upset if it didn't work.

    BTW my Hardware is Rev 020c.
    Last edited: Jan 18, 2017
  17. drieksje

    drieksje New Member

    same problem here, no audio over HDMI(TX-SR608 Onkyo AV) latest build of Libreelec(12c), been searching for a week , back on Android now. hoping for an solution to fix it!!!
  18. getochkn

    getochkn Member

    Audio working fine here on latest 8.0 Beta running Kodi 17RC3 on LE from SD-card.

    And post in the LE forums, the dev for the 905 boxes doesn't check here, it's only 1 person who makes the ROM's.
  19. Sean369

    Sean369 Active Member

    I've been running librelec off a sd card since version 7 or 8 and no audio issues at all. Currently running 7.0.3.012c.
  20. drieksje

    drieksje New Member

    Tryed to run the 8.0 beta version(SD), diden't work(booting) stuck on the minix screen, do i need another SDcard or is there an other way to boot, the latest version that did work was the 12a(no audio)????