1. Welcome to the official forum for MINIX devices!

U1 doesn't find external hard drive

Discussion in 'NEO U1' started by Hadar Y, Nov 4, 2017.

  1. Hadar Y

    Hadar Y New Member

    I used to connect Seagate external drive of 1TB to one of the USB ports, and all was fine.
    This hard drive is USB3.
    suddenly (I didnt install any new app) the U1 dont find it. It dont apear in file explorer where it usually was listed, and other apps (music players, Kodi) dont find it as well.
    The hard drive is working as usual in my PC.
    A flash drive that I connect to same USB port in U1 is working.
    I updated to latest FW013 from 20170629, still the same...
    Anyone can help?
    Thank you
  2. Hadar Y

    Hadar Y New Member

    I tried to pull the cable a little backwards , as was suggested in other thread. It didn't help
  3. Hadar Y

    Hadar Y New Member

    file system in the Hard drive is NTFS
    (I checked it through windows file explorer. it still works without problems in my PC)
  4. Villa

    Villa Administrator Administrator

    HDD has external PSU?
  5. Hadar Y

    Hadar Y New Member

    PSU means power supply? Then answer is No. gets the power from USB cable
  6. Villa

    Villa Administrator Administrator

    Then the answer is, possibly it doesn't get sufficient power from the device?
    You should try using a powered USB hub.
  7. Hadar Y

    Hadar Y New Member

    The HDD have a led that lights when it is connected to pc/laptop.
    It does light with the U1. does it mean power is not the problem?
    Anyway i will look for such hub, though i didnt see such thing for long time. They were common when devices came with too few USB ports. Or you mean something different than the hub i talk about?
    Thanks for the help
  8. Villa

    Villa Administrator Administrator

    Powered USB hubs are still very common!
  9. David03

    David03 New Member

    I have a Seagate 6 TB HHD (powered) which functions as a hub and storage. The advantage is you gain extra usb ports to use. What's strange is that I can connect a 1 TB,2TB (non powered) HDD directly to the Minix usb ports and it recognizes the HHD's everytime without the hub.
  10. Hadar Y

    Hadar Y New Member

    Update:
    Power was not the issue in my case.
    I changed file system from NTFS to exFAT.
    The HDD works now.
  11. ninjastyle

    ninjastyle New Member

    U1 can read USB3 drives? I thought it was USB2 only
  12. skynet

    skynet Well-Known Member Trusted Helper

    USB3 drives are backward compatible with USB2, so you can plug USB3 devices on U1.
  13. Jun

    Jun New Member

    Try clearing cache data.. In settings >storage..works for me..

    Attached Files:

    Last edited: Dec 29, 2017
  14. Strazmadaz

    Strazmadaz New Member

    Hi I have the same problem. I understand what you are saying about the file ext. But I plugged in my Seagate drive from the begining and now six months later without any file changes of any kind it stops working ? My drive is externally powered. I even did the cable wiggling thing no luck.
    What I find interesting is that with aboslutly no changes to the hard drive it stops workng after six months. I tried another drive and I changed the cables to no luck