1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

u9h doesnt recognize external hard disk anymore

Discussion in 'NEO U9-H' started by PLAY911, Jul 20, 2017.

  1. MrBig

    MrBig Active Member

    :censored:
     
  2. Malcolm10

    Malcolm10 New Member

    Good day
    I have a similar problem, when I access my movies, music on a qnap ts431 Nas the Neo 9U does something that causes device not accessible error. I have to reset the Nas to regain access to it, when I do get in and check it warns me that the hard drive needs to be scanned and then repaired. I must mention that I have a PI3 with Kodi 17 and that work 100% also an xtreamer prodigy that also have no problems accessing the same drive in the Nas but as soon as in access the Nas with the Neo 9U this happens not always immediately. I have tested kodi 17.1 and 17.3 on the Neo 9U same problem, I have tested fw005 and fw004 same problem. I purchased the Neo 9U for the Dolby atoms and when it plays it performs beautifully until I get the unexpected not accessible errror.
    I know this is a difficult one, but other members also experience similar hard drive issues I will appreciate if this can be investigated please?
    Thanks for the very good support!!
     
  3. Dr Goodvibes

    Dr Goodvibes The Doctor

    You can talk tech to us.
    I'm old school and don't switch off if there is more than one sentence of technical detail. *sigh*

    But you might be the first to say you can't access media from a NAS.

    So, the Minix U9-H is placing an exclusive lock/corrupting the file index, such that the disk index has to be rescanned (on NAS restart) to correct the 'disk' (storage pool).
    That is frigg'n scary.
    What RAID type are you using, what QNAP fw are you running QTS 4.3?

    How does the U9-H access the TS-431(4xHDD) NAS? SMB?

    You sir have peaked my interest.
    I'm almost temp'd to attach my U9-H to the LAN to find out...like what the heck???

    If you lose access to the NAS it's more likely a Network and/or application configuration issue.

    None of my Minix boxes (U9-H included) have EVER corrupted my QNAP NAS RAID file systems.

    It scares me to think how that could even happen.

    This all sounds very dodggie to me.

    Update — Only time I could think a Mini box could invoke the requirement for a disk index to be rescanned after a NAS is restarted, is if the NAS was shut-down while the Minix box had an exclusive lock on a file that could not be released at the time of shut-down. Clean shut-down or forced shut-down of the NAS??

    I'm guessing you use Kodi for all your media access.
    AND it sounds like one is attempting to write media sourced via the Minix box, onto the NAS.
    That would be the slowest way to populate media onto a NAS, where the NAS probably has the tools to source the media directly.

    All my media is sourced from my NAS and my NAS populates/provides access to that media.

    I don't use a Minix box to populate media onto my NAS..... in any volume.

    My Minix box(s) are strictly client media consumers.

    I have never used Kodi to populate media/data onto my NAS and if I was doing that, it'd only be done over 1Gbit Ethernet.

    Just use Kodi for real-time TV(sourced via NAS TV adapter) and multi-channel HD BD videos..... until I find out if new MX player can do multi-channel audio DD/DTS.

    So not big on Kodi myself.










    Sent from my D5503 using Tapatalk
     
    Last edited: Aug 1, 2017
  4. medwatt

    medwatt Member

    I was just about to create a thread here regarding this same issue. I bought two U9 boxes. I was setting up one yesterday and everything went fine. Then I did an upgrade to the latest update. My 1TB USB powered stopped getting contacted. I thought this was a hard drive issue at first. I connected the HDD to my computer and there was nothing wrong with it. I tried it again on the U9: same problem. I then tried it on the second U9, which is still not updated to the lastest. It worked with no issues.
     
  5. mick1601

    mick1601 New Member

    I have a similar with a 4TB external HDD (unpowered). The U9-H picks it up without a drama, until a power failure....then I have issues. Plugging the HDD into my PC then ejecting it through the PC fixes this issue, though sometimes I have to do it more than once. What I have found that works even better is to use a cheap and nasty USB 3.0 hub. Plugging the HDD into the hub, then into the u9-h usb port results in the player picking it up without a drama. I hope this helps anyone else having this issue.
     
    MINIX - Martin and skynet like this.