1. Welcome to the official forum for MINIX devices!

Ubuntu 16 reboot hang

Discussion in 'NEO Z83-4 Alternate OS discussion' started by vatara, Nov 10, 2017.

  1. vatara

    vatara New Member

    I installed Ubuntu 16 on a Z83-4 and (most) things worked straight away. The one major problem is every time I try to reboot, Ubuntu goes through the shutdown process but the device never restarts. I don't see any obvious errors, it just stops at the shutdown log screen. I've tried changing the grub cmdline reboot option and it hasn't made any difference. Anyone had this problem and fixed it?
  2. nimoatwoodway

    nimoatwoodway New Member

    Hello Vatara! Same problem here with Ubuntu 14. Did you find a solution?
  3. vatara

    vatara New Member

    No, I haven't :(
  4. nimoatwoodway

    nimoatwoodway New Member

    Hey Vatara! Good News! I've just tried current Version of 16 LTS and now it just works! Without any modification! Since there was a bug in auto power on I also updated to last firmware.
  5. vatara

    vatara New Member

    Still have the issue here. I've done apt update/upgrade and nothing has changed.
  6. Dangagi

    Dangagi New Member

  7. MightyGorilla

    MightyGorilla New Member

    This is definitely still a problem with 16.04.3 LTS.
    acpi=force has no effect on this problem.
  8. MightyGorilla

    MightyGorilla New Member

    I realize Linuxium has worked out the process of building a custom iso to install from, which is great, but from what I understood- the primary reason for that was to get the WiFi & Bluetooth functioning, which are irrelevant to my particular needs, so I just wanted to go with a stock release.

    Ubuntu 17.10 does not suffer from this particular issue, but I'm expecting that updating the kernel on 16LTS to something closer to 4.13.0-16 would resolve this problem. From searches I came across, some suggested (possibly) it was the unrecognized WiFi hardware on the PCI bus that is botching up the shutdown process (although those posts were related to a different brand/model device...)

    I tried updating the kernel from 4.4.x on 16LTS to 4.8.x as well as 4.10.x, and 4.13.x, and sadly my Linux skills must be pretty bad, because I couldn't figure out why all of those attempts ended in a pile of mdadm and/or initramfs errors, finally dumping me to an initramfs shell prompt after it give up trying to find a root device.