1. Official MINIX forum

Tutorial UNBRICK X7 - The X7 is never dead!

Discussion in 'NEO X7 Guides & FAQs' started by HardwareGuru, Aug 26, 2014.

  1. HardwareGuru

    HardwareGuru Developer Administrator

    Hello Guys,

    Your X7 can be bricked after wrongly flashing Jellybean(4.2) rom when your previouse was a KitKat (4.4).
    Or any other reason ofcource..

    For this tutorial i forced the X7 to get bricked as you see in the video.
    I show you how it gets bricked too!
    Then you see it wont go into flashmode anymore :(
    Dead? Bricked? yes and no.... there is a way to raise it from its grave lol.

    Short pin 7 and 8 on the chip while pressing reset and powerbutton.
    This way it gets forced into maskrom mode!
    After you see the blue square on the flashtool unshort thepins and keep power and reset pressed!
    Press "RESTORE" on the flashtool.
    Yes your finger will hurt but KEEP POWER AND RESET PRESSED till the flash is fully done!

    Have fun

    Last edited: Aug 26, 2014
  2. Fuseau

    Fuseau New Member

    Your video came as a new hope for my Neo X7, but so far, I've not been able to bring it back to life:
    I've used the "Pin" technique so many times, with various flavors of Windows XP, 8, Linux. The box starts with a short flash of the SPDIF plug, then the USB primary handshake appears on my computer (it shows in the VMWare USB setup window) but I can never get passed the 7 seconds it stays connected.
    The flash tool never sees the minix, windows no longer asks for a driver:

    I've come to believe that the lowest level of the boot sequence is corrupted, isn't there any solution to re-inject the boot sequence or something like that back into the machine? It' so frustrating that I can't find any failsafe application from Rockchip that could help me out.
  3. gufone

    gufone Big Owl - Developer Super Moderator

    I've done this recovery many times and it should work. Are you sure that you have shurt cutted the right pins? If not your device might be really KO.
  4. TLM

    TLM New Member

    i tried this several times and cannot make this x7 detect RKTool. Light goes on and I follow your instructions.any other options?
  5. lardybarstow

    lardybarstow Member

    Hi after updating to the x7 gufone/guru collaboration I got into all sorts of trouble mainly the x7 switched itself off every few minutes, and when it was on could not play half the stuff it used too. I tried to go back but I believe I bricked it, I loaded what I thought was the original x7 firmware bit it came up no device found after I had the green square and chose restore using the firmware image, I tried reloading the gufone/guru image same result. Tried all the various techniques listed and was reluctantly about to pull the unit apart and follow the video, then I decided to try once more using the gufone/ guru for x7 got green square selected image all whilst I kept both power and reset button depressed it started to load but failed at the end but square was blue re started and held both power and reset to the whole firmware procedure finished and to my relief it loaded succesfully, its running still shutting down, many add ons for spmc not compatible, and my sign in for some sites say im signed in under another e-mail address and wont let me in bizarre...I have my main x8 on guru which is great so il sit and wait for update on this rom from gufone/guru especially after my noob attempt and going back to another rom lol.
  6. Higgs

    Higgs Yellow Dude Super Moderator

    Which firmware is your x7 on now? Try updating to fw010.

    Sent using Tapatalk
  7. HardwareGuru

    HardwareGuru Developer Administrator

    Please report your isues in our kitkat topic so we know what issues there are and we can try and fix it. Thnaks.. glad its up and running agian
  8. lardybarstow

    lardybarstow Member

    Im back on Guru/Gufone kit kat pre release 8gb, I am going to report in kit kat topic as requested good luck.
  9. Banditen-Sweden

    Banditen-Sweden Active Member Beta Tester

    Last time when i tried to get back from , i think it was HardwareGuru 5 0r 6. Things got fucked up. I ended up getting the red bar all the time. It even didn't work to press and hold reset and power button as i have done many times before. Then i tried the RKAndroidTool v1.37 and i got the Minix X7-4.4.2-build-miracle proper installed.
    Then i started the process over to get back to the latest original FW. Started the flash procedure and ended up with a red bar. Flashed again and hold both reset and power down. This time the bar was blue i think. Did the same shit again and this time the bar was green and fine. So now my Minix are up and running again. Thanks to a great forum.
  10. Zarko

    Zarko New Member

    HI HardwareGuru,
    I'm little bit confused, about unbricking neo x7, you say pin 7 and 8, but pins 7 and 8 are on the other side of that chip (H27UCG8T2BTR), not where you show here..on your youtube video you connect I/O5 and I/O4 (42,41) chip pins...On other sites people talking about connecting RB + R/E or R/E + CE pins (7+8 or 8+9) or connecting T4 and T5 points, but they are on the other side...I have the same box...or I have missed something?
    I also have minix neo5 mini and I connect it with pc win7 without any problems, but with neo x7 there is no way...I don't know what to do anymore...any suggestions please?
  11. garza

    garza New Member

    Hi all, running out of idea's regarding un-bricking x7, have tried your tutorial HG but to no avail, the problem I have is that It fails at (Layer 1-3 Download IDB) every time, I believe it went one further to (Loader) on one occasion but general ally fails at the afore mentioned.
    I'm loading an old firmware(2013-09-18 1080p) and using the auto driver installer downloaded from geekbuyings site, obviously I can't install the driver in the firmware package because windows does'nt see the x7 long enough( 7 second window) to install in the old way, any ideas?, was coming from wassers 1.0.4 kitkat rom and stupidly tried to go back to jelly bean without holding recover and power together.
  12. garza

    garza New Member

    Ok I can answer this myself now, I managed to reflash the wasser firmware and bring the x7 back from the dead, it did take a few attempts, but I managed to get the box up and running, I want to move to another firmware but I'll wait till a stable kitkat is released before attempting that again.( it definatly would not flash back to 4.2) hope this can help somebody in the same predicament.
  13. juleeugrl

    juleeugrl New Member

    good video it something to keep in mind
  14. Chris Hoekstra

    Chris Hoekstra New Member

    I had 2 minix X7's I bought from a coworker that were bricked. They both were completely dead with no blue light, no USB recognition within windows, and no power from the USB ports (wouldn't charge cell phone). By all intents and purposes these would normally go back with an RMA.

    However, using the pin 7-8 method I was able to get these both resurrected from the dead and now I have 2 extra minix X7's to give to friends and family. MUCH KUDOS for this!
    KAR likes this.
  15. JimLG

    JimLG New Member

    Hi, Like Zarko I am also trying to restore my bricked Neo X7 by following the tip here (Shorting pins 7 & 8 of the NAND IC), I'm being careful to get the correct pins, and I assume my board is a different version to the one in your video (note my PCB indicates it's Ver 2.1 Please refer to the included photo), as the chip pins 7 & 8 are located on the other side of the corner-most NAND IC?

    Therefore can someone please confirm that I should be shorting pins 7 & 8 of the FLAS2 IC (An H27UCG8T2BTR-BC) I have found tech info on the Flash IC here: [Sadly, I am not allowed to post links in this forum until I have become a more established forum member, So I could not include the file location, Yet]

    Clear information here would be appreciated, thanks.

    Attached Files:

  16. Chris Hoekstra

    Chris Hoekstra New Member

    I believe it isn't truly pins 7&8 but counting down from the top left of the bottom nand chip it is the 7th & 8th trace down. I just checked the screenshot I took of my boards and they also have the dimple bottom right but I used the top left and counted down 7 traces and it worked great.

    I would say you have the same board as I did based on your screenshot so you should be fine in shorting the pins you highlighted (top left 7&8).
  17. JimLG

    JimLG New Member

    Thank you Chris; I'm off to give it a try after a glass of wine ;)
  18. Chris Hoekstra

    Chris Hoekstra New Member

    Good luck and please report back on how it went!
  19. JimLG

    JimLG New Member

    So I have tried to complete the flashing process with the Rockchip batch Tool 1.7 (I have successfully done this previously for Quickshot ROM versions, So I feel confident in this part of the procedure) But I have never previously had to recover a bricked Neo X7, So am still learning here.
    I should point out that when the X7 was dead and even when the flash tool indicated that it was connected by USB it never gave a power indication from the Blue LED, The only light that comes on is a red light from inside the optical SPDIF connector, So I'm concerned that the X7 may be more seriously damaged; Having provided this information I can however say that the indications from the Rk-chip batch Tool were all good and went as shown in the tutorial vid (Using the Upgrade function to flash it),
    But at completion of the process with Quickshot V3.1 I still have a device that fails to boot or indicate a Power-on state via the Blue LED; Perhaps I should try flashing it with a current default version of Minx's own ROM before trying to Flash it with the Quickshot version?

    I'll included the the saved log file here next.

    Thanks in advance; Jim.

    Attached Files:

    Last edited: Jan 22, 2015
  20. Chris Hoekstra

    Chris Hoekstra New Member

    Yeah, the logs show all is good with the flash. I think you should definitely try other roms.

    I have found the Community Edition really stable and might be worth a try. At this point it won't boot up into an OS but does is it detected by windows when plugged in via USB? Try other ROM's and hopefully you can get it working again.

    And I would be careful with Minix default rom. Just make sure it is kitkat based (4.4.x) as if not it will brick it again.