1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Tutorial UNBRICK X7 - The X7 is never dead!

Discussion in 'NEO X7 Guides & FAQs' started by HardwareGuru, Aug 26, 2014.

  1. JimLG

    JimLG New Member

  2. Chris Hoekstra

    Chris Hoekstra New Member

    I think I had to do a restore instead of upgrade. I tried one and it gave an error but allowed me to remove my hands from reset and power buttons and then I flashed it using the other. I think it was restore I did first which had an error but got it to boot enough for windows connection then did an upgrade. Or vice versa. :)
    vn800art likes this.
  3. gaz

    gaz New Member

    Just unbricked my X7 using the "Community Edition". All went well . Chris H is correct regarding the location of pins"7 & 8". Thanks to all above for their input. And to save my fingers, I modified two plastic clothes pegs to hold the switches. . .worked like a charm.
    Cheers
    Gary

    Attached Files:

    Last edited: Jan 24, 2015
  4. Alvinyansg

    Alvinyansg New Member

    Keep getting "Wait for Loader fail" or "IDB download fail"

    Any idea what is the issue?
    Last edited: Jul 12, 2015
  5. Villa

    Villa Trusted Helper Super Moderator

    A little more info wouldn't go a miss!

    What is it you are doing? How?
  6. Alvinyansg

    Alvinyansg New Member

    sorry for the lack of details.

    Flashed my X7 to Kitkat (Version 240) a few days back and yesterday decided to flash back to 4.2.2(version 008).
    did not read up and flash is as per previously.
    my x7 was not able to keep connected in flash mode after that(around 10 secs max)
    did some searching and found this thread.
    followed the steps.
    however keeps getting "wait for loader fail" or "download idb fail"
    Last edited: Jul 12, 2015
  7. chapito

    chapito New Member

    Hello.
    I performed the following operation:
    - With the RKBatchTool - 1.7 I put in X7 in flashroom mode, pressing reset + power button.
    - When I X7 detects the computer, remove the reset button and continue pressing the power button.
    - Without releasing the power button I press "Restore" in the RKBatchTool and hope to finalize the installation.
    This operation I have performed several times and it always works.
    I hope you get back to version 4.2.2.
    A greeting.
  8. Villa

    Villa Trusted Helper Super Moderator

    http://www.minixforum.com/threads/downgrade-4-4-2-kitkat-to-4-2-2-jellybean-rockchip-only.5218/
  9. Alvinyansg

    Alvinyansg New Member

  10. isek7or

    isek7or New Member

    I hat to admit if it wasn't for my persistence I wouldn't have succeeded. Although I was correctly following the instructions from the beginning, for some reason my unit continued to disconnect after a few seconds. I recall I had to do something different in order for this process to work. If I recall, I had to hold the power button for only one second (or the needle/pin) in order for this to work. So if you are not able to complete the process on your first attempt, don't give up and try different combinations/durations when holding the power or the needle/pin (not talking about the pin location). By the way, the laundry clips/pegs work like a charm. Good luck.
    Last edited: Aug 2, 2015
  11. Villa

    Villa Trusted Helper Super Moderator

    What is a nidddle?
    How would you use a laundry clip? Don't get that!

    I can't make any sense of what you have written or how it will help anyone else!
    Can you please try and clarify your post.
  12. isek7or

    isek7or New Member

    You are correct. I meant to say needle and the laundry clips are called pegs. I edited my original post and hope that it makes more sense now. However, I figured since the step by step process has been previously explained, I didn't have to be technical. So I'm only sharing my feedback.
  13. Villa

    Villa Trusted Helper Super Moderator

    I know what a laundry clip is! I just don't understand why or what it's purpose is in this process?
    Am I missing something? Is it something that has been mentioned before?

    I am just trying to clarify your feedback! And yes you do not have to be technical, but you do at least have to make sense otherwise it isn't worth posting.

    This line gives the impression that you have not succeeded!
    "I hat to admit if it wasn't for my persistence I would have succeeded."
  14. isek7or

    isek7or New Member

    I wasn't sure if laundry clip was the correct term as English is not my first language. Gaz mentioned it earlier.
    Regarding the fist line on my original posting, I meant to say "wouldn't" so I apologize for the confusion (edited).
    Just to make you aware, it almost sounds you are in a mission. I personally believe this is not the right approach to encourage new members to participate. At this point, I am regret for even trying to help other minix customers having challenges with this specific issue. So please let me know if deleting my original post is the most reasonable resolution. Kind regards.
  15. vn800art

    vn800art Member

    @isek7or: keep on contributing, for me is always helpful to read about smbody else experience! And one can also refine his English language knowledge !
    Regards
    Alessandro
    isek7or likes this.
  16. Villa

    Villa Trusted Helper Super Moderator

    Just to make you aware! ;)
    Like you, I am a member of this community. I learn from other members, like yourself, to broaden my knowledge so as to be able to hand out more help, if I can. If I don't understand what a member has written I will question this, as other members do, until my understanding is met.

    I still don't understand the pegs! (n)

    Aswell as being a Member I also have the title of Moderator. And along with the other Moderators/Administrators, I have an added duty to keep the Forum on track, clean & tidy, making sense, etc...

    If you would like to see how some New Members participate and see the outcome read through this thread...
    http://www.minixforum.com/threads/audio-sync-issue-minix-neo-x8-h-plus-xbmc-local-video-files.6859/

    Please keep on contributing! (y)
    Do not delete your posts!
    isek7or likes this.
  17. isek7or

    isek7or New Member

    Thank you for your response. I used a sewing needle for the chip/flash and the pegs to hold the power (bottom right) and reset (top right) buttons during the process.

    https://www.google.com/search?q=minix x7 unasamble&client=safari&hl=en&prmd=sv&source=lnms&tbm=isch&sa=X&ved=0CAgQ_AUoAGoVChMIot7zyoaMxwIV0fSACh0uRgug&biw=320&bih=460#imgrc=_Z0HgyYrwjkfDM:

    For some reason, the process shown on the original video didn't work on my device. After several attempts I was able to succeed but I had to release the power or the reset button right after (instead of holding it) in order to keep my device showing connected to the pc.
    Hope I didn't make it more confusing.
    vn800art likes this.
  18. ilpleasu

    ilpleasu New Member

    Followed your procedure and wala it worked again. Don't know what version I'm on but hey the blue light is back on. Gonna go hook it back up to my pc and see what happens...thanks my friend.
    vn800art likes this.
  19. cloneman

    cloneman New Member

    I tried of bunch of things for one hour but none of them got me passed the 7-second of power on. However, there was this yellow jumper in the middle of the board which I removed and it stayed on permanently. I didn't have to hold any buttons when I removed this jumper.
  20. JohnX

    JohnX New Member

    ANOTHER TRICK
    there's another trick my friend Darren showed me... when the short-pin7-&-pin8 method doesn't seem to work. See Step 3... genius...:
    1. Take off the back cover and unscrew the board. Do not touch the board or components unecessarily, to avoid ESD.
    2. (optional) Move the autorestart jumper, marked green in image below. This forces a restart when power is reconnected to the device, without pressing the power button.
    3. Detach the CMOS battery lead, marked red below. Leave it unattached for a couple of minutes. Then replace the CMOS plug.
    20151210_112554.jpg

    4. replace the board in the case, screw it up and replace the cover.

    Then continue with the method of powering up with the recovery button pressed:

    5. On a PC, open the Rockchip Batchtool (v1.7) and browse to the required image

    6. Attach the mini-USB lead to the Minix.
    7. Insert the point of a pin or the end of a paper clip in the 'Recover' hole, then insert the power lead. (If you haven't enabled auto-power-on in step 2, you'll have to press Power now)
    8. The Rockchip display should show a blue or green square as shown:
    A blue square indicates the device is in 'maskROM mode', when it is tricked into thinking that there is no NAND chip available.

    9. Select 'Restore'. Hold the Recovery button while the process completes.
    10. If it fails the first time, remove and replace the power lead and repeat steps 7-9 but select 'Upgrade' this time.
    11. If that still fails, return to step 1 & repeat.

    good luck! Perhaps no 2 machines get bricked exactly alike, so you can never tel if this will work the same way again. All life's an adventure!
    KAR likes this.