1. Registration issues have now been resolved. New accounts are able to be created

Update from 20141213 to 20141224 fails installing - XBMC now unusable

Discussion in 'X8 - X8H Official Firmware 002' started by William81, Jan 8, 2015.

  1. William81

    William81 New Member

    My Minix X8-H fails installing the latest update. The upgrade from 20141015 to the firmware 002 as described in the first post went perfectly (after I had discovered the USB stick should be placed at the back of the box instead of at the right).
    Via the app System Update (or via the tool box at the top level) the latest update is discovered and downloading is also no problem. When I click ' Update Now' , it starts installing for a fraction of a second then it shows:

    IMG_0312.JPG

    I can move the up down arrows of my remote control, but I cannot select anything.
    Anyway, I have to unplug the power and reboot the system. Now I am in really trouble: I can not use the XBMC anymore. Every time I select a option in the main screen, like e.g. 'Settings': I get a black screen. i can then only use the 'back' button on the remote and then I am back again in the main screen.
    IMG_0314.JPG

    At randomly (after rebooting), the blue wall paper with the balls has changed to a totally black wallpaper:
    IMG_0315.JPG

    It looks to me the wallpaper is set to black (together with the fonts) when I select a sub option in the main screen. But I am only guessing here.

    I have also downloaded the upgrade and do a off-line upgrade by selecting the downloaded file, together with the parameter file. That gave the same result as described above.

    Please, any suggestions?
    (BTW the XBMC worked quite perfectly with the old release 20141015; sometimes it just crashed while playing, but compared to the situation now, that was not so bad.)
    Last edited: Jan 8, 2015
  2. smera

    smera Member

    Have you tried to reinstall XBMC?
  3. cool

    cool Active Member

    Buddy no worries factory reset the box once Every thing will be fine
  4. William81

    William81 New Member

    Thanks for the suggestion, smera. I have re-installed the new release via the Kodi web portal. It is now rebuilding my CD library of ~ 4.000 flac files and that takes a while. Unfortunately, cool, I read your post just after I had re-installed Kodi. Pressing a button is easier than what I have to do now. It looks it works faster than the previous version. I am curious that is still the case after having build that CD library. But anyways, thanks you both!
    cool likes this.
  5. jchoong

    jchoong New Member

    Williams81 - have you successfully installed and run Kodi Helix 14? I managed to install Helix 14, but when I tried to run the Fusion zip file (to run config wizard), it showed a script error. I reinstalled Helix 14 but the problem remains.

    I have not used this X8-H box for a few months; updating it now before passing it to my daughter.
  6. William81

    William81 New Member

    I did not have run the fusion zip file. I have downloaded the file from kodi.tv/download/ (instructions on: kodi.wiki/view/HOW-TO:Install_Kodi_for_Android). After installing it this way, I got release 20141213. After that I could install the latest release (20141224) via the ' System update' app. Now I am only facing the issue that the Kodi does not see my NAS servers on the (home) network (this worked flawlessly in the 20141015 release).
    So still something to work on ..
  7. jchoong

    jchoong New Member

    Thanks William81. I checked elsewhere and it is confirmed that Fusion is temporarily down.
  8. William81

    William81 New Member

    ur wlc. Anyway, for some reason the NAS servers on my home network were spontaneously visible, so creating the library I could start right away (took 5-6 hrs for ~ 2 TB flac files). Now I am trying to get fanart enabled again. We are getting one step ahead each time.
  9. William81

    William81 New Member

    Looks everything is solved now. I got a ' not enough memory' warning when I wanted to install an App, although ~ 500 MB was free on board and the App was only a few MBs. Anyway, I had used the on board memory as download directory for videos. After I have moved that path and it contents to the external USB memory and so freeing 10 GB, all problems were history.
    So, my advise is: at least leave several GBs free for the Kodi application.
  10. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Glad to know your problem is resolved.
  11. William81

    William81 New Member

    Hi Ken, so am I. Shouldn't this be taken up into the FAQs - that at least 2(?) GB should be free or Kodi? Kodi gave at random all kind of strange behavior and sometimes not. Strange behavior like: when selecting the sub menu (like under Video or Music or System) the screen went black or Kodi just did not start up. Having only 500 MB free memory did not ring a bell to me that could cause the problem, especially because no warning/error message was shown at all when starting Kodi.