1. Registration issues have now been resolved. New accounts are able to be created

Update Not Happenning

Discussion in 'NEO X8-H Plus' started by Nilesh Topiwala, Jul 3, 2017.

  1. Nilesh Topiwala

    Nilesh Topiwala New Member

    Hi,

    I have the Neo-X8H-Plus and am stuck on Android4.4.2 with Kernel Version 3.10.33 and build number KOT49H.20161222.

    Whenever I check on the OTA it always states that I am up to date

    Is there going to an update to Android 5? I have seen on the forum that there is an update but I cannot seem to get it OTA.

    I cannot update to Kodi Krypton as it needs Android 5.

    Please can some one advise.

    Many Thanks
    Nilesh
  2. Frederick_99

    Frederick_99 Well-Known Member Trusted Helper

    you have been a member for over 2 years...surely you should know how to look in the firmware release section for the x8h-plus and see how to install it :rolleyes:
  3. Nilesh Topiwala

    Nilesh Topiwala New Member

    Thank you for your reply. Unfortunately I am not as tech savvy as you are. In the past two years I have hardly been on the forum as I have had no issue with my box.
    But with no OTA happening I thought of coming here for help and advise.
  4. Villa

    Villa Well-Known Member Super Moderator

    There has already been an Android 5 BETA version and now there is an RC (Release Candidate) version. Next there will be an Official release.
    If you want to try the RC then you have to flash a full system image with the burning tool and a PC. If you wait for the Official release I expect you will have to do the same. I don't think it will be possible by OTA.

    http://www.minixforum.com/threads/x8-h-plus-lollipop-rc-firmware-june-2017.16633/

    An alternative to using the burning tool...
    http://www.minixforum.com/threads/flash-x8-h-plus-firmware-from-sd-card-using-burncardmaker.16646/
  5. Nilesh Topiwala

    Nilesh Topiwala New Member

    Many Thanks for your kind advise ...much appreciated. But just to confirm I am going to go to the below link......

    June 2017 update - release candidate firmware:Download link of X8H-PLUS Android Lollipop release candidate firmware:
    Download from MINIX forum server (Europe):http://www.minixforum.com/downloads/download.php?file=X8H_PLUS_LOLLIPOP_RC.rar

    Down load the rar file on my windows pc. ...

    And I will then follow the alternative method you have suggested above as I feel that might be more easier.

    Do I run the risk of bricking my device if there is a mistake on my part? Please could I have your thoughts.

    Many Thanks.
  6. cold iron

    cold iron New Member

    Way back in the TV access card days their where lots of forums on how to do it. I never seen anyone criticize for asking for help. Fred, if you don;t want to help then don't say anything. juts saying.
    Steve MacEwan likes this.
  7. Frederick_99

    Frederick_99 Well-Known Member Trusted Helper

    and exactly what is the point of your comment and where is your help....i pointed him to the right place..

    Villa likes this.
  8. Nilesh Topiwala

    Nilesh Topiwala New Member

    Thank you for your help guys. I successfully flashed the firmware. Signed into my google account. But when I go to google play I get the error:

    Error retrieving information from server [DF-DFERH-01

    Tried all the tricks, deleting data, deleting cache, factory resetting but still the same issue. Any ideas guys?

    Many Thanks