1. Registration issues have now been resolved. New accounts are able to be created

Upgrading from XBMC 13.3 to Kodi

Discussion in 'NEO X6' started by Bigmaxdaddy, Feb 7, 2017.

  1. Bigmaxdaddy

    Bigmaxdaddy New Member

    I purchased the Minix Neo X6 yesterday and am trying to install and set up Kodi. I tried downloading the latest version of Kodi from either my browser or Playstore and in both cases I got a "parsing" error. From what I can see, my device came preloaded with XBMC 13.3 Minix but most of the add-ons don't support any less than Kodi 14. I am very new with this, but generally pretty decent around computers so I am hoping this isn't entirely just "user error"! If I can't get it figured out on here, I will probably just return the box and try the expensive Nvidia Shield to see if it is easier to work with...
    Thanks,
    Marc


    Sent from my iPad using Tapatalk
  2. Villa

    Villa Well-Known Member Super Moderator

  3. Villa

    Villa Well-Known Member Super Moderator

    May I ask why you decided to buy the X6 and not a newer MINIX device?
    If you were to return the device have you not thought about swapping it for a MINIX NEO U1?
  4. Bigmaxdaddy

    Bigmaxdaddy New Member

    Thanks for your help - there was a significant price difference between this model and the others and I didn't know that it was because of this being an older model.


    Sent from my iPad using Tapatalk