1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

USB 3.0 Drive randomly disconnecting/reconnecting

Discussion in 'NEO Z83-4' started by le_hades, Dec 17, 2016.

  1. le_hades

    le_hades New Member

    Hi there:

    Just bought a Z83-4 and i'm having a problem with a usb 3.0 device.

    I'm using a 'Sandisk Ultra FIT USB 3.0 flash drive' formatted as NTFS as a secondary drive for the system and performance is more than okay (as good as can be expected from a 3.0 flash drive) but the drive keeps disconnecting/reconnecting randomly. Suddenly the drive disappears and instantly windows re-detects it and reappears. Obviously this makes it unusable if i'm writing/reading something to the drive at that exact moment...

    AFAIK I can't find a pattern:
    • It can work OK for a while, it can happen once or it can happen a couple times in a row.
    • It can happen while the system is idling or in use.
    • The drive works perfectly fine in 3 other different computers.
    Things I've tried and didn't work (after googling A LOT):
    • Updated the bios to the last 1.4 version.
    • Tried switching the bios setting about 'usb charging'.
    • Tried customizing the power plan in windows so USB devices can't be powered down nor disks shut down.
    • Tried modifying the usb controller settings under windows device manager so it can't be turned off to save energy.
    • Tried modifying the removal policy of the device from quick removal to performance under windows device manager.
    • Tried formatting it as a FAT32 drive.
    • Tried formatting it as a exFAT drive.
    I'm out of ideas and right now i don't know what else to do. any suggestions?

    Thank you in advance. Cheers

    EDIT 1: words, because english is not my first language
    EDIT 2: FAT32 is a NO-GO too
    EDIT 3: exFAT is a NO-GO too
     
    Last edited: Dec 17, 2016
  2. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    It's not actually disconnecting/reconnecting.
    It's redetecting (refreshing) somehow but there are no diconnections in between.

    Try to play a video of >2 hours, you will see. (We did tests like that to verify)

    We copied the same result on all Cherrytrail based machines.
    (We purchased a few samples of other brands and checked the same thing)

    It's driver related, not our hardware or BIOS.
    We've reported this problem to Intel.
     
  3. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Meanwhile, you may go to Power Options -> Advanced settings -> USB settings -> USB selective suspend setting -> Disabled.

    (But I guess you've tried it already)
     
  4. le_hades

    le_hades New Member

    I believe what you are saying about cherry trail to be true, i've read about this problem with USB 3.0 drives in several forums but i believe it does disconnect. It has happened to me while copying files and the copy failed because 'a file couldn't be found' which wouldn't happen if the connection was OK.
    Maybe due to the nature of video playing (buffering and such) a micro-cut on the connection doesn't affect it the same way and that passed your test.

    Indeed, that was the 'Tried customizing the power plan in windows so USB devices can't be powered down nor disks shut down.' bulletpoint

    More test show it doesn't happen with USB 2.0 pendrives, an external 3.0 HDD drive (Western Digital Elements 1TB) or some other USB 3.0 pendrives ( Transcend Jetflash 710 16GB )

    I'm... dumbfounded
     
  5. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Thanks for your feedback, we've reported this to Intel.
    During our tests conducted before, it appears that SanDisk USB 3.0 drives can copy this issue easily, but not Kingston, or Transcend.

    Check inside the USB 3.0 connector of the SanDisk USB 3.0 drives, the pin headers' structure is different from a normal USB 3.0 connector.
    You may compare and should understand what I'm talking about, maybe it's a clue.

    https://www.bleepingcomputer.com/fo...h-drive-constantly-disconnectingreconnecting/
    https://answers.microsoft.com/en-us...mb-drive/76c21073-6fba-4270-bd76-fdf903b490be

    When I said we copied the same result on other Cherrytrail platforms,
    I mean the same SanDisk drives copied the same problem across these platforms.

    Here is a thread discussing the stability issues with the Ultra Fit drives:
    http://forums.sandisk.com/t5/All-Sa...Fit-USB-3-0-Excessive-Heat/td-p/336404/page/2
    Many users pointed out the drives get really hot, slowing down, disconnecting...etc.

    Off-topic tip: You shouldn't format a flash drive to NTFS, it's not a proper filesystem for flash drive, you should do FAT32 for drives <=64GB, exFAT for drives >64GB. (No journaling, less overhead, less heat.)
     
  6. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    [​IMG]

    By the way, I bought this drive recently, and it runs EXTREMELY hot within minutes, so hot that you can't keep touching it for 2 seconds......
     
  7. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Been testing with a Kingston DataTraveler 100 G3 32GB drive for more than a day,
    zero pops on the port where the SanDisk Ultra Fit pops out all the time.

    DT32.jpg
     
  8. le_hades

    le_hades New Member

    I've been trying with other devices and i can't replicate the issue, seems to be some kind of problem with the Sandisk Ultra Fit Drive and the cherry trail platform, which is weird because:
    • It works perfect everywhere else
    • I have three of them: one on a skylake PC, one in the car mp3 player, one on a digital photo frame and all work OK
    • Other usb 3.0 devices seem to be using the exact intel driver and don't fail
    So I think I've found a solution... I have a lexar S75 drive coming in today, thank you Amazon Prime :LOL:

    I'll post again if i find anything else, otherwise thank you very much Ken. (y)
     
    MINIX - Ken likes this.
  9. le_hades

    le_hades New Member

    OK... this is officially stupid now, everything works, benchmarks and runs perfectly fine on 3 different computers but on the z83-4:
    • External USB 3.0 2.5" HDDs work (without additional power)
    • Internal 2.5" HDDs with USB 3.0 adapter work (without additional power)
    • Internal 2.5" HDDs with USB 3.0 adapter work (with additional power)
    • Any USB 2.0 pendrive works
    • Sandisk Extreme USB 3.0 works
    • Transcend Jetflash 710 3.0 works
    • Sandisk Ultra FIT USB 3.0 doesn't work
    • Lexar S75 doesn't work (it's almost worse than the FIT, usb 3.0 stop recognizing anything else until a couple reboots)
    The thing is both the Sandisk extreme and the Transcend Jetflash are being used elsewhere and the pendrives i have available do not work :sick:

    I've read elsewhere that a externally powered usb 3.0 hub may help, but i don't own one. Is that something you could test Ken?

    I'm ready to give up and stick in some crappy microsd and call it a day. :cry:
     
  10. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    We could test it but I don't think it's related because our port could supply 1.2A...
    There are lots of posts like this on Tom's, scroll down you can see many:
    http://www.tomshardware.com/answers...connected-reconnected-usb-work-great-usb.html

    People are suggesting the XHCI driver causing this kind of incompatibility.

    (I bought the S75 128GB for testing today, I'm beggining to worry after reading the critical reviews... amazon.ca/Lexar-JumpDrive-256GB-Flash-Drive/product-reviews/B00S5V5PTC/ref=cm_cr_arp_d_viewpnt_rgt?ie=UTF8&filterByStar=critical&reviewerType=avp_only_reviews&sortBy=helpful)
     
  11. le_hades

    le_hades New Member

    I'm sure the device is supplying enough power because in my tests it runs a laptop HDD through a SATA<->USB 3.0 adapter without auxiliary power perfectly fine.

    I understand and I've read all about the XHCI driver but I've read also a lot of people talking about usb hubs working for them, so sadly I think it's the last test i can do.

    Meanwhile, about the S75... build quality isn't the best (very very 'plasticky') but speed-wise is going strong. It's nowhere close to the sandisk extreme but that is one of the fastest traditional usb drives you can buy (outside of ssd usb's).

    We'll see how long it lasts, but at 64GB/12€... i can deal with it. If only it would work with the Z83... :mad:
     

    Attached Files:

  12. le_hades

    le_hades New Member

    Okay... SOLUTION: use a freaking USB 3.0 hub...

    Today i borrowed one from a coworker... crappy one at that.
    It's a 4*USB3 + 3*USB2 thing that can work with or without auxiliary power as especified by the manufacturer.
    As I said I didn't fault the device power output so I tried everything without external power and then repeated some tests with it (which gave the same results).
    • As soon as i connected any of the problematic drives through the HUB (Lexar S75 or Sandisk Ultra FIT) they both worked perfect: no disconnects, no pop-ups, no anything. Not even under benchmarking (heavy loads would show faults easier before) and there wasn't much performance hit either.
    sandisk_hub_nopower.png
    • Then stepped it up to 3*3.0 drives benchmarking at the same time (Sandisk Extreme + Lexar S75 + Sandisk Ultra FIT)... everything perfect again.
    extreme-s75-fit_hub_nopower.png
    • Went back to direct connection and both drives started showing disconnects again.
    • Last test was the definitive one... all ports benchmarking at the same time 4*USB3 + 3*USB2 drives. Everything worked like a charm, no disconnects whatsoever and surprisingly consistent speeds:
    full_equipe_2.png
    full_equipe_1.png
    So, my advice is get a USB 3.0 HUB and check for yourself, I am pretty sure it's the drivers fault, maybe using an external hub instead of the one built in the mobo changes something but i'll be getting one in the mail on friday. expect final confirmation.

    Cheers.
     
    Last edited by a moderator: Dec 21, 2016
  13. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Thanks for your report!
    It's really helpful.
     
  14. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    The Lexar drive arrived... using Windows 14393, it's not even detected directly, but working via a hub, like you said.
    Reinstall older Windows 10586... drive detected straight away without hub...

    Something wrong with these 2 drivers: USBXHCI.SYS / USBHUB3.SYS , both Microsoft drivers... changed during upgrading to Anniversary Edition...

    Need to investigate further. :)
     
  15. le_hades

    le_hades New Member

    I tested the hub I bought and I can confirm that the hub workarround indeed works, i bought on amazon a "4-Port Ultra-Slim USB 3.0 Hub" from Anker which works great (no external power)

    While microsoft sorts out their mess of drivers i'm not going to downgrade and lose the security patches/fixes so.. hub it is.

    Thank you Ken again for your time, if you feel this may be useful info for other users/time feel free to pin the thread.
     
    MINIX - Ken likes this.
  16. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Have made it sticky, thanks.
     
  17. Gianlucas

    Gianlucas New Member

    Hi all!
    I have some problem with this product
    RaidSonic ICY BOX HDD Dock 2.5"/3.5", USB3/SATA Dual, Nero

    There are new driver for USB 3.0???
     
    Last edited by a moderator: May 10, 2017
  18. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    No, Microsoft created these drivers.
     
  19. buildbanner

    buildbanner New Member

    all of this can be solved by going to the control panel and
    Control Panel\Hardware and Sound\Power Options\Edit Plan Settings

    then go to advanced power settings and go to the USB Settings
    there should only be one setting which says "USB selective suspend setting"
    disable that.
    I haven't received any problems after doing this, and its a simple fix.
     
  20. le_hades

    le_hades New Member

    This didn't work back then, i'm 100% sure of it because it was one of the first things i tried. Maybe a recent driver or w10 update has changed the behaviour.

    In any case, it's good to know. Thank you