1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

USB 3.0 Drive randomly disconnecting/reconnecting

Discussion in 'NEO Z83-4' started by le_hades, Dec 17, 2016.

  1. srjuanjo

    srjuanjo Member

    The same happens to me, but I have connected an SD card, it is disconnecting by itself, is annoying because I have applications installed on it and them freeze when the SD disconnect.
    Any ideasÇ thanks
     
  2. miguel87

    miguel87 New Member

    Hi! I'm a happy Minix new user, just discovered this brand.

    Same problem here with USB 3.0 HDD Toshiba Canvio Basics 1TB. Well, almost the same. It only disconnects (and fires unplug windows sound) while playing videos, no problem while copying files or downloading torrents. I've already tried to do the general recommendations about USB power saving settings. It works OK if I plug the HDD to a USB 2.0 port.

    It doesn´t seem to be the same issue as le_hades, but maybe. Should I try buying that Anker HUB? I can't borrow one to try first.

    Thank you.
     
  3. BadProduct

    BadProduct New Member

    Another annoying thing for this product.

    I think because of its compact package, its circuit is very sensitive to surrounding electromagnetic/RFI/etc. Try not to plug any other devices generating such intense electrical disturbance, especially notebook's adapters. In my case, having notebook's adapter plugged in the same extension-plug with the USB hard drive's plugs always makes the USB hard drives unstable.

    Also, if possible, you may attach the ferrite-bead to every USB cable in your system.
     
  4. Markus88

    Markus88 New Member

    I suspect I've been having this problem as well, with my USB 3.0 docking station with two 4TB drives attached. Glad to have (probably) found the cause, at least. For now, I've moved the connection over to a USB 2.0 slot. Hopefully this proves to be a fix, for the moment.

    Any word on an official fix?
     
  5. Markus88

    Markus88 New Member

    I'm sorry to double post and bump this, but I'm still stuck with a Minix that does not have a fully functional USB 3.0 port, which is a real bummer. So please: is there any news on this?
     
  6. Markus88

    Markus88 New Member

    It seems as though the 1.7 bios update solved this issue. I cannot say with 100% certainty because there is strangely no changelog, but I have had zero disconnects since the update. I did choose usb 2 over 3 for my usb 3 external hdd dock, but even on usb 2 I was getting cut-outs, though less often so. Will switch back to usb 3 and continue monitoring.
     
  7. Markus88

    Markus88 New Member

    Usb 3.0 still unreliable, usb 2.0 works 99% of the time, but just had another cut-out. What's the word, Minix? I'm very close to claiming warranty on this.
     
  8. skynet

    skynet Moderator Moderator

    Many users reported it's working fine with a small powered USB hub.
     
  9. Markus88

    Markus88 New Member

    The external dock that's losing connectivity has its own power supply.