1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

USB audio stream corrupted

Discussion in '[Bugtracker] NEO X8/X8-H 002 beta 8 firmware' started by Damir, Sep 6, 2014.

  1. Damir

    Damir New Member

    I'm using X8-H with external USB DAC:

    manufacturer: Head 'n' HiFi
    model: ODAC RCA
    compliant: USB 2.0 Full-Speed
    interface: USB Audio Class 1.0
    bit depth: 16/24
    sampling: 8/16/32/44.1/48/96 kHz
    chipset: Tenor TE7022/Sabre ES9023

    It basically works, but the audio quality is severely impaired - occasionally (few times per second, randomly) there comes a 'pop' sound, clearly audible on certain audio passages (e.g. orchestra music). It doesn't happen on silent passages, loud passages mask them below audibility, but anyhow it's far from acceptable. It happens playing both video and audio files. It's the same with stock firmware and latest 002 beta 8 (not rooted). Player doesn't matter (XBMC/4K/MX player/ES player...), software/hardware decoder (with MX player) doesn't matter, either. ODAC connected to my PC works fine.

    As the X8 headphone output is not exactly audiophile quality, it's important to me (and hopefully others) to have an external DAC option. Didn't tried TOSLINK yet, but the bit perfect USB stream will be greatly appreciated.
  2. WeK05

    WeK05 Audio Visual Master Specialist

  3. Damir

    Damir New Member

    Thanks for the input, WeK05. I installed Neutron, but the result is identical. It allows audio engine selection (Settings/Audio hardware/Use generic driver), both OpenSL and AudioTrack give the same popping sound. However, headphone out doesn't show the same problem, so bug is not in the audio engine itself, but rather in the USB driver. Also, Neutron reports 16 bit output, that means it probably can't recognize 24 bit ODAC.
  4. WeK05

    WeK05 Audio Visual Master Specialist

    Interesting... I do not have a USB DAC to test. I tried an old Edirol UA-1EX device. It wasn't recognized.