1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

USB not working.

Discussion in 'NEO Z83-4' started by VadisH, Jan 1, 2018.

  1. VadisH

    VadisH New Member

    Hello, suddenly my usb stoped working on my Z83-4. I use external hard drive on my usb3 and on other ports: air mouse and wireless mouse+keyboard. Nothing of them works now.
    If i connect or disconnect any usb device windows makes no sound, so connection is not recognized, but when i connect my external hard drive it has blue light on and i hear that it works, so electricity is getting there.
    Tried to connect another usb stick but no luck.
    I can control my Minix via remote access.
    I've found out that on Device manager my usb it has yellow triangle, (screen shot provided) saying it has error code 10.
    Tried to uninstall and reinstall usb drivers but it says the best drivers for my device is already installed.
    Trying to avoid windows reset via settings cause then I won't be able to use my minix via remote control.
    Can you please advise me on what to do next? Maybe you can give me different usb drivers I can try to install?

    Thank you.
     

    Attached Files: